Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#45439 - [mkvtoolnix-gtk] The new GUI is missing

Attached to Project: Arch Linux
Opened by Okki (okki) - Tuesday, 23 June 2015, 18:33 GMT
Last edited by Maxime Gauduin (Alucryd) - Sunday, 11 October 2015, 14:20 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Giovanni Scafora (giovanni)
Maxime Gauduin (Alucryd)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 21
Private No

Details

hello,

On the official website, we can read : « I’ve released MKVToolNix v8.0.0. A ton of work has gone into the new GUI, MKVToolNix GUI, which is now officially the GUI to use. The old GUI is now marked as being deprecated (it will show a warning about that when you start it) and will be removed within the next two releases. »

https://www.bunkus.org/blog/

But I can't find the binary mkvtoolnix-gui in the package, which contains only the old mmg, which displays the deprecated message.


Additional info:
* mkvtoolnix-gtk 8.0.0-1
This task depends upon

Closed by  Maxime Gauduin (Alucryd)
Sunday, 11 October 2015, 14:20 GMT
Reason for closing:  Fixed
Additional comments about closing:  8.4.0-2
Comment by Ma Jiehong (jiehong) - Monday, 13 July 2015, 17:21 GMT
I can confirm that, still with version 8.1.0, so the warning should be effective next version, worst case scenario.

Here is the warning message displayed:

> Please note that this program (mkvmerge GUI) is deprecated and will be removed within one or two releases. It has been superseded by the new MKVToolNix GUI which should also be included in the same package.

In the code repository, the new gui seems to be "mkvtoolnix-gui": https://github.com/mbunkus/mkvtoolnix/tree/master/src/mkvtoolnix-gui

However, it clearly seems to be based on Qt instead of Gtk.
Comment by Moritz Bunkus (mbunkus) - Monday, 13 July 2015, 17:34 GMT
That is correct (I'm the author of MKVToolNix and can comment on this with authority). The new GUI (mkvtoolnix-gui) is the recommended as of 8.1.0 and will replace the old one (mmg) which will be removed soonish.

The new GUI requires Qt. mkvinfo's GUI comes in two flavors as well with the Qt version being preferred over the wxWidgets one if both libraries are found.

See https://www.bunkus.org/blog/2015/05/mkvtoolnix-v7-9-0-released/ for an explanation of configure's switches wrt. the GUIs. By default mkvtoolnix-gui and the Qt port of mkvinfo's GUI will be built if the Qt libraries are found and mmg will be built if wxWidgets is found.
Comment by prettyvanilla (prettyvanilla) - Sunday, 20 September 2015, 17:04 GMT
With the release of version 8.4.0 the wxWidgets-based GUI has now been removed completely (https://www.bunkus.org/blog/2015/09/mkvtoolnix-v8-4-0-released/), which means that the current mkvtoolnix-gtk package only contains the mkvinfo-gtk program now and no GUI for the mkvmerge functionality. Therefore a new package mkvtoolnix-qt or mkvtoolnix-gui will be needed.
Comment by Moritz Bunkus (mbunkus) - Sunday, 20 September 2015, 17:15 GMT
That's not 100% correct. The whole wxWidgets-based code has been removed. Therefore if mkvinfo 8.4.0 has been built with GUI support then it's actually the Qt GUI.

I second that the package should be renamed from mkvtoolnix-gtk to mkvtoolnix-gui or mkvtoolnix-qt or something like that – in addition to the modifications required for packaging the Qt-based GUIs, of course.
Comment by prettyvanilla (prettyvanilla) - Sunday, 20 September 2015, 17:25 GMT
True, actually the way it's currently packaged, the mkvtoolnix-gtk package provides the exact same mkvinfo binary as the mkvtoolnix-cli package (it's just being renamed to mkvinfo-gtk at packaging time) and a few empty man-page directories.
So the PKGBUILD definitely needs a rework (I can look into it tomorrow if wanted/needed).
Comment by Benjamin Robin (benjarobin) - Monday, 21 September 2015, 22:59 GMT
Here a corrected version of the PKGBUILD : http://pastebin.com/rbBiZdwJ
Comment by Benjamin Robin (benjarobin) - Tuesday, 22 September 2015, 12:33 GMT
There are already 2 bug report referencing this one : #24532 and #44948
Comment by Moritz Bunkus (mbunkus) - Tuesday, 22 September 2015, 12:43 GMT
On behalf of other Arch users: thanks for the PKGBUILD, Benjamin. As Arch Linux is my primary development platform I'm pretty certain of the following minor issues:

1. Defining -DBOOST_FILESYSTEM_VERSION=3 is not necessary.
2. Defining -DBOOST_CODECVT_DO_LENGTH_CONST=const is not necessary; that bug has been fixed in 8.1.0 already.
3. Boost can be found just fine without passing --with-boost-libdir=/usr/lib to configure.
4. The build can be sped up slightly by only building mkvinfo in the first step instead of the whole package. For this build with »./drake apps:mkvinfo« instead of simply »./drake« (line 44).
Comment by Benjamin Robin (benjarobin) - Tuesday, 22 September 2015, 17:53 GMT
The updated version of the PKGBUILD : http://pastebin.com/rtguGrbR
Thank you Moritz Bunku :-)
Comment by Bruno Pagani (ArchangeGabriel) - Tuesday, 22 September 2015, 18:08 GMT
The question is why giovanni is still ignoring these 3 issues. Currently the package is really broken while they have been warning about this for quite a long time now…
Comment by Benjamin Robin (benjarobin) - Tuesday, 22 September 2015, 18:57 GMT
I really hope that he just does not have the time to manage theses bugs, that's why I made the PKGBUILD. But in this case it should not be maintainer...
I am going to wait until the weekend, then I am going to write to the mailing list.
Comment by Benjamin Robin (benjarobin) - Sunday, 27 September 2015, 20:59 GMT
Sadly, updating the Severity of this bu report will not help...
I did sent an email on the mailing list : https://lists.archlinux.org/pipermail/arch-general/2015-September/039909.html

Loading...