Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#45204 - [lib32-qt4] [skype] Skype immediately crashes after launch

Attached to Project: Community Packages
Opened by Alexandru Moise (AlexanderMoses) - Thursday, 04 June 2015, 16:26 GMT
Last edited by Florian Pritz (bluewind) - Saturday, 06 June 2015, 08:44 GMT
Task Type Bug Report
Category Packages: Multilib
Status Closed
Assigned To Florian Pritz (bluewind)
Sven-Hendrik Haase (Svenstaro)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 52
Private No

Details

Description:

I just updated to lib32-qt4-4.8.7-1 and skype will not launch anymore, (Core dump).


Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Florian Pritz (bluewind)
Saturday, 06 June 2015, 08:44 GMT
Reason for closing:  Fixed
Additional comments about closing:  lib32-qt4 4.8.7-2
Comment by Alexandru Moise (AlexanderMoses) - Thursday, 04 June 2015, 17:18 GMT
I downgraded with:
pacman -U /var/cache/pacman/pkg/lib32-qt4-4.8.6-4-x86_64.pkg.tar.xz

Now it works fine
Comment by Alexandru Moise (AlexanderMoses) - Thursday, 04 June 2015, 17:40 GMT
Sorry for the duplicate but I've opened the issue again on the qt package so it appears on their reported bugs list:

https://bugs.archlinux.org/task/45205?project=1&cat%5B0%5D=2&string=qt4
Comment by Ilias Stamatis (Ilias95) - Thursday, 04 June 2015, 17:51 GMT
Rebuilding skype against the new lib32-qt4, does not work.
Comment by Alexandru Moise (AlexanderMoses) - Thursday, 04 June 2015, 17:56 GMT
I generated a core dump with gdb if it helps anyone:

http://www.megafileupload.com/22Z4/core.4399
Comment by Florian Pritz (bluewind) - Thursday, 04 June 2015, 18:42 GMT
Please create a backtrace rather than a core dump on some OCH.
Comment by Alexandru Moise (AlexanderMoses) - Thursday, 04 June 2015, 18:57 GMT
(gdb) run
Starting program: /home/obsrwr/Downloads/skype/skype-4.3.0.37/skype
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[New Thread 0xee4feb40 (LWP 3538)]
[New Thread 0xe61fdb40 (LWP 3553)]
[New Thread 0xe69feb40 (LWP 3552)]
[New Thread 0xe72ffb40 (LWP 3551)]
[New Thread 0xe7cfbb40 (LWP 3550)]
[New Thread 0xe84fcb40 (LWP 3549)]
[New Thread 0xe8cfdb40 (LWP 3548)]
[New Thread 0xe94feb40 (LWP 3547)]
[New Thread 0xe9cffb40 (LWP 3546)]
[New Thread 0xea8ffb40 (LWP 3545)]
[New Thread 0xeb2ffb40 (LWP 3544)]
[New Thread 0xebcffb40 (LWP 3542)]
[New Thread 0xec6ffb40 (LWP 3541)]
[New Thread 0xed0feb40 (LWP 3540)]
[New Thread 0xed8ffb40 (LWP 3539)]
[New Thread 0xeecffb40 (LWP 3537)]
[New Thread 0xef6ffb40 (LWP 3536)]
[New Thread 0xf00ffb40 (LWP 3535)]
[New Thread 0xf0affb40 (LWP 3534)]
[New Thread 0xf14ffb40 (LWP 3533)]
[New Thread 0xf1effb40 (LWP 3532)]
[New Thread 0xf2843b40 (LWP 3531)]

Program received signal SIGSEGV, Segmentation fault.
0xf75b5a8f in ?? () from /usr/lib32/libQtWebKit.so.4
(gdb) bt
#0 0xf75b5a8f in ?? () from /usr/lib32/libQtWebKit.so.4
#1 0xf75b55a1 in ?? () from /usr/lib32/libQtWebKit.so.4
#2 0xf6bf5328 in ?? () from /usr/lib32/libQtWebKit.so.4
#3 0xf6d46b9d in ?? () from /usr/lib32/libQtWebKit.so.4
#4 0xf6d8f33c in ?? () from /usr/lib32/libQtWebKit.so.4
#5 0xf6d8f398 in ?? () from /usr/lib32/libQtWebKit.so.4
#6 0xf6d67a47 in ?? () from /usr/lib32/libQtWebKit.so.4
#7 0xf6d7a5ce in ?? () from /usr/lib32/libQtWebKit.so.4
#8 0xf6d8ce78 in ?? () from /usr/lib32/libQtWebKit.so.4
#9 0xf6db7248 in ?? () from /usr/lib32/libQtWebKit.so.4
#10 0xf6dd4aa1 in ?? () from /usr/lib32/libQtWebKit.so.4
#11 0xf6f27a0e in ?? () from /usr/lib32/libQtWebKit.so.4
#12 0xf6f27b4e in ?? () from /usr/lib32/libQtWebKit.so.4
#13 0xf6da29d8 in ?? () from /usr/lib32/libQtWebKit.so.4
#14 0xf74d3ff9 in ?? () from /usr/lib32/libQtWebKit.so.4
#15 0xf74d52f9 in ?? () from /usr/lib32/libQtWebKit.so.4
#16 0xf6f6f328 in ?? () from /usr/lib32/libQtWebKit.so.4
#17 0xf6f701d4 in ?? () from /usr/lib32/libQtWebKit.so.4
#18 0xf6f6bc3f in ?? () from /usr/lib32/libQtWebKit.so.4
#19 0xf6f6be74 in ?? () from /usr/lib32/libQtWebKit.so.4
#20 0xf6f4e8a8 in ?? () from /usr/lib32/libQtWebKit.so.4
#21 0xf6f4faa9 in ?? () from /usr/lib32/libQtWebKit.so.4
#22 0xf747679c in ?? () from /usr/lib32/libQtWebKit.so.4
#23 0xf6ffdb1c in ?? () from /usr/lib32/libQtWebKit.so.4
#24 0xf6ff5181 in ?? () from /usr/lib32/libQtWebKit.so.4
#25 0xf6c587ec in ?? () from /usr/lib32/libQtWebKit.so.4
#26 0xf6ff5ffd in ?? () from /usr/lib32/libQtWebKit.so.4
#27 0xf701fdc9 in ?? () from /usr/lib32/libQtWebKit.so.4
#28 0xf70320e9 in ?? () from /usr/lib32/libQtWebKit.so.4
#29 0xf7021cf7 in ?? () from /usr/lib32/libQtWebKit.so.4
#30 0xf7031331 in ?? () from /usr/lib32/libQtWebKit.so.4
#31 0xf725f125 in ?? () from /usr/lib32/libQtWebKit.so.4
#32 0xf7261422 in ?? () from /usr/lib32/libQtWebKit.so.4
#33 0xf72622bd in ?? () from /usr/lib32/libQtWebKit.so.4
#34 0xf7262370 in ?? () from /usr/lib32/libQtWebKit.so.4
---Type <return> to continue, or q <return> to quit---
#35 0xf7262753 in ?? () from /usr/lib32/libQtWebKit.so.4
#36 0xf7262a89 in ?? () from /usr/lib32/libQtWebKit.so.4
#37 0xf575ee5b in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib32/libQtCore.so.4
#38 0xf57b1bd2 in QIODevice::readyRead() () from /usr/lib32/libQtCore.so.4
#39 0xf57b1d40 in ?? () from /usr/lib32/libQtCore.so.4
#40 0xf575cd7a in QMetaCallEvent::placeMetaCall(QObject*) () from /usr/lib32/libQtCore.so.4
#41 0xf5764f61 in QObject::event(QEvent*) () from /usr/lib32/libQtCore.so.4
#42 0xf5b4ff8a in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib32/libQtGui.so.4
#43 0xf5b571c1 in QApplication::notify(QObject*, QEvent*) () from /usr/lib32/libQtGui.so.4
#44 0xf5749bba in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib32/libQtCore.so.4
#45 0xf574d316 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib32/libQtCore.so.4
#46 0xf574d645 in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib32/libQtCore.so.4
#47 0xf577c0a3 in ?? () from /usr/lib32/libQtCore.so.4
#48 0xf4fcf709 in g_main_context_dispatch () from /usr/lib32/libglib-2.0.so.0
#49 0xf4fcf9a9 in ?? () from /usr/lib32/libglib-2.0.so.0
#50 0xf4fcfa74 in g_main_context_iteration () from /usr/lib32/libglib-2.0.so.0
#51 0xf577c1f5 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib32/libQtCore.so.4
#52 0xf5c07f46 in ?? () from /usr/lib32/libQtGui.so.4
#53 0xf574829f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib32/libQtCore.so.4
#54 0xf574862e in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib32/libQtCore.so.4
#55 0xf574e696 in QCoreApplication::exec() () from /usr/lib32/libQtCore.so.4
#56 0xf5b4e454 in QApplication::exec() () from /usr/lib32/libQtGui.so.4
#57 0x5680387b in ?? ()
#58 0xf522b637 in __libc_start_main () from /usr/lib32/libc.so.6
#59 0x567f6739 in ?? ()
(gdb)
Comment by Alexandru Moise (AlexanderMoses) - Thursday, 04 June 2015, 19:52 GMT Comment by Vincenzo Maffione (vmaffione) - Friday, 05 June 2015, 13:52 GMT
I experienced the same, and solved by downgrading lib32-qt
Comment by Jordan Pavlov (digitalblade) - Friday, 05 June 2015, 14:29 GMT
Are you 100% sure it's in the QT package? Here is my output from skype.
[code]
(skype:4110): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",

(skype:4110): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",
Gtk-Message: Failed to load module "atk-bridge"
Aborted (core dumped)
[/code]
Could the problem be in an import of atk-bridge.h or the at-spi2-atk package?
In any case if downgrade the QT package resolve the error then it should be a QT Problem.
I can confirm that the downgrade worked.

Edited:
Yes I am sorry about this. This warning is given even is skype starts normally. Should have nothing to do with at-spi2-atk. I just never noticed it till now.
Comment by Alexandru Moise (AlexanderMoses) - Friday, 05 June 2015, 14:59 GMT
@Jordan
I am unsure if this is an actual QT problem, but it certainly does not appear in the previous package version.
Also from my backtrace just reminded me of previous bugs I've seen that had people complain about that area.
I am not a Qt developer so I'll refrain from voicing an opinion on the matter.
Comment by Andrea (soul_rebel) - Friday, 05 June 2015, 20:56 GMT
Exactly same thing happens to me.
Comment by Florian Pritz (bluewind) - Friday, 05 June 2015, 22:49 GMT
Please refrain from posting "me too" comments unless you have anything to add that can help narrow the issue down. Thanks.
Comment by Florian Pritz (bluewind) - Saturday, 06 June 2015, 08:30 GMT
Please test lib32-qt4 4.8.7-2.
Comment by Alexandru Moise (AlexanderMoses) - Saturday, 06 June 2015, 08:34 GMT
Updated to lib32-qt4 4.8.7-2 and it works with no problems.
Comment by Max Ammann (maxammann) - Saturday, 06 June 2015, 08:38 GMT
Same here. For everyone who hasn't the old lib laying around: http://seblu.net/a/arm/packages/l/lib32-qt4/lib32-qt4-4.8.6-4-x86_64.pkg.tar.xz

EDIT: k, lib32-qt4 4.8.7-2 fixed it, had an out-dated mirror
Comment by Alexandru Moise (AlexanderMoses) - Saturday, 06 June 2015, 08:39 GMT
No point downgrading now that the issue is fixed.

Loading...