Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#45067 - [dwb] crashes with webkitgtk2 version 2.4.9-1 (and doesn't build)

Attached to Project: Community Packages
Opened by Stephen Chang (stephenchang) - Sunday, 24 May 2015, 08:24 GMT
Last edited by Eli Schwartz (eschwartz) - Thursday, 03 August 2017, 23:09 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No

Details

Description:

Update to version 2.4.9-1 crashes browsers, namely dwb. Downgrade to 2.4.8-2 fixes the issue. This issue occurs on both multiple machines with different browser configurations.

Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
Install webkitgtk2 2.4.9-1 and launch browser using webkitgtk2
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Thursday, 03 August 2017, 23:09 GMT
Reason for closing:  Won't fix
Additional comments about closing:  dwb and webkitgtk2 were dropped from the repos: https://lists.archlinux.org/pipermail/ar ch-dev-public/2017-January/028634.html https://lists.archlinux.org/pipermail/ar ch-dev-public/2017-June/028900.html
Comment by Jan Alexander Steffens (heftig) - Sunday, 24 May 2015, 15:30 GMT
Works for me.
Comment by Doug Newgard (Scimmia) - Sunday, 24 May 2015, 15:54 GMT
Possibly (probably?) related:  FS#45057 
Comment by Martyn Yates (martynjy) - Sunday, 24 May 2015, 22:17 GMT
I can confirm that webkitgtk2 2.4.9-1 causes dwb browser to crash when starting it. And that downgrade to 2.4.8-2 corrects it. I am using linux 3.14.43-2-lts (i686).
Comment by g0re (g0relike) - Thursday, 28 May 2015, 01:17 GMT
luakit works out of the box

I compiled dwb using -Os -march=i686 -mtune=i686 (-O1/ -O2/ -O3 crash)

It is the second packages that I use the same workarond

Maybe due line 41 on https://projects.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/webkitgtk ?
Comment by Nickolay (neothefox) - Thursday, 04 February 2016, 09:18 GMT
dwb keeps crashing, even the version from git. At this point I suggest dropping this package entirely, since dwb is pretty much abandoned and broken.
Comment by Jan de Groot (JGC) - Friday, 08 April 2016, 22:00 GMT
Not a webkit problem IMHO.

dwb uses loads of deprecated functions, also includes patches to disable -Werror and the current package doesn't build, not with extra, not with testing. If webkitgtk2 was broken, more applications would suffer from this.
Comment by Doug Newgard (Scimmia) - Friday, 08 April 2016, 23:19 GMT
Assigning to someone who is no longer a TU isn't going to help.
Comment by Andreas Radke (AndyRTR) - Saturday, 09 April 2016, 13:29 GMT
I'm not a TU, don't know anything about dwb (only touched it when rebuilding a long ago for gnutls).

I suggest to drop it from the repos.
Comment by Stefan Husmann (stefanhusmann) - Saturday, 04 June 2016, 18:48 GMT
I face this also for surf, surf-git and the webkit browser built into emacs 25 (package emacs-xwidget-git), but only under i686 architecture.

Loading...