Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#44948 - [mkvtoolnix] Build QT gui

Attached to Project: Arch Linux
Opened by Bruno Pagani (ArchangeGabriel) - Tuesday, 12 May 2015, 20:20 GMT
Last edited by Maxime Gauduin (Alucryd) - Sunday, 11 October 2015, 14:20 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Giovanni Scafora (giovanni)
Maxime Gauduin (Alucryd)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Apparently, since 7.9, the new QT GUI is no longer a preview.[1]

It require QT>5.2 to build, and can be built along with the current wxgtk version. Is it possible to add it?

Thanks alot!

[1]https://www.bunkus.org/blog/2015/05/mkvtoolnix-v7-9-0-released/

This task depends upon

Closed by  Maxime Gauduin (Alucryd)
Sunday, 11 October 2015, 14:20 GMT
Reason for closing:  Fixed
Additional comments about closing:  8.4.0-2
Comment by Bruno Pagani (ArchangeGabriel) - Monday, 21 September 2015, 16:42 GMT
Well, since 8.3 we have this in changelog:

* build system: removal: the switch »--without-mkvtoolnix-gui« has
been removed. There are only two GUIs left in the package: the
Qt-enabled mkvinfo and MKVToolNix GUI. Both are enabled by default
and can be disabled with the option »--disable-qt«. In that case
only the text-mode version of mkvinfo is built, and the MKVToolNix
GUI is not built at all.

* Removal: all support for wxWidgets has been removed. This means
that the mkvmerge GUI (mmg) has been removed and that mkvinfo now
only supports a text-mode and a Qt-based interface.

Why hasn’t the PKGBUILD been updated accordingly?

Thanks,

Bruno
Comment by Bruno Pagani (ArchangeGabriel) - Monday, 21 September 2015, 16:44 GMT
Also, this is a very high priority and severity bug now, because the qt gui isn’t build and the wxgtk isn’t anymore, so that the package actually contains no GUI…
Comment by Benjamin Robin (benjarobin) - Tuesday, 22 September 2015, 12:29 GMT
This bug report is duplicate of https://bugs.archlinux.org/task/24532
And is kind of a duplicate of this one : https://bugs.archlinux.org/task/45439

Loading...