Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#44779 - [linux] Login screen flashes after upgrading to linux 4.0.1-1, drm errors

Attached to Project: Arch Linux
Opened by Nybble (wuxb45) - Wednesday, 29 April 2015, 16:06 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 02 August 2015, 16:48 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
After upgrading linux 4.0.1(x86_64) kernel. The bottom half of the login screen flashes (gdm). However the problem disappeared after successful logged in. The screen does not flash before or after the login screen.

dmesg show such error messages:
[ 5.954975] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[ 5.955019] [drm:intel_set_pch_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder A
[ 5.955043] [drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun


Additional info:
* package version(s)
linux 4.0.1-1
gnome-shell 3.16.1-2
gdm 3.16.1.1-1

* config and/or log files etc.
thinkpad x220

Steps to reproduce:
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 02 August 2015, 16:48 GMT
Reason for closing:  Fixed
Comment by sven (commonuser) - Wednesday, 29 April 2015, 21:04 GMT
I can confirm this behavior on a ThinkPad T420, which is a Sandy Bridge system.

With GDM 3.16, Wayland is used as the display server, the actual user session
is still backed by X. That may explain the disappearance of the problem after login.

On LKML I found this one https://lkml.org/lkml/2015/2/11/78 , which, by the log,
is also on a Sandy Bridge system.
Comment by john (watgrad) - Wednesday, 29 April 2015, 21:30 GMT
I can also confirm this exact same behaviour on MacBook Pro 8.1

same packages / kernel.
Comment by Geoff Hill (geoffhill) - Thursday, 30 April 2015, 00:21 GMT
Same behavior on a MacBookAir4,2 (Sandy Bridge). The problem persists for a short period even after login.
Comment by Tomasz Przybył (FadeMind) - Thursday, 30 April 2015, 04:57 GMT
FIFO underrun (PCH and CPU errors) are present in Linux Kernel since 3.15.x series. Since 3.19 kernel this messages can be moving in to DEBUG mode. Nothing more can be done with this.

Related with patch FS# https://bugs.archlinux.org/task/43848
Comment by Chris (kitteboss) - Thursday, 30 April 2015, 06:27 GMT
There is a workaround for this:
uncomment in /etc/gdm/custom.conf the line

WaylandEnable=false

Details:
https://bugzilla.redhat.com/show_bug.cgi?id=1199890

 FS#44636 
Comment by Ruben Kelevra (RubenKelevra) - Thursday, 30 April 2015, 12:51 GMT
I can confirm this issue, with Gnome / SandyBridge i3 /w HD2xxx. Kernel package 4.0.1-1.

Else I have issues under Chome, which sometimes have flickerings on forms while load webpages (very rare).
Comment by Soham Pal (petey) - Thursday, 30 April 2015, 16:05 GMT
Same behavior on a Sony Vaio SVE14A15FN (Sandy Bridge).
Comment by Nybble (wuxb45) - Thursday, 30 April 2015, 16:32 GMT
@Chris: Thanks. It works.
Comment by Chris (kitteboss) - Thursday, 30 April 2015, 19:41 GMT
Hey, don't thank me, thank Christian Stadelmann for his comment at redhat! I'm just happy to share usefull information and hope that wayland will soon be more stable. Don't get me wrong X11 is a nice pice of code (well not really as far as I've heared :D ) but it's time to move on :)
Comment by sven (commonuser) - Wednesday, 06 May 2015, 22:33 GMT Comment by Alexandre (alebuque) - Friday, 08 May 2015, 19:53 GMT
Same behavior on a Sony Vaio VPCEA33FB, @Chris tip works fine.
Comment by Ryan Owens (ryanvade) - Tuesday, 26 May 2015, 03:14 GMT
The fix by @Chris mostly works. The flashing is nolonger an issue at the login screen but during general use I still have the issue. It seems to be getting worse. Maybe my issue is Bumblebee related but I would not mark this as fixed by anymeans nor is this just related to the login screen.
Comment by Ruben Kelevra (RubenKelevra) - Saturday, 06 June 2015, 12:08 GMT
Still occurs on my system with latest updates. No workaround has been installed.

linux 4.0.4-2
wayland 1.8.0-1
gdm 3.16.1.1-2
xorg-server 1.17.1-5
Comment by Peter Weber (hoschi) - Wednesday, 10 June 2015, 11:57 GMT
Happens also on my ThinkPad X220 (SandyBridge) and ThinkPad T420 (SandyBridge).
By the way, it doesn't occur if the machine is connected to a dock with a second monitor.
Comment by zh32 (zh32) - Sunday, 28 June 2015, 12:30 GMT
Happens to me as well (Thinkpad L450, Broadwell, xfce, no dm).
Temporally solved by installing lts kernel.
Comment by Luis Henrique Mello (lmello) - Sunday, 28 June 2015, 22:32 GMT
Sony Vaio, intel graphics card. The screen blinks at startup for a while... if I wait long enough, it disappears. hum.
Comment by Peter Weber (hoschi) - Monday, 29 June 2015, 09:18 GMT
Hello!
I'm using a self compiled vanilla-kernel kernel and upgraded on 4.1.0 during the weekend, the problem is fixed and everything works. So I assume this will be fixed, as soons as "linux >= 4.1.0-1" becomes stable for Archlinux.
Comment by Chris (kitteboss) - Saturday, 04 July 2015, 16:24 GMT
Also I can confirm that the latest kernel testing/linux 4.1.1-1 solves the problem.

Loading...