Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#44582 - [linux] 4.2.x Add support for I2C controller based battery

Attached to Project: Arch Linux
Opened by rimaille (ekyo) - Tuesday, 14 April 2015, 15:26 GMT
Last edited by Tobias Powalowski (tpowa) - Thursday, 03 September 2015, 13:42 GMT
Task Type Feature Request
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:

Battery indicator is broken on new laptops using I2C bus (mine is Asus x205ta).
upower indicates no battery is present.

Could you please enable ACPI I2C Operation region support in archlinux .config ?
If you prefer to do it on the testing kernel on a first time, that's OK.

I did that on a mainline kernel and that's OK, tested since 3.19 kernels.

Additional info:
* package version(s) : all archlinux kernels, this symbol is present since 3.17 kernels (marked as NEW, now in 4.0 kernel it'snt tagged as new).

Symbol: ACPI_I2C_OPREGION [=y]
Say Y here if you want to enable ACPI I2C operation region support.
Operation Regions allow firmware (BIOS) code to access I2C slave devices,
such as smart batteries through an I2C host controller driver.
Location:
-> Device Drivers
-> I2C support
-> I2C support (I2C [=y])
Defined at drivers/i2c/Kconfig:26
Depends on: I2C [=y]=y && ACPI [=y]

Thank you for reading this (apologies for my english, i did my best but...)
and thank you for Archlinux :)
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Thursday, 03 September 2015, 13:42 GMT
Reason for closing:  Fixed
Additional comments about closing:  4.2.0-1
Comment by Massimo Branchini (max.bra) - Saturday, 13 June 2015, 06:41 GMT
asus x205ta.
confirmed acpi battery level access not available with current stock arch kernel config.
also, access restored with ACPI_I2C_OPREGION enabled.

IMHO, in a mobile device, having no software nor hardware battery level is an issue a little bit higher than 'medium' requiring more attention given the ease of resolution
Comment by rimaille (ekyo) - Monday, 27 July 2015, 06:28 GMT
Anyone is looking this task ?
Comment by Massimo Branchini (max.bra) - Saturday, 08 August 2015, 08:02 GMT
anyone on this?
Comment by Massimo Branchini (max.bra) - Monday, 31 August 2015, 15:26 GMT
please, can you consider this?
it's a shame to recompile a kernel only for this...
Comment by rimaille (ekyo) - Tuesday, 01 September 2015, 08:05 GMT
Another task was open on this request, please vote https://bugs.archlinux.org/task/45610 to maximize our chances
Comment by Tobias Powalowski (tpowa) - Thursday, 03 September 2015, 06:42 GMT
I'll include it in 4.2.x

Loading...