Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#42511 - [gnome-shell] Gnome 3.14 resume from suspend wallpaper

Attached to Project: Arch Linux
Opened by Lucas S (rootusercyclone) - Thursday, 23 October 2014, 14:01 GMT
Last edited by Jan de Groot (JGC) - Wednesday, 22 March 2017, 15:47 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 32
Private No

Details

Description:
When I resume from suspend, my desktop resumes as normal, but my wallpaper is replaced by a white-ish seemingly random series of pixels. When I alt-2 r the wallpaper reloads as normal.

Additional Info:
my drivers are from the nvidia package
Gnome 3.14

This task depends upon

Closed by  Jan de Groot (JGC)
Wednesday, 22 March 2017, 15:47 GMT
Reason for closing:  Fixed
Comment by Doug Newgard (Scimmia) - Thursday, 23 October 2014, 17:27 GMT Comment by Lucas S (rootusercyclone) - Thursday, 23 October 2014, 17:37 GMT
No it doesn't. I'll grab a screenshot as soon as I get home
Comment by Lucas S (rootusercyclone) - Thursday, 23 October 2014, 19:48 GMT
This is a screenshot of the problem http://i.imgur.com/PY0ZTP5.jpg
Comment by Paul Smet (slumslayer) - Friday, 24 October 2014, 12:08 GMT
Related bug on Debian : https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=765436
Seems to only affect nvidia cards with proprietary drivers on gnome 3.14
Comment by Jeremy M. (jskier) - Saturday, 25 October 2014, 13:05 GMT
It's not just graphic files, also just setting the color yields a mangled background (see attached). Upon changing the color or to graphic file the problem is fine.
Anyone report this upstream yet for Gnome?
Comment by Jeremy M. (jskier) - Saturday, 25 October 2014, 13:07 GMT
Correction and apologies, I haven't had my coffee yet this morning. The problem is never fine, but merely reverts back to normal temporarily by changing the wallpaper settings.
Comment by Kristof Jozsa (kjozsa) - Monday, 27 October 2014, 20:34 GMT
Here's how it looks on my notebook: http://h.dropcanvas.com/ex1c3/nvidia.png - gnome 3.14, nvidia 343.22, linux-ck 3.16
Comment by Ryan Zabcik (rzabcik) - Sunday, 02 November 2014, 19:19 GMT
Bump, this is what mine looks like: http://i.imgur.com/94sYxtE.jpg

This happens after restoring from hibernate.
Comment by Hanno J. (hanno) - Wednesday, 05 November 2014, 08:40 GMT
My colleague and I also have this problem - with different patterns (mine: more random color noise; his: black/white structures, sometimes with color noise overlayed). See: http://imgur.com/a/Bd4H5
gnome 3.14, nvidia 343.22, linux 3.17
Comment by Simone Economo (eKoeS) - Wednesday, 05 November 2014, 09:57 GMT
Here is mine, quite boring I would say... jskier's wallpaper is the most artistic so far! ;)
Comment by Lucas S (rootusercyclone) - Sunday, 09 November 2014, 20:23 GMT
Is everyone that's having the issues using the nvidia package for their drivers?
Comment by Duong Pham (dthpham) - Sunday, 09 November 2014, 20:49 GMT
Having the same issue. Using linux (3.17.2-1), gnome (3.14), nvidia (343.22-4).
Comment by Mark (mrgrumpyarse) - Tuesday, 11 November 2014, 16:00 GMT
Also experiencing the same issue - Linux 3.17.2-1 - gnome 3.14.1 - nvidia 343.22-4
Comment by Denis Saintilma (Fallstaff) - Tuesday, 11 November 2014, 23:20 GMT
Same here
Comment by Lucas S (rootusercyclone) - Monday, 01 December 2014, 16:03 GMT
Well I buggered something up in my install so I'm going to wipe and try again. I'll report back and see if the issue is fixed on a clean install
Comment by Mike Walker (punkmikey) - Thursday, 18 December 2014, 15:38 GMT
Same issue. Also nvidia user. Does anyone have the same issue on other desktop environments or is this purely gnome related?
nvidia 343.36-2, gnome 3.14.2, linux 3.18.1-2-ck.
Comment by Lucas S (rootusercyclone) - Thursday, 18 December 2014, 17:10 GMT
Everything works fine under KDE so I'm guessing it's a gnome issue
Comment by Gerhard Stein (gerstrong) - Tuesday, 13 January 2015, 10:05 GMT
Same issue here, KDE is not affected as it seems
Comment by Matheus Caldas Santos (mtcs) - Friday, 16 January 2015, 13:00 GMT
Same here,

And today I managed to create another interesting pattern! I think we could do a Nvidia/Gnome-resume-background-bug-art-contest!
Comment by Austin (butler360) - Friday, 16 January 2015, 17:56 GMT
This is already reported to Gnome: https://bugzilla.gnome.org/show_bug.cgi?id=739178
Comment by Lucas S (rootusercyclone) - Monday, 19 January 2015, 02:28 GMT
Did a clean install, same problem :( Running GTX 760, how about everyone else?
Comment by G R (gururise) - Wednesday, 11 February 2015, 03:35 GMT
GTX 750ti here. Same problem. Kernel 3.18.6-1-ARCH. Nvidia Drivers: 346.35
Comment by Reik Keutterling (Spielkind) - Wednesday, 25 March 2015, 16:27 GMT
AFAIK they released a fix which will be included in 3.16.1, may you could add a backport if you release a new package:
https://bugzilla.gnome.org/show_bug.cgi?id=739178
Comment by John Chadwick (jchadwick) - Monday, 06 April 2015, 12:51 GMT
3.14.4 of gnome-shell + mutter fix this, it is fairly trivial to compile them using the existing pkgbuild. I have noticed that it does not work for solid-color wallpapers, though.
Comment by Lucas S (rootusercyclone) - Friday, 10 April 2015, 05:06 GMT
  • Field changed: Percent Complete (100% → 0%)
I upgraded to 3.16 and it still is having the same issue
Comment by Jan de Groot (JGC) - Friday, 10 April 2015, 07:43 GMT
Seems 3.16.0 didn't get the fix, it will be in 3.16.1 which is scheduled for release next week.
Comment by Timo Saarinen (timosa) - Monday, 08 June 2015, 06:41 GMT
After 3.16.1 update the problem seemed to have vanished, but later it came back. Not sure, if that happened around 3.16.2 or if it was triggered by an nvidia binary driver update.
Comment by Miles (miles) - Monday, 10 August 2015, 19:45 GMT
  • Field changed: Percent Complete (100% → 0%)
bug still present in GNOME Shell 3.16.3
Comment by Jeremy M. (jskier) - Wednesday, 23 September 2015, 13:11 GMT
This is also happening for me still in 3.16.3, although it seems to primarily be with the lock screen now.
Comment by Lucas S (rootusercyclone) - Wednesday, 23 September 2015, 17:36 GMT
Yeah same here. It seems to be random when it happens, but as soon as I hit a key to slide the lock screen up to enter my password it goes away. I haven't had any issues in on the actual desktop in a long time
Comment by Jan S. (stueja) - Monday, 19 October 2015, 08:45 GMT
Same here. (nvidia drivers, nvidia gtx980m, gnome 3.18.1)
Comment by sam (asg1448) - Wednesday, 11 November 2015, 03:53 GMT
The problem happens to me on the desktop. NVidia drivers, but without any suspend. All I need to do is change to another VT, then back (Alt+Ctrl+F3, Alt+Ctrl+F2)
Comment by Dimos Dimoulis (dimosd) - Saturday, 14 November 2015, 13:46 GMT
I get this problem as well (gnome 3.18.2 + nvidia) when switching to another VT and sometimes when locking the screen
Comment by Amir Sabbaghi (asaba90) - Tuesday, 17 November 2015, 15:22 GMT
I am using nouveau and I had this problem before. But with 3.18 I am experiencing different problems now. If you look at the attachment, there is a distorted part of my terminal in the background; and the "Volume" and "Power" icons are modified too.
I tried to change the background image. It was okay. But when I reverted my background image, the faded terminal was back!
Comment by Dimos Dimoulis (dimosd) - Saturday, 12 December 2015, 00:40 GMT
With the latest nvidia-358 this got worse to the point of getting random lockups when waking from suspend.
I downgraded to nvidia-340xx and it solved all problems (it supports up to gtx750).
I also had to downgrade xorg-server xorg-server-common xf86-input-evdev to their latest pre-1.18 version. If anyone tries this, remember to keep /usr/share/X11/xorg.conf.d/10-evdev.conf which will be missing or the keyboard and mouse won't work.
Comment by Reik Keutterling (Spielkind) - Saturday, 12 December 2015, 10:46 GMT
I downgraded to nvidia 355.11 & xorg 1.17.4-2 to solve this problem. So either it's about xorg 1.18 or the new nvidia driver.
Comment by Dimos Dimoulis (dimosd) - Sunday, 13 December 2015, 06:44 GMT
Nvidia's long lived branch 352.63 has been updated to support xorg 1.18. I am using it now and it works well but I had to compile from source.
Comment by Nepoxx (Nepoxx) - Thursday, 17 March 2016, 20:55 GMT
Still happening with Nvidia's 361.28 driver with Gnome 3.18.4 (included screencap)

Comment by Cysioland (Cysioland) - Monday, 30 May 2016, 22:08 GMT
Still happens, GTX 960

nvidia 364.19-3
gnome-shell 3.20.2-1
Comment by Hussam Al-Tayeb (hussam) - Sunday, 03 July 2016, 09:57 GMT
This is fixed upstream in mutter/gnome-shell (for gnome 3.22) but requires nvidia driver 367.27 or higher.
Comment by Philipp Wolfer (phw) - Wednesday, 22 March 2017, 15:45 GMT
Can this be closed, since both gnome-shell 3.22 and nvidia 367.27 are a long time in the repositories?

Loading...