FS#42500 - [banshee] very slow, high cpu usage, unresponsive

Attached to Project: Arch Linux
Opened by Siwei Luo (sluo) - Wednesday, 22 October 2014, 17:44 GMT
Last edited by Isenmann Daniel (ise) - Thursday, 08 January 2015, 10:57 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Isenmann Daniel (ise)
Jan Alexander Steffens (heftig)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 9
Private No


After recent update banshee becomes near to unusable. Symptoms are:

* very slow initial opening times (it seems like a crash/freeze at first, but it loads eventually after a couple of minutes)
* same symptom when using the search/filter function
* top shows a "Main Thread" process at 100% running

I have suspicion that the recent sqlite update might have caused the problem. After deletion of ~/.config/banshee-1 banshee starts as fast as usual and begins to build its database. The problems occur after you close and open it again.

I have my log output attached.

Additional info:
* banshee 2.6.2-4

Steps to reproduce:
* open banshee with a non-empty database
* perform a search/filter
   log (9.6 KiB)
This task depends upon

Closed by  Isenmann Daniel (ise)
Thursday, 08 January 2015, 10:57 GMT
Reason for closing:  Fixed
Additional comments about closing:  Package version 6 should fixed this issue. Patch was applied from upstream.
Comment by John Piers (johnpiers) - Friday, 24 October 2014, 12:08 GMT
I have exactly the same problem by the looks of things. As the OP describes, my symptoms appear to be pretty similar! I have attached a .txt file with the output from my terminal! Some info on this would be greatly appreciated! Piers.
Comment by Anael (nanawel) - Friday, 24 October 2014, 21:43 GMT
Same issue for me. A few weeks back Banshee used to load instantly with a 20 000+ files library, but now it needs 2 minutes at least and uses 1 core at 100% during this time.
Comment by John Piers (johnpiers) - Sunday, 26 October 2014, 11:00 GMT
Can anyone give an update on whether this is a bug within Banshee or if it's OS related, Gnome Shell etc? Perhaps one of the guys to whom this issue has been assigned who be so kind to give an update? Thanks.
Comment by Siwei Luo (sluo) - Sunday, 26 October 2014, 12:08 GMT
Seems it is an upstream issue, the maintainer of the git version has similiar problems:

Comment by Siwei Luo (sluo) - Wednesday, 29 October 2014, 12:52 GMT
Downgrading sqlite to sqlite-3.8.6-1 fixes the loading time problem (see also: https://bbs.archlinux.org/viewtopic.php?id=187605).

So should i report it to upstream or is it an arch bug?
Comment by John Piers (johnpiers) - Saturday, 01 November 2014, 18:20 GMT
Is anything happening with this? Does anyone know what the problem actually is? There seems to be an eerie silence, just wondering if we should just give up on Banshee altogether! Thanks.
Comment by Günter Loch (gnloch) - Monday, 03 November 2014, 17:05 GMT
Same problem here. Attached file contain banshee --debug output using sqlite-
Comment by Isenmann Daniel (ise) - Monday, 03 November 2014, 19:32 GMT
Have you tried the new sqlite version My problems are all gone with this update. Even the problems with evolution are gone.
Comment by John Piers (johnpiers) - Monday, 03 November 2014, 19:45 GMT
If you are using ARCH and you use the updates, the latest version of sqlite is installed and makes absolutely no difference at all, in fact seems slower! Takes about 3 minutes to load and spews out drivel in the terminal! So no, does not help at all.
Comment by Isenmann Daniel (ise) - Monday, 03 November 2014, 19:54 GMT
Yes, I'm using Arch. What else should I use as Arch maintainer of banshee?

Maybe I should contact the upstream developers, because I don't see here a problem with Arch. Maybe it's time to update the package to the latest development version of banshee 2.9.1.
Have to think about it.
Comment by John Piers (johnpiers) - Monday, 03 November 2014, 20:00 GMT
It was a rhetorical question friend, I would hope that you do! Problem is that half the stuff in 2.9.1 does not seem to fully functional yet, or has that changed? Thanks all the same!
Comment by Isenmann Daniel (ise) - Monday, 03 November 2014, 20:07 GMT
I don't know if it's fully functional yet, but it's a development version so you can't expect it. I have contacted the developers, maybe they know an answer.
Comment by John Piers (johnpiers) - Monday, 03 November 2014, 20:19 GMT
I went here: https://aur.archlinux.org/packages/banshee-git/ Did a build and installed it, everything opened normally, it ran OK but quite a few things were missing and still had errors in the terminal. Yes, that things don't work correctly in a developmental version is to be expected. Thanks again.
Comment by Siwei Luo (sluo) - Monday, 03 November 2014, 20:24 GMT
Unfortunately the latest sqlite package ( did not fix the problems for me either. I also deleted my old database and had banshee created a new one.
Comment by Isenmann Daniel (ise) - Monday, 03 November 2014, 20:30 GMT
According to the sqlite mailing list, the slow down is according to a change in 3.8.7. So, it's not directly a bug in banshee.
The sqlite developer maybe change this in 3.8.8, I don't know if the banshee developers are aware of this problem at the moment.
Comment by Isenmann Daniel (ise) - Monday, 03 November 2014, 20:39 GMT
Here is the mail from the mailing list as reference: http://pastebin.com/GRWpNPTR
Comment by Siwei Luo (sluo) - Monday, 03 November 2014, 21:36 GMT
Your research work and the maintenance of the package is much appreciated!
Comment by John Piers (johnpiers) - Wednesday, 19 November 2014, 19:26 GMT
So Banshee is still broken and nadda from anyone? Nothing at all?? Just updated sqlite to sqlite and still bugger all helps! Very disappointed by the fact that no one really seems to give a tos whether this gets fixed or not. Guess it's time to move on! :-(
Comment by Siwei Luo (sluo) - Wednesday, 19 November 2014, 20:18 GMT
Didn't you read the mail exchange above? The problem is probably to be fixed in sqlite 3.8.8, so there is nothing to be done here at the moment. At the meantime, only fix that works is downgrade to 3.8.6 and add sqlite to IgnorePkg in your pacman.conf.

Comment by John Piers (johnpiers) - Thursday, 11 December 2014, 12:33 GMT
I see that there was an update (two of them) for sqlite, still not 3.8.8, and a Banshee update, but still completely broken, doing the same thing! The Banshee folk obviously don't think that the issue is on their side or perhaps are not aware of it?
Comment by Isenmann Daniel (ise) - Thursday, 11 December 2014, 13:41 GMT
The banshee update addresses some other issues which we had with banshee. This specific issue wasn't fixed, because this must be fixed with an sqlite update to 3.8.8 (if they fixed it there) or with a new version of banshee 2.6
Comment by Samuel Gyger (gygersamuel) - Thursday, 01 January 2015, 10:51 GMT
There is a patch commited to the repository that fixes the slow down on sqlite.

See the upstream bug report: https://bugzilla.gnome.org/show_bug.cgi?id=740879