Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40871 - [jre7-openjdk-headless] No fonts after upgrade

Attached to Project: Arch Linux
Opened by Armin Hahn (flittermice) - Tuesday, 17 June 2014, 05:39 GMT
Last edited by Guillaume ALAUX (galaux) - Wednesday, 09 July 2014, 15:47 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Guillaume ALAUX (galaux)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 15
Private No

Details

After upgrading jre7-openjdk-headless and jre7-openjdk to version 7.u60_2.5.0-2 my Java applications don't show any fonts anymore.
I uploaded screenshots of 2 Java applications and the output of JDownloader startup.

When I go back to version 7.u55_2.4.7-1 everything works as expected again.

FYI: I took the old packages from Arch Rollback Machine and let pacman ignore the package for now:
/etc/pacman.conf:
IgnorePkg = jre7-openjdk*

Additional info:
* package version(s): 7.u60_2.5.0-2

Steps to reproduce:
Start any Java appliation
This task depends upon

Closed by  Guillaume ALAUX (galaux)
Wednesday, 09 July 2014, 15:47 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed 7.u60_2.5.0-3
Comment by Sun Ning (sunng) - Tuesday, 17 June 2014, 08:59 GMT
I confirm this issue. And I believe it's related to anti-aliasing.

I'm running Intellj IDEA and all fonts are invisible after upgrade. Then I unchecked anti-aliasing, they are back.
Comment by st.binder (nium) - Tuesday, 17 June 2014, 11:07 GMT
The same bug here, no fonts in Java programs!
Comment by Sebastien Bariteau (numkem) - Tuesday, 17 June 2014, 13:09 GMT
PyCharm shows fonts but they are blurry and unreadable.

Turning off anti-aliasing didn't change anything for me.
Comment by Marc Geerlings (markus-66) - Tuesday, 17 June 2014, 19:06 GMT
Can confirm.
No fonts in ums and filebot for me.
Downgrading to 7.u55_2.4.7-1 helps.
Comment by Guillaume ALAUX (galaux) - Wednesday, 18 June 2014, 19:28 GMT
About "JDownloader": I don't know this piece of software but judging by the website, it looks like rather old and out of date. I can install it with this (out of date?) AUR package [0]. Font look very ugly but I can see them. How did you install it?

About "Jcat": same here. How did you install it? That package [1] makes it with very ugly font for me (I've just deleted a second AUR package that was just a pure mess).

About "Idea": I see no text as described. Just a reminder: IntelliJ does NOT support OpenJDK. Still…

… I can get nice clean fonts on all 3 pieces of softwares with the following as explained here [2]:

export _JAVA_OPTIONS='-Dawt.useSystemAAFontSettings=on -Dswing.aatext=true -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel'

Can you please check this? Also can you check user conf in ~/.java/
For AUR packages can you also please check package is up to date?

[0] https://aur.archlinux.org/packages/jdownloader/
[1] https://aur.archlinux.org/packages/jcatgui-9kw/
[2] https://wiki.archlinux.org/index.php/Java
Comment by Marc Geerlings (markus-66) - Wednesday, 18 June 2014, 19:43 GMT
ums and filebot are working with
export _JAVA_OPTIONS='-Dawt.useSystemAAFontSettings=on -Dswing.aatext=true -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel'
GUI and fonts are normal.
Comment by Armin Hahn (flittermice) - Thursday, 19 June 2014, 21:55 GMT
I upgraded again and I too can confirm that the workarounds posted by galaux are working with JDownloader and jCatGUI - thank you!
Anyway, I don't think this can be the expected behaviour of Java, especially because the issue has been introduced lately.
Comment by Jeff (jgmdev) - Saturday, 21 June 2014, 19:02 GMT
I too confirm the issue is happening with netbeans and turning off antialiasing fixed it.
Comment by Guillaume ALAUX (galaux) - Sunday, 22 June 2014, 10:50 GMT
Just to be clear, parameter `awt.useSystemAAFontSettings` overrides JRE anti-aliasing setting to **on**, not **off** [0]

[0] http://docs.oracle.com/javase/6/docs/technotes/guides/2d/flags.html#aaFonts

Ok so I have done some more investigations: may I know what all of you are using as desktop environment or window manager?
Comment by Stefan (s9r) - Sunday, 22 June 2014, 11:31 GMT
I'm using KDE with KWin.
Comment by Guillaume ALAUX (galaux) - Sunday, 22 June 2014, 12:40 GMT
About IntelliJ: I've just opened this bug report  FS#40934 . This should solve it.
@sunng: could you please test switching the parameter as explained on  FS#40934  and report result on bug report  FS#40934 ?
Comment by Marc Geerlings (markus-66) - Sunday, 22 June 2014, 12:48 GMT
I use Gnome 3 on my laptops and lxde via Xrdp on my media server. Both have the problem.
Comment by Guillaume ALAUX (galaux) - Sunday, 22 June 2014, 12:50 GMT
@flittermice: the first line of the stack trace you supply says: `Picked up _JAVA_OPTIONS: -Dawt.useSystemAAFontSettings=lcd`. I don't know how you set this but I bet if you change it to `-Dawt.useSystemAAFontSettings=on`
your issue with JDownloader will get fixed.
Comment by Guillaume ALAUX (galaux) - Sunday, 22 June 2014, 13:01 GMT
I have tested (gnome, kde, i3) * (filebot, jcatgui-9kw, jdownloader, netbeans) and all work ok. Fonts are ugly on i3 but very nice on kde/gnome. Can you please check you have no personal setting interferring (like /etc/profile.d/*, bashrc, zshrc, ~/.java)?
Comment by ska (skazska) - Sunday, 22 June 2014, 15:00 GMT
I have same problem, if it may help, i also get error message, when type java --version (gnome 3)

Given workaround, helped! thanks
Comment by Guillaume ALAUX (galaux) - Sunday, 22 June 2014, 15:38 GMT
@ska: `--version` is not a valid `java` option. `-version` (one "dash") is. If you get an error with `java -version` then please check you jre/jdk install.
Comment by Jeff (jgmdev) - Sunday, 22 June 2014, 15:43 GMT
I tested on gnome3 and xfce4 and got the font issue on both.
Comment by Guillaume ALAUX (galaux) - Sunday, 22 June 2014, 18:19 GMT
Can you please check you have no personal setting interferring (like /etc/profile.d/*, bashrc, zshrc, ~/.java)?
And also check what `echo $_JAVA_OPTIONS` gives?
Comment by Marc Geerlings (markus-66) - Sunday, 22 June 2014, 18:34 GMT
Gnome 3 with no $_JAVA_OPTIONS set: No fonts in (for me) ums and filebot.
See screenshot.
Comment by Marc Geerlings (markus-66) - Sunday, 22 June 2014, 18:35 GMT
Forgot screenshot :)
Comment by Guillaume ALAUX (galaux) - Sunday, 22 June 2014, 18:49 GMT
@markus-66: what about `~/.java`? Could you please make a backup and then remove this dir?
Comment by Marc Geerlings (markus-66) - Sunday, 22 June 2014, 18:53 GMT
@Guillaume: Remove .java. Makes no differents.
Comment by Guillaume ALAUX (galaux) - Sunday, 22 June 2014, 18:58 GMT
I have just tried on a vanilla Arch Linux Virtual Box image: installed Gnome, ums, filebot, jcatgui-9kw and jdownloader (versions from AUR) and they all work OK with nice fonts.
Comment by Marc Geerlings (markus-66) - Sunday, 22 June 2014, 19:14 GMT
After last postI added a clean user. filebot worked normally under this user.
Comment by Guillaume ALAUX (galaux) - Monday, 23 June 2014, 11:40 GMT
Great news Marc thank you. Could all of you try to narrow down the culprit? Must be a dot file in home or something.
Comment by Armin Hahn (flittermice) - Tuesday, 24 June 2014, 21:06 GMT
@Guillaume: Yes, sure, correcting the Dawt.useSystemAAFontSettings=on was the first thing I did and that helped.

Like suggested above I tried to track the problem down by moving (nearly) all .dot files and directories out of the way but without success.
My observations:
- no problems & beautiful fonts in Gnome 3
- no fonts at all in LXDE
- distorted fonts in Obenbox (without LXDE)
- In all cases exporting _JAVA_OPTIONS like told above helps.

I think the reason we are still around here is that something in the new package is broken when the _JAVA_OPTIONS is not set (properly)...
Comment by Ben (bsidhom) - Thursday, 26 June 2014, 22:45 GMT
I can confirm that I still have this issue on a fresh account (newly minted user AND home directory) when using i3. I haven't tried with other DE/WMs.
Comment by Stefan (s9r) - Friday, 27 June 2014, 20:02 GMT
Same here: a fresh user did not change a thing. KDE/KWin.
Comment by Ricardo Funke Ormieres (ricardofunke) - Tuesday, 01 July 2014, 00:09 GMT
I can reproduce this issue in Gnome 3.12 changing the font anti-aliasing to "rgba" using Gnome Tweak Tool. Changing back to "grayscale" or "None" do workaround the problem.
Comment by Marcelo Origoni (marcelo.origoni) - Tuesday, 01 July 2014, 01:38 GMT
I'm having the same issue, I tested it on netbeans, jDownloader and freeCol, none display the fonts. My DE is Cinnamon 2.2.13.
I checked the .java folder, and compared the fonts for v 1.7.0_55 and 1.7.0_60 and they are identical.
The rollback did work for me
Comment by Guillaume ALAUX (galaux) - Wednesday, 02 July 2014, 11:29 GMT
"Good news everyone"®

I submitted this issue to upstream IcedTea for advice [0] who kindly points us at an IcedTea bug report [1] that in turn points at this IcedTea commit [2].

With current packages from [extra], when I force _JAVA_OPTIONS='-Dawt.useSystemAAFontSettings=lcd' I can reproduce your issue. With these new packages I built [3] with "--enable-infinality=no" (and local option still set to '=lcd'), text DO appear.

Can you please download and test these packages [3] and let me know the result here.

[0] http://mail.openjdk.java.net/pipermail/distro-pkg-dev/2014-July/028441.html
[1] http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=729
[2] http://icedtea.classpath.org//hg/release/icedtea7-2.5?cmd=changeset;node=012d523c56c9
[3] http://pkgbuild.com/~guillaume/misc/openjdk_no_infinality/
Comment by Ricardo Funke Ormieres (ricardofunke) - Wednesday, 02 July 2014, 12:10 GMT
Hi Guillaume,

Packages in [3] works fine now even with anti-aliasing set to "rgba". I'm not using _JAVA_OPTIONS.
Comment by Marc Geerlings (markus-66) - Wednesday, 02 July 2014, 12:19 GMT
Can confirm
Packages in [3] work wthout font problems.

- Started filebot/ums with current java; No text.
- Upgraded packages.
- Started filebot/ums with upgraded java; Text visible.
Comment by Steve Dougherty (sdough) - Wednesday, 02 July 2014, 14:33 GMT
Packages in [3] result in visible text here with MATE as well.
Comment by Marcelo Origoni (marcelo.origoni) - Wednesday, 02 July 2014, 15:07 GMT
Just tested, and I can confirm packages in [3] make the text visible. Thanks Guillaume!
Comment by Guillaume ALAUX (galaux) - Wednesday, 02 July 2014, 15:29 GMT Comment by Guillaume ALAUX (galaux) - Wednesday, 09 July 2014, 15:46 GMT
Version "-3" with "--enable-infinality=no" is now in [extra]. I am thus closing this bug report and will follow upstream bug report.

Loading...