Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39313 - [skype] Garbled sound after pulseaudio update

Attached to Project: Community Packages
Opened by Mauro Santos (R00KIE) - Monday, 10 March 2014, 19:33 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Wednesday, 21 May 2014, 02:06 GMT
Task Type Bug Report
Category Packages: Multilib
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
When doing skype's test call the sound that is played back is garbled, this means recording is not working properly.

Changing the exec line in /usr/bin/skype from 'PULSE_LATENCY_MSEC=30 exec "$LIBDIR/skype/skype" "$@"' to 'exec "$LIBDIR/skype/skype" "$@"' seems to solve the problem in two cases where a usb headset was used[1].

The 'PULSE_LATENCY_MSEC=30' prefix was added to workaround a bug but now it seems to be causing some trouble. There is the possibility that the problem lies with pulseaudio since some users report problems with other programs.

Additional info:
skype 4.2.0.13-1
pulseaudio 5.0-1


Steps to reproduce:
Call echo123, let the lady finish talking and say a few test words. Wait for the playback and note that it is not correct. I have tested with a usb headset but I suppose the problem might also manifest itself if using a built-in soundcard.


[1] https://bbs.archlinux.org/viewtopic.php?id=178176
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Wednesday, 21 May 2014, 02:06 GMT
Reason for closing:  Fixed
Comment by Florian Pritz (bluewind) - Monday, 17 March 2014, 20:46 GMT
I've removed the workaround in 4.2.0.13-2. If problems come back I'd suggest contacting pulse upstream.
Comment by AnAkkk (AnAkkk) - Tuesday, 25 March 2014, 00:24 GMT
Removing that workaround breaks sound for a number of people, including me.
See https://bbs.archlinux.org/viewtopic.php?id=178872
And see what upstream says about it https://bugs.freedesktop.org/show_bug.cgi?id=76532#c2
Comment by Florian Pritz (bluewind) - Tuesday, 25 March 2014, 09:30 GMT
Alright so if upstream considers this workaround to be needed I'll put it back in, but I'll give 60 instead of 30 msec a try. Please test 4.2.0.13-3 and if you experience problems, well no idea. Maybe tell pulse upstream that both (workaround or not) cause issues.

I'll close this in a week or two unless issues come back.
Comment by Damian Nowak (Nowaker) - Thursday, 27 March 2014, 20:05 GMT
All my problems with Skype were resolved after you removed this "workaround" 10 days ago. People used to say they hear me as if I was a heavy metal guitar... skype 4.2.0.13-2 FTW.

Introducing some "fixes" that fix issues for some people, and simultaneously break things for others don't seem reasonable. I'd rather upstream fixes that for good, not Arch Linux.
Comment by Damian Nowak (Nowaker) - Thursday, 27 March 2014, 20:12 GMT
I just came up with an idea of introducing /etc/skype.conf where people could put some startup parameters of their choice. It would be empty by default but people could add PULSE_LATENCY_MSEC=30, PULSE_LATENCY_MSEC=60 or whatever.
Comment by Damian Nowak (Nowaker) - Sunday, 20 April 2014, 21:08 GMT
Any news on that? I still claim the upstream is responsible for a fix, not Arch Linux, especially when our "fix" fixes for some people and breaks for the other.
Comment by AnAkkk (AnAkkk) - Sunday, 20 April 2014, 21:23 GMT
I doubt you can count on Microsoft for fixing an issue in the Linux version of their Skype client.
Comment by Mauro Santos (R00KIE) - Sunday, 20 April 2014, 22:02 GMT
The fix/workaround works for me, hence my silence so far.

I also wouldn't count much on skype fixing this properly anytime soon, skype for linux was always a 2nd class citizen and updates are few and far apart.
Comment by Damian Nowak (Nowaker) - Sunday, 20 April 2014, 23:29 GMT
You still miss the point. If the "fix" works for some group, and breaks for the other, then there is no sense in such a fix performed by Arch Linux maintainers whatsoever, and either vanilla Skype should be provided or some unintrusive fix (e.g. /etc/skype.conf). Making /usr/bin/skype a script with this "fix" is unreasonable.
Comment by Damian Nowak (Nowaker) - Sunday, 20 April 2014, 23:57 GMT
https://wiki.archlinux.org/index.php/The_Arch_Way

> (...) rather than unnecessary patching (...)
> Software patches are therefore kept to an absolute minimum; ideally, never.

This patch/fix doesn't belong here, especially because it's not a fix for everyone.


> Arch Linux targets and accommodates competent GNU/Linux users by giving them complete control and responsibility over the system.

Should anyone want PULSE_LATENCY_MSEC=30, they should add it permanently to their env.


> Users are not only permitted to make all decisions concerning system configuration (...)

Even if I decide to have PULSE_LATENCY_MSEC=whatever, and set it permanently to my env, my decision is overridden by what the maintainer believes to be the best value in /usr/bin/skype. /usr/bin is for binaries or minimalistic start scripts - not for patches.


The "fix" is clearly against the rules. Please remove it.
Comment by Damian Nowak (Nowaker) - Thursday, 15 May 2014, 13:39 GMT
Hey Sven, any news on this?
Comment by Sven-Hendrik Haase (Svenstaro) - Tuesday, 20 May 2014, 01:46 GMT
Well, what can I do? We can't even properly debug the problem and I doubt this has anything to do with how we package our stuff. Unless there is an easy patch that fixes it for everyone and doesn't break it for everybody else, I doubt there is a sensible solution.
Comment by Damian Nowak (Nowaker) - Tuesday, 20 May 2014, 18:50 GMT
@Sven, what you can do is to revert this "fix", and let people set PULSE_LATENCY_MSEC themselves if they need it. This is a sensible solution.

Loading...