Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38686 - [linux] 3.13: Module 'hci_vhci' has devname (vhci)

Attached to Project: Arch Linux
Opened by Darek (blablo) - Monday, 27 January 2014, 12:25 GMT
Last edited by Thomas Bächler (brain0) - Saturday, 22 February 2014, 22:38 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 14
Private No

Details

Description:
Upgrading the kernel and nvidia produces this message:

(pacman log)
[ALPM-SCRIPTLET] depmod: ERROR: Module 'hci_vhci' has devname (vhci) but lacks major and minor information. Ignoring.

Additional info:
* package version(s): linux 3.13-2, nvidia 331.38-3



Steps to reproduce:
Upgrading the kernel and nvidia packages. (testing repo)
This task depends upon

Closed by  Thomas Bächler (brain0)
Saturday, 22 February 2014, 22:38 GMT
Reason for closing:  None
Additional comments about closing:  This bug has no consequence and people have started spamming this bug report with unrelated discussion. Please request reopen when there is an actual problem caused by this.
Comment by Darek (blablo) - Monday, 27 January 2014, 12:30 GMT Comment by Thomas Bächler (brain0) - Thursday, 06 February 2014, 22:30 GMT
I guess we could remove the devname from vhci. Or we could disable vhci, since it is unlikely that anyone needs it. Or we could simply ignore the message and do useful things.
Comment by simendsjo (simendsjo) - Friday, 21 February 2014, 17:10 GMT
FYI, I get the same error with VirtualBox modules (I think..).

(4/4) upgrading virtualbox-host-modules [########################################################] 100%
depmod: ERROR: Module 'hci_vhci' has devname (vhci) but lacks major and minor information. Ignoring.
In order to use the new version, reload all virtualbox modules manually.
Comment by Paolo (palmaway) - Saturday, 22 February 2014, 21:02 GMT
Apparently it breaks tools which rely on depmod to return a 0 value. Is there an upstream bug report? Not sure how to do that myself...
Comment by gpdas (gpdas) - Saturday, 22 February 2014, 22:28 GMT
fyi. i noticed it today after the update. wasn't able to use optirun (bumblebee) after the update. rolled back for the time being.

upgrading to the following packages gave the depmod error for me.
1. linux-3.13.4-1
2. nvidia-331.38-3
3. bbswitch-0.8-6
4. virtualbox-host-modules-4.3.6-5
5. vhba-module-20130607-24
Comment by Paolo (palmaway) - Saturday, 22 February 2014, 22:36 GMT
@gdpas: same problem here with bumblebee.

Is this related in any manner or is it just a coincidence due to the contemporary upgrade of the nvidia package?

Loading...