Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38308 - Please update Nvidia conflicts for X.org 1.15 server

Attached to Project: Arch Linux
Opened by Chuck (foxcm2000) - Sunday, 29 December 2013, 17:46 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Monday, 13 January 2014, 19:37 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 11
Private No

Details

Description:

X.org 1.15 has been brought into testing but it does not work with the Nvidia 331.20 drivers. Even using the IgnoreABI flag results in a segfault. Other versions of Nvidia drivers are ABI compatible with 1.15, but not the newest 331.20 drivers that are in the Arch repos. I know that the actual software fix is beyond the scope of the Arch maintainers, but the 1.15 packages should be masked for anyone use the 331.20 drivers to maintain functionality.

Request: Please update the conflict file in the PKGBUILD to make sure that Xorg 1.15 won't be installed when the 331.20 version of the nvidia driver is being used. For example, this is an example of an updated conflicts line:
conflicts=('nvidia-utils<=290.10' 'nvidia-utils=331.20)

Of course, when Nvidia releases updated drivers that fix the problem, this can go away.


Additional info:
package versions:
Xorg server 1.15 (and associated dependencies)
Nvidia 331.20 including the nvidia kernel driver and nvidia-utils packages.


Steps to reproduce:

Install Xorg server 1.15 on a system using the Nvidia 331.20 binary drivers.
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Monday, 13 January 2014, 19:37 GMT
Reason for closing:  None
Additional comments about closing:  A new nvidia driver fixed this.
Comment by cju (cju) - Monday, 30 December 2013, 08:37 GMT
This problem occurs not just only with nvidia, but also with virtualbox respectively the virtualbox-guest-utils.
Comment by Ionut Biru (wonder) - Monday, 30 December 2013, 10:19 GMT
just did it for nvidia and xorg.
Comment by Oleg (moonman) - Monday, 30 December 2013, 10:57 GMT
I have no problem with nvidia 331.20. I do run a custom kernel with nvidia-dkms so the driver is recompiled every time. Are you sure it is driver problem?

pacman -Qi nvidia-dkms xorg-server linux-uksm
Name : nvidia-dkms
Version : 331.20-1
Description : NVIDIA kernel module sources (DKMS)
Architecture : x86_64
URL : http://www.nvidia.com/
Licenses : custom
Groups : None
Provides : nvidia=331.20
Depends On : dkms nvidia-utils=331.20
Optional Deps : linux-headers: Build the module against Arch kernel [installed]
linux-lts-headers: Build the module against LTS Arch kernel
Required By : nvidia-hook
Optional For : None
Conflicts With : nvidia
Replaces : None
Installed Size : 15085.00 KiB
Packager : Unknown Packager
Build Date : Thu 21 Nov 2013 07:19:12 AM MST
Install Date : Thu 21 Nov 2013 07:23:57 AM MST
Install Reason : Explicitly installed
Install Script : Yes
Validated By : None

Name : xorg-server
Version : 1.15.0-1
Description : Xorg X server
Architecture : x86_64
URL : http://xorg.freedesktop.org
Licenses : custom
Groups : xorg
Provides : X-ABI-VIDEODRV_VERSION=15 X-ABI-XINPUT_VERSION=20 X-ABI-EXTENSION_VERSION=8.0 x-server
Depends On : libxdmcp libxfont libpciaccess libdrm pixman libgcrypt libxau xorg-server-common
xf86-input-evdev
Optional Deps : None
Required By : nvidia-utils
Optional For : None
Conflicts With : nvidia-utils<=290.10
Replaces : None
Installed Size : 3307.00 KiB
Packager : Andreas Radke <andyrtr@archlinux.org>
Build Date : Sat 28 Dec 2013 04:23:04 AM MST
Install Date : Sun 29 Dec 2013 06:46:37 PM MST
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Name : linux-uksm
Version : 3.12.6-1
Description : Linux Kernel and modules with the UKSM patchset featuring the v1.2.2.
Architecture : x86_64
URL : http://kerneldedup.org/
Licenses : GPL2
Groups : None
Provides : linux-uksm=3.12.6
Depends On : coreutils linux-firmware mkinitcpio>=0.7
Optional Deps : crda
nvidia-uksm
modprobed_db
Required By : None
Optional For : None
Conflicts With : kernel26-uksm
Replaces : kernel26-uksm
Installed Size : 70441.00 KiB
Packager : Unknown Packager
Build Date : Sun 22 Dec 2013 03:41:21 PM MST
Install Date : Sun 22 Dec 2013 03:43:53 PM MST
Install Reason : Explicitly installed
Install Script : Yes
Validated By : None
Comment by cju (cju) - Monday, 30 December 2013, 11:04 GMT
Since X 1.15 works with nouveau but fails with nvidia even after recompiling, I'd say this *is* a nvidia problem. Are you sure you're running the latest X version (1.15.0-2) with nvidia?
Comment by Ionut Biru (wonder) - Monday, 30 December 2013, 11:22 GMT
nvidia doesn't support xorg 1.15 at this time. nvidia-dkms is the kernel module but nvidia-utils contains the driver for X in order to perform the 3d stuff.
Comment by Oleg (moonman) - Monday, 30 December 2013, 11:38 GMT
my bad... rebooted and kdm didn't start. Didn't notice that xorg-server was updated so i assumed it was installed for a while
Comment by Jan de Groot (JGC) - Monday, 30 December 2013, 12:07 GMT
This is a bug in nvidia-utils. All xorg drivers have conflicts on X-ABI-VIDEODRV_VERSION which doesn't match the supported ABI at that moment, but nvidia-utils doesn't have this conflict.
Comment by Anke Boersma (abveritas) - Monday, 30 December 2013, 13:43 GMT
Nvidia 330.20 is not ready for xorg 1.15, but 319.76 is, just an FYI if you would consider using epoch with nvidia.
Comment by Ionut Biru (wonder) - Monday, 30 December 2013, 13:56 GMT
no way, downgrading is not an option. pretty sure nvidiah is going to release a new version soonish.
Comment by KaiSforza (KaiSforza) - Thursday, 02 January 2014, 20:23 GMT
So, someone made them conflict, but nvidia-utils depends on xorg-server, which creates some issues.
Comment by Gustavo Alvarez (sl1pkn07) - Tuesday, 07 January 2014, 05:02 GMT Comment by Pierre Schmitz (Pierre) - Tuesday, 07 January 2014, 09:32 GMT
The nvidia-304xx driver from the repos works just fine. It supports cards up to like the 6xx series so this should be a good workaround for a lot of people.
Comment by Ng Oon-Ee (ngoonee) - Tuesday, 07 January 2014, 12:41 GMT
Except the bumblebee crowd (unsure why nvidia-304xx-utils has conflicts that nvidia-utils doesn't).
Comment by lorim (lorim) - Friday, 10 January 2014, 15:35 GMT
the PKGBUILD for nvidia-utils provides a split-package named "nvidia-libgl" that does the libGL.so symlinking, allowing the installation of nvidia-utils along mesa-libgl... nvidia-304xx-utils is missing that split-package, maybe it's worth providing it for us folks using bumblebee

(the same applies for lib32-nvidia-304xx-utils)

Loading...