Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#37412 - [gnome-shell] flickering background when gnome-shell-extensions is not installed

Attached to Project: Arch Linux
Opened by Clément Guérin (geecko) - Saturday, 19 October 2013, 13:21 GMT
Last edited by Jan Alexander Steffens (heftig) - Tuesday, 17 December 2013, 11:09 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Ionut Biru (wonder)
Jan Alexander Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No


After logging in with autologin activated, gnome-shell launches but fails to display the background, resulting in flickering. This issue only appears when gnome-shell-extensions is not installed.

Until upstream fixes it, gnome-shell should depend on gnome-shell-extensions to fix the problem.

Additional info:
* gnome-shell 3.10.1-1
* Bug tracking
* Arch Linux thread with solution

Steps to reproduce:
* Uninstall gnome-shell-extensions
* Boot the system with autologin activated
* No wallpaper and screen flickering.
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Tuesday, 17 December 2013, 11:09 GMT
Reason for closing:  Fixed
Additional comments about closing:  gnome-shell
Comment by Greg (gm25flew) - Saturday, 19 October 2013, 16:03 GMT
I can confirm the problem and the fix. I did not have gnome-shell-extensions installed and had the problem, installing it corrected the problem.
Comment by Philipp Wolfer (phw) - Saturday, 19 October 2013, 20:18 GMT
See also (scheduled to be closed as a duplicate).
Comment by Philipp Wolfer (phw) - Monday, 21 October 2013, 06:42 GMT
In the upstream bug report it was mentioned that it is sufficient to create the directory /usr/share/gnome-shell/modes (which is included in the gnome-shell-extensions package). The underlying cause of the behavior is still not clear, but until upstream ships a bugfix it might be a solution to just include this directory in the gnome-shell package.
Comment by Alberto (albertoalcolea) - Monday, 28 October 2013, 16:53 GMT
Same error after upgrade the following packages:
pulseaudio (4.0-2 -> 4.0-5),
tzdata (2013g-1 -> 2013h-1),
upower (0.9.22-1 -> 0.9.23-1),
xorg-xinit (1.3.3-1 -> 1.3.3-2)

I had installed gnome-shell-extensions before this and I haven't autologin activated.
I get black screen after login on gdm. I can see and move the cursor but not the rest of the environment of gnome-shell.
After a few minutes an error window appears with this message: "A problem has ocurred and the system can't recover. All extensions have been disabled as a precaution"
Comment by Philipp Wolfer (phw) - Monday, 28 October 2013, 17:55 GMT
@Alberto: This sounds like a different problem to this one. I'd suggest you open a separate bug report for it.
Comment by Alfredo (qwattash) - Sunday, 10 November 2013, 22:50 GMT
I confirm the bug as well as the fix by intalling gnome-shell-extensions
Comment by Marius (marius) - Sunday, 01 December 2013, 09:42 GMT
I can confirm the bug and the fix (installing gnome-shell-extensions) too.
Comment by John Mullen (JTM) - Friday, 06 December 2013, 03:01 GMT
I confirm the bug, as well as the fix by installing gnome-shell-extensions.

EDIT: This bug is marked as critical, but I don't think it qualifies as such.