Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#36647 - [netctl] 1.3-1 netctl-auto can't be overidden

Attached to Project: Arch Linux
Opened by Farence (kotrfa) - Friday, 23 August 2013, 18:09 GMT
Last edited by Jouke Witteveen (jouke) - Saturday, 24 August 2013, 12:20 GMT
Task Type Feature Request
Category Packages: Core
Status Closed
Assigned To Jouke Witteveen (jouke)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 4
Private No

Details

Description:
When netctl-auto@$INTERFACE.service is on, it is imposible to change AP using wifi-menu, even there is no known AP in area. All I get is an report_notice "Interface '$INTERFACE' is controlled by netctl-auto".

So I have to disable netctl-auto using "systemctl stop netctl-auto@wlp1s0.service", which also automatically run command "rfkill block wlan". I have to turn on using "rfkill unblock wlan" and then I can use "wifi-menu".

Even when you want to manually change to known profile "netctl start <profile>" when is netctl-auto on, you have to do same stupidity, because otherwise it says:

"Job for netctl@<interface><profile>.service failed. See 'systemctl status netctl@<interface><profile>.service' and 'journalctl -xn' for details"

uname -a
Linux 530uarch 3.10.7-1-ARCH #1 SMP PREEMPT Thu Aug 15 11:55:34 CEST 2013 x86_64 GNU/Linux

version of coreutils: 8.21-2
version of systemd: 204-3

Wireless adapter:
"Network controller: Intel Corporation Centrino Advanced-N 6230 [Rainbow Peak] (rev 34)"

Using laptop Samsung 530U.
This task depends upon

Closed by  Jouke Witteveen (jouke)
Saturday, 24 August 2013, 12:20 GMT
Reason for closing:  Not a bug
Comment by Jouke Witteveen (jouke) - Saturday, 24 August 2013, 12:20 GMT
The notice you get is no more than a notice. In the background, netctl-auto is restarted, so that it might decide to use the newly created profile (it need not, other known networks might also be available). In netctl 1.3, the netctl-auto utility gained support for management of the netctl-auto process.

Loading...