Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#36521 - [glibc] Can't open console/shell in X with glibc 2.18-1

Attached to Project: Arch Linux
Opened by Andreas (misc) - Tuesday, 13 August 2013, 21:01 GMT
Last edited by Allan McRae (Allan) - Wednesday, 14 August 2013, 03:35 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No


tmux (if opened while 2.17 still installed, otherwise it'll fail entirely) will refuse to create a new shell with "Exec format error", urxvtc with "can't initialize pseudo-tty, aborting.", and gnome-terminal with "grantpt failed: Not allowed".

Outside of X everything seems to work fine. Downgrading to 2.17 resolves these issues within X.

A change to the PKGBUILD removed pt_chown — judged by urxvtc's & gnome-terminal's errors, and the description of pt_chown as "helper function for grantpt, changes ownship and permissions of pseudotty", I suppose that's it.
This task depends upon

Closed by  Allan McRae (Allan)
Wednesday, 14 August 2013, 03:35 GMT
Reason for closing:  Not a bug
Comment by Andreas (misc) - Tuesday, 13 August 2013, 21:09 GMT
Apparently this now has to be set as explicit build flag as it can be a security risk and is no longer entirely necessary. From :

"It is not built by default because systems using the Linux kernel are commonly built with the `devpts' filesystem enabled and mounted at `/dev/pts', which manages pseudo-terminal ownership automatically."

Despite that however — I *do* have devpts enabled, and still got the errors. From my fstab:
devpts /dev/pts devpts defaults 0 0
Comment by Rémy Oudompheng (remyoudompheng) - Tuesday, 13 August 2013, 21:33 GMT
I confirm the issue on my system. It has become totally unusable except for xterm.
Comment by Rémy Oudompheng (remyoudompheng) - Tuesday, 13 August 2013, 21:42 GMT
The solution for me was to comment out /dev/pts in my fstab.
systemd already mounts /dev/pts with the correct options and the fstab entry was making it wrong.

Please confirm it worked for you.
Comment by Andreas (misc) - Tuesday, 13 August 2013, 21:55 GMT
Yes, disabling that fstab line worked for me as well — thanks.