Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35991 - [linux] 3.10.x renders Logitech Unified Receivers useless

Attached to Project: Arch Linux
Opened by Andreas (misc) - Tuesday, 02 July 2013, 00:00 GMT
Last edited by Tobias Powalowski (tpowa) - Tuesday, 13 August 2013, 07:21 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

https://patchwork.kernel.org/patch/1562431/raw/

This workaround for the Unified Receiver's HID driver was reverted in 3.10 for a proper solution —

https://git.kernel.org/cgit/linux/kernel/git/jikos/hid.git/commit/?id=8af6c08830b1ae114d1a8b548b1f8b056e068887

— which unfortunately does not work, at least for my Anywhere MX. I've reapplied it, and now the cursor is moving again.

Others are having the same issue, see this report in Launchpad:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1194649
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Tuesday, 13 August 2013, 07:21 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.10.6-2
Comment by Tobias Powalowski (tpowa) - Tuesday, 02 July 2013, 08:10 GMT
Please report upstream.
Comment by Johan R (cleanrock) - Friday, 05 July 2013, 13:58 GMT
Just want to know if you will move 3.10 to core without this being fixed ? I hope not, pretty severe problem imo.
Comment by Andreas (misc) - Wednesday, 10 July 2013, 07:34 GMT
Reported upstream almost a week ago, but nobody there seems to care.
https://bugzilla.kernel.org/show_bug.cgi?id=60507
Comment by Johan R (cleanrock) - Friday, 26 July 2013, 06:48 GMT Comment by Wilco (Wilco) - Friday, 26 July 2013, 21:29 GMT
Can confirm this bug with a Logitech Performance MX. Downgrading to 3.9 fixes the issue, guess we'll have to wait for an upstream patch
Comment by Óscar Pereira (gauthma) - Thursday, 01 August 2013, 17:58 GMT
I can confirm this bug with a Logitech Wireless Trackball. Downgrading to 3.9 works, as well as re-applying the patch (I re-applied it to 3.10.3).

Further, I would second Johan R's question. A month has gone by since his comment, and the 3.10 series did indeed hit [core]. Probably this was done because (as mentioned in arch-dev-general about a week ago) the 3.9 series hit end-of-life. But nevertheless, shipping this to [core] with a bug like this does seem a bit severe... I am on a laptop, so losing my (usb) mouse meant that I had to use the touchpad -- not that big of a deal. Had it been a desktop, it would have meant "no mouse for you" until you could go bug hunting...

EDIT: On a totally unrelated note, upgrading to the 3.10 series also solved a longstanding annoyance: my laptop has a backlit keyboard, that *never* got lit automatically -- I had to use asus-kbd-backlight manually. Now it does...
Comment by Andreas (misc) - Wednesday, 07 August 2013, 15:15 GMT
Just a quick update, the one-liner that accompanied the revert in 3.11-rc4 (and presumably will also in 3.10.6) broke things for me yet again:
https://lkml.org/lkml/2013/7/18/261
Comment by Andreas (misc) - Monday, 12 August 2013, 15:37 GMT
… and said one-liner has been reverted for 3.11-rc5.

The main revert has still not been included in 3.10.6; maybe the Arch devs might consider including it on their own.
Comment by Tobias Powalowski (tpowa) - Monday, 12 August 2013, 15:42 GMT
If you would post link to the one liner would be nice.
Comment by Óscar Pereira (gauthma) - Monday, 12 August 2013, 16:38 GMT
Speaking of one-liners, I updated the system, unpatched kernel got installed, and after reboot I got no mouse, again. But the good (or lesser bad) news is that this one-liner worked to bring my mouse back: https://bbs.archlinux.org/viewtopic.php?pid=1309910#p1309910

Hope this can be of some help.
Comment by Andreas (misc) - Monday, 12 August 2013, 17:12 GMT
This is the main revert that made the receivers work again with 3.11-rc4: https://github.com/torvalds/linux/commit/c63e0e370028d7e4033bd40165f18499872b5183

This revert was accompanied by a second commit, said one-liner, which broke it yet again and was reverted here for 3.11-rc5: https://github.com/torvalds/linux/commit/8e5654ce6914b950b42d1f896f3d8a75fbf307ae

Loading...