Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35937 - [grub] the "*.mo" files are missing

Attached to Project: Arch Linux
Opened by patrick (potomac) - Wednesday, 26 June 2013, 09:11 GMT
Last edited by Tobias Powalowski (tpowa) - Thursday, 27 June 2013, 07:05 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity Low
Priority Normal
Reported Version 4.1.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Summary and Info: the "*.mo" files are missing in the grub package

I did a "pacman -Syu", grub was updated ( replaced by core/grub )

the update was ok, no problem,

but I notice now a quick error message during the boot process :

error: file '/boot/grub/locale/fr.mo' not found

then the boot menu is displayed and I can boot arch linux without problem,

when I check the directory /boot/grub/locale/ I see no files, that's why I have this error message,

I use the MBR for booting grub,

I try to reinstall grub ( grub-install --recheck /dev/sda )

but I still have the same error message on boot,

the wiki says that "grub.mo" file is in /usr/share/locale/en@quot/LC_MESSAGES/ but I see no "grub.mo", no "fr.mo" in this directory, so I can not copy these files to /boot/grub/locale/,

so I think there is a bug in grub package, the "*.mo" files are missing in the grub package, because before this update I never had this error message


Steps to Reproduce:
install grub package

you will not find *.mo files in /boot/grub/locale, and no grub.mo, fr.mo, eng.mo in /usr/share/locale/en@quot/LC_MESSAGES/
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Thursday, 27 June 2013, 07:05 GMT
Reason for closing:  Fixed
Additional comments about closing:  2.00.5043-2
Comment by patrick (potomac) - Wednesday, 26 June 2013, 10:09 GMT
in fact the error message is :

error: file '/boot/grub/locale/fr.gmo' not found

so the gmo files are missing in the grub package
Comment by Joschka Thurner (jthurner) - Wednesday, 26 June 2013, 13:12 GMT
If you get the source from bzr, translation files are excluded and have to be pulled seperately with linguas.sh before building (see po/README). I added running linguas.sh to the the PKGBUILD, but was hit by a locale error (ASCI/UTF-8/german translation) on make. Sadly don't have time now to look into it further.
Comment by Tobias Powalowski (tpowa) - Wednesday, 26 June 2013, 18:33 GMT
Please try 2.00.5043-2 from testing, it should contain the missing .mo files.
Comment by Joschka Thurner (jthurner) - Wednesday, 26 June 2013, 23:00 GMT
Can confirm fixed in 2.00.5043-2.
Btw, there is no need to manually copy *.mo files - "grub-install" puts them into /boot/grub/locale/ automatically.

Loading...