Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35690 - [skype] pulseaudio 4.0-1 breaks sound in skype

Attached to Project: Community Packages
Opened by Stefy (Steve1984) - Friday, 07 June 2013, 15:03 GMT
Last edited by Jan Steffens (heftig) - Friday, 02 August 2013, 10:22 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Gavin Bisesi (Daenyth)
Florian Pritz (bluewind)
Jan Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 8
Private No

Details

Description:
no sound in skype after update to pulseaudio 4·0-1

solution:

downgrade pulseaudio and libpulse to version 3

Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Jan Steffens (heftig)
Friday, 02 August 2013, 10:22 GMT
Reason for closing:  Fixed
Additional comments about closing:  skype 4.2.0.11-3
Comment by Daniel Wallace (gtmanfred) - Friday, 07 June 2013, 15:05 GMT
do you have lib32-libpulse that is listed in the skype optdepends?
Comment by Stefy (Steve1984) - Friday, 07 June 2013, 15:11 GMT
of course yes and it has always worked, so it is not a missing dependency
thanks anyway
Comment by phanisvara das (phani00) - Friday, 07 June 2013, 16:40 GMT
for me skype & pulse are still working, but somebody else on G+ had the same problem. he added this line to his deault.pa and got things working again:

load-module module-equalizer-sink

[edit: neither he nor i understand exactly why that's so; he found it via google somewhere.]

[edit 2: here's the link: https://plus.google.com/u/0/116063824455643804738/posts/HRfU4vyAajP ]
Comment by Stefy (Steve1984) - Friday, 07 June 2013, 17:16 GMT
my friend you saved my day, that does the job, i have got to say that pulseaudio is starting to get a bit on my nerves !!!!
bye bye from UK
Comment by Patrick Fernie (nogoma) - Friday, 07 June 2013, 18:50 GMT
I had the same issue today, and the linked fix also worked. I also needed to add the "tsched=0" param to default.pa to get rid of some bad gapping/crackling under the new pulse, as described here: https://wiki.archlinux.org/index.php/PulseAudio#Glitches.2C_skips_or_crackling (audio was not perfect pre-upgrade, but it definitely got worse). To avoid this just being a "me too", I will mention that this is on a Thinkpad T420s, so this is on the snd_hda_intel driver.
Comment by Aleksei (yupi) - Saturday, 08 June 2013, 20:47 GMT
I have the same issue but neither "load-module module-equalizer-sink" nor "load-module module-udev-detect tsched=0" help me.
Comment by Daniel Wallace (gtmanfred) - Saturday, 08 June 2013, 21:46 GMT
have you removed your users pulseaudio configuration and merged the pacnews like it is noted in the post_update() message?
Comment by Aleksei (yupi) - Saturday, 08 June 2013, 22:01 GMT
I never had any per-user configuration. Everything (and Skype) worked fine before.
BTW, I am on Thinkpad W510, the same snd_hda_intel driver.

The only way for me to have sound in Skype now, is to kill pulseaudio (pulseaudio -k) and restart Skype.
Comment by Jan Steffens (heftig) - Sunday, 09 June 2013, 11:41 GMT
Starting Skype with PULSE_LATENCY_MSEC=30 should allow things to work. Maybe this workaround could be added to the launching script.
Comment by Ivan Lyapunov (dront78) - Friday, 14 June 2013, 06:54 GMT
Please add this to a launch script
Comment by Rafael Fontenelle (josephg) - Sunday, 16 June 2013, 10:21 GMT
'skype PULSE_LATENCY_MSEC=30' didn't work for me, in pulseaudio 4.0-2. All I get is a constant noise.
Comment by Adria Arrufat (swiftscythe) - Sunday, 16 June 2013, 17:46 GMT
I confirm adding PULSE_LATENCY_MSEC=30 to the launching script helped.
This is the Exec line in the .desktop file:
Exec=/usr/bin/env PULSE_LATENCY_MSEC=30 /usr/bin/skype
Comment by Rafael Fontenelle (josephg) - Sunday, 16 June 2013, 17:57 GMT
What Adria said works for me. Just remember to add "%U", like:
Exec=/usr/bin/env PULSE_LATENCY_MSEC=30 /usr/bin/skype %U
Comment by Kari Hreinsson (karihre) - Sunday, 16 June 2013, 21:29 GMT
Starting skype with PULSE_LATENCY_MSEC=30 worked for me as well. Would be nice if it were included in /usr/bin/skype.
Comment by Bastian Beischer (totsilence) - Friday, 02 August 2013, 10:12 GMT
  • Field changed: Percent Complete (100% → 0%)
The fix in skype 4.2.0.11-2 does not work with the shell builtin "exec" when using zsh:

/usr/bin/skype: line 13: exec: PULSE_LATENCY_MSEC=30: not found

Loading...