Community Packages

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#35672 - [oss] osscore module fails to load after update

Attached to Project: Community Packages
Opened by Petar (klothius) - Thursday, 06 June 2013, 08:46 GMT
Last edited by Kyle Keen (keenerd) - Wednesday, 25 September 2013, 11:38 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Kyle Keen (keenerd)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 24
Private No


After the last update, while soundon osscore throws an error :
"modprobe: ERROR: could not insert 'osscore' : Invalid argument
Loading the osscore module failed"

The only lines in dmesg regarding this are :
"osscore: no symbol version for memmove
osscore: Unknown symbol memmove (err -22)"

Tested on clean arch installs in vm and both x64 and x86 fails.

oss-4.2_2007-2 package still works as it should.

Additional info:
* package version(s)
* config and/or log files etc.

Steps to reproduce:
update system to the latest
install oss-4.2_2007-4
This task depends upon

Closed by  Kyle Keen (keenerd)
Wednesday, 25 September 2013, 11:38 GMT
Reason for closing:  Won't fix
Additional comments about closing:  OSS has been moved to AUR.
Comment by Sebastian Schwarz (seschwar) - Monday, 10 June 2013, 17:13 GMT
I can confirm -- and a user on IRC could do so too -- that downgrading to oss-4.2_2007-2 made the OSS modules work again. -3 also works as it actually has the same content as -2.

The main difference in the newer package is the /usr move. But how did it break OSS and why won't the symlinks help?
Comment by Alexandr (santic) - Monday, 10 June 2013, 17:20 GMT
seschwar, which kernel you are using?
Comment by Sebastian Schwarz (seschwar) - Monday, 10 June 2013, 17:30 GMT
I'm using linux-3.9.5-1.
Comment by Kennedy Skelton (Kiirani) - Tuesday, 11 June 2013, 03:02 GMT
Since most recent system update, I have this exact problem.

I'm throwing in here because I'm not using the latest kernel -- I'm running linux-lts 3.0.81-1
Comment by Ken Gunderson (kgunders) - Tuesday, 16 July 2013, 07:19 GMT
I have same issue post filesystem changes on both 3.9.9-1 and LTS kernels. Downgrading to oss-4.2_2007-2 brings me no joy. Would be great to get this sorted out....
Comment by Petar (klothius) - Tuesday, 16 July 2013, 13:23 GMT
Ken, you could try oss-nonfree from aur for the time being as it's also based on a newer build than this community package is (2008 vs 2007). I have switched over to it and have absolutely no problems.
Comment by Philip (nuc) - Sunday, 28 July 2013, 15:10 GMT
Sad it takes so long to get it fixed. I think it's related to the /usr move.
Comment by Philip (nuc) - Wednesday, 07 August 2013, 20:55 GMT
Any chance to get this downstream bug fixed soon? I'm forced to use Windows 7 for months already... Maybe I'll try oss-nonfree (thanks for the tip!).
Comment by Kennedy Skelton (Kiirani) - Wednesday, 07 August 2013, 21:10 GMT
Why are you using windows instead of just downgrading to a working package?
Comment by Philip (nuc) - Wednesday, 07 August 2013, 22:22 GMT
Is there a working package? As far as I remember OSS didn't get screwed by a new OSS package but by something else..?
Comment by Kennedy Skelton (Kiirani) - Thursday, 08 August 2013, 10:45 GMT
Downgrade worked for me, the original submitter of this bug, as well as another commenter. Then Ken has said downgrading doesn't work for him.
I would be really interested to see what your results are?
Comment by Sebastian Schwarz (seschwar) - Monday, 26 August 2013, 13:18 GMT
I created a PKGBUILD which

- was cleaned up and simplified a bit
- updates to 4.2_2008
- fixes  FS#36033 
- fixes  FS#36284 

However while everything compiles, the OSS modules still fail to load with the memmove symbol error!

Until we can fix this bug OSS users can install the oss-nonfree package from the AUR, which uses 4Front's precompiled binaries and currently works well:
   PKGBUILD (3.3 KiB)
Comment by Ken Gunderson (kgunders) - Tuesday, 03 September 2013, 04:28 GMT
I haven't had time to investigate the downgrade path and why it doesn't work on my system, but I can confirm that the oss-nonfree AUR package does work on this box. Currently on 3.10.10 kernel.
Comment by Kyle Keen (keenerd) - Monday, 09 September 2013, 03:20 GMT
I've been trying everything under the sun to make this work. I have given up. OSS will be removed to AUR in one week if no one can find a fix.
Comment by Petar (klothius) - Monday, 09 September 2013, 07:30 GMT
Have you tried to make it work with build 2008?
Comment by Kyle Keen (keenerd) - Monday, 09 September 2013, 11:24 GMT
Of course. And with the newer patches. And with stuff from the oss-nonfree pkbuild. Whenever the package is built from source it does not work. This suggests it might be something toolchain related, but I really have no idea.
Comment by Damian Nowak (Nowaker) - Saturday, 21 September 2013, 12:33 GMT
Confirming, I built my own PKGBUILD, a fork of oss from [community]. I changed the source to git and excluded the patches that are no longer relevant. I get the same modprobe error.

I will contact Hannu Savolainen who seems to be the active oss developer and ask for suggestions. Maybe they are using a different compiler, or whatever.
Comment by Damian Nowak (Nowaker) - Saturday, 21 September 2013, 19:10 GMT
> OSS doesn't use memmove at all so this problem must be caused by some
> new version of gcc that geterates calls to memmove. I have never heard
> about this kind of problem.

> I'm not working on OSS any more so I can't help.
Comment by Petar (klothius) - Saturday, 21 September 2013, 22:18 GMT
Not sure about this one, but 2008 works ok with GCC 4.6.4 (4.8 gave the same error when compiling from scratch), but it doesn't matter if this one compiles or not as the newest one is build 2008.