Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35518 - [mplayer] lacks smb support since update to smbclient 4

Attached to Project: Arch Linux
Opened by Mikko Seppälä (Neverth) - Tuesday, 28 May 2013, 16:04 GMT
Last edited by Bartłomiej Piotrowski (Barthalion) - Thursday, 31 October 2013, 20:30 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Bartłomiej Piotrowski (Barthalion)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:
All mplayer packages in repos are lacking smb support since update to smbclient 4.
mplayer packages still depend on smbclient, but it is not used since mplayer configure cannot find version 4.

Attitional info:
Building from source results in:
./configure --...
...
Checking for Samba support (libsmbclient) ... no
...

Downgrading to smbclient 3.6.9 from rollback machine results in
...
Checking for Samba support (libsmbclient) ... yes
...
and compiled package plays smb:// streams.

Steps to reproduce:
Install mplayer.
Try playing smb:// stream.

This task depends upon

Closed by  Bartłomiej Piotrowski (Barthalion)
Thursday, 31 October 2013, 20:30 GMT
Reason for closing:  Fixed
Additional comments about closing:  mplayer 36498-2
Comment by Pablo (Slurp) - Monday, 07 October 2013, 19:53 GMT
Is it easy to fix using ABS?
Comment by Mikko Seppälä (Neverth) - Monday, 07 October 2013, 20:48 GMT
Pablo:
Maybe.
Mplayer2 works just by changing the samba includeline in stream/stream_smb.c to <samba-4.0/libsmbclient.h> and recompile.
The thing is that mplayer2 ./configure finds the libsmbclient, but has wrong includeline (not sure if it has been fixed, running my old package).

Loading...