Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34971 - NetworkManager stopped adding modemmanager to dbus, or find connected cables

Attached to Project: Arch Linux
Opened by ido (ik_5) - Friday, 26 April 2013, 10:02 GMT
Last edited by Jan Steffens (heftig) - Friday, 02 August 2013, 10:21 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Steffens (heftig)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
After an update to NetworkManager and ModemManager, it stopped adding the dbus for ModemManager:

Apr 26 13:03:22 rebirth dbus-daemon[980]: dbus[980]: [system] Activating via systemd: service name='org.freedesktop.ModemManager1' unit='dbus-org.freedesktop.ModemManager1.service'
Apr 26 13:03:22 rebirth dbus[980]: [system] Activating via systemd: service name='org.freedesktop.ModemManager1' unit='dbus-org.freedesktop.ModemManager1.service'
Apr 26 13:03:22 rebirth dbus[980]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.ModemManager1.service': Unit dbus-org.freedesktop.ModemManager1.service failed to load: No such file or directory. See system logs and 'systemctl status dbus-org.freedesktop.ModemManager1.service' for details.
Apr 26 13:03:22 rebirth NetworkManager[977]: <warn> error poking ModemManager: GDBus.Error:org.freedesktop.systemd1.LoadFailed: Unit dbus-org.freedesktop.ModemManager1.service failed to load: No such file or directory. See system logs and 'systemctl status dbus-org.freedesktop.ModemManager1.service' for details.
Apr 26 13:03:22 rebirth dbus-daemon[980]: dbus[980]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.ModemManager1.service': Unit dbus-org.freedesktop.ModemManager1.service failed to load: No such file or directory. See system logs and 'systemctl status dbus-org.freedesktop.ModemManager1.service' for details.


Also, it stopped finding that cable is connected to eth.

I have nm enabled at systemd

Additional info:
* modemmanager 0.7.990-4
* networkmanager 0.9.8.0-3


Steps to reproduce:
This task depends upon

Closed by  Jan Steffens (heftig)
Friday, 02 August 2013, 10:21 GMT
Reason for closing:  Not a bug
Additional comments about closing:  systemctl enable ModemManager.service
Comment by Fabian Ebner (briefbanane) - Friday, 26 April 2013, 13:38 GMT
After updating my Huawei 3G modem won't be recognized anymore by networkmanager, other programs (i.e. wvdial) still recognize it.
It's probably because of this bug.
Comment by Ionut Biru (wonder) - Friday, 26 April 2013, 13:44 GMT
do systemctl start ModemManager.service and systemctl enable ModemManager.service
Comment by ido (ik_5) - Friday, 26 April 2013, 13:54 GMT
It stopped reporting the error, and find the connected cable, but my cellular modem is still not recognized anymore, and it does not offer me it's usage.

I have a build-in modem part of my laptop.
Comment by Fabian Ebner (briefbanane) - Friday, 26 April 2013, 15:52 GMT
Thanks, for me it worked when starting the service.
Comment by ido (ik_5) - Saturday, 27 April 2013, 15:02 GMT
Rebooting the machine made everything returns to normal
Comment by Götz (goetzc) - Thursday, 06 June 2013, 15:47 GMT
Same messages repeated thousands of times in journal (every minute). I don't have a modem.
Comment by simeon (FelSim) - Friday, 02 August 2013, 10:17 GMT
  • Field changed: Percent Complete (100% → 0%)
I have the same problem
modemmanager: 1.0.0-1

I get messages like:
Jul 22 18:09:19 pandora dbus-daemon[951]: dbus[951]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.ModemManager1.service': Unit dbus-org.freedesktop.ModemManager1.service failed to load: No such file or directory. See system logs and 'systemctl status dbus-org.freedesktop.ModemManager1.service' for details.
Jul 22 18:10:05 pandora NetworkManager[2787]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted

or the same as mentioned above. Then my internet connection breaks down. Very annoying.


I don't know if my lenovo x230 has a built-in modem.

Loading...