Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34571 - [python2-protobuf] needs provides/conflicts

Attached to Project: Community Packages
Opened by David Eisenmann (D4ve) - Tuesday, 02 April 2013, 10:57 GMT
Last edited by Evangelos Foutras (foutrelis) - Tuesday, 02 April 2013, 11:16 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Pacman has problems replacing packages, it wants to upgrade the old package and install the new, in my special case (look at the attachment):

protobuf-python-2.5.0-1
protobuf-python-2.5.0-1 [removal]
python2-protobuf-2.5.0-2

So pacman gets a file conflict of course.

Additional info:
pacman: v4.1.0
libalpm: v8.0.0
System itself is up to date.

Steps to reproduce:
Just a pacman -Syu
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Tuesday, 02 April 2013, 11:16 GMT
Reason for closing:  Fixed
Additional comments about closing:  python2-protobuf 2.5.0-3 now conflicts/provides protobuf-python.
Comment by Allan McRae (Allan) - Tuesday, 02 April 2013, 11:02 GMT
Do you have "python2-ubuntuone-storageprotocol" installed?
Comment by David Eisenmann (D4ve) - Tuesday, 02 April 2013, 11:05 GMT
Yes, it's installed:

$ pacman -Ss python2-ubuntuone-storageprotocol
community/python2-ubuntuone-storageprotocol 4.2.0-1 [installed]
Comment by Allan McRae (Allan) - Tuesday, 02 April 2013, 11:05 GMT
Yes you do... packaging bug.

python2-ubuntuone-storageprotocol depends on protobuf-python so it has to be pulled into the transaction, despite the attempt at replacing it. python2-protobuf needs provides/conflicts added.
Comment by David Eisenmann (D4ve) - Tuesday, 02 April 2013, 11:09 GMT
So it's not an pacman related issue. Good :)

Loading...