FS#33967 - [linux] 3.8.x - 3.10.x Very high power consumption

Attached to Project: Arch Linux
Opened by Link Mauve (linkmauve) - Friday, 22 February 2013, 12:52 GMT
Last edited by Tobias Powalowski (tpowa) - Monday, 07 October 2013, 10:49 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No


Since the upgrade from 3.7.6 to 3.8 on my Lenovo X121e, the power consumption of the whole computer went from 8~10W to 15~19W, the heat went up too, without any other upgrade from the userland. I don’t run different programs and I don’t really know how to debug that, or which information to provide.

Additional info:
* package version(s)

Steps to reproduce:
Install powertop
Run it while on battery
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Monday, 07 October 2013, 10:49 GMT
Reason for closing:  Upstream
Comment by Tobias Powalowski (tpowa) - Thursday, 23 May 2013, 19:50 GMT
status on 3.9?
Comment by Link Mauve (linkmauve) - Sunday, 26 May 2013, 10:11 GMT
Yes, it is still present in 3.9.3.
Comment by Andrew Cowie (afcowie) - Wednesday, 29 May 2013, 14:28 GMT
powertop seems to be blaming

Audio codec hwC0D0: IDT
Audio codec hwC0D3: Intel

both stuck at 100%. I _think_ that having powertop set "Enable Audio codec power management" to "Good" took care of it, but my battery was already flatlined (again, sigh). If that *is* the culprit, then we need to figure out how to fix this at boot time.

The other possibility is the GPU not entering RC6 (see bug #32025). Regardless of the culprit, I agree this is definitely a regression from 3.8 to 3.9. I'm guessing someone changed a default somewhere.

Comment by Andrew Cowie (afcowie) - Sunday, 09 June 2013, 09:02 GMT
Brutal: when the audio is powered up and not doing anything it's costing about 8 Watts. Toggling the "tunable" in powertop drops its usage and power consumption to zero immediately.

Having to run powertop all the time just to save my laptop from draining mercilessly is quite the pain.

Comment by Stéphane Travostino (eazy) - Wednesday, 19 June 2013, 07:22 GMT
This is affecting me too, Sony Vaio VPCSA.

Previous versions (I don't recall which ones exactly) used around 9W on battery, around 55°C - now it's running at ~25W on battery, 65 °C.
Powertop indicates very high "Display backlight" power usage, I see two of them, 8W each. Running at the lowest brightness setting doesn't affect the power usage very much.
Comment by Tobias Powalowski (tpowa) - Tuesday, 30 July 2013, 10:35 GMT
Status on 3.10.x?
Comment by Stéphane Travostino (eazy) - Tuesday, 30 July 2013, 10:38 GMT
Still not solved. Here's my forum post about 3.9.9: https://bbs.archlinux.org/viewtopic.php?pid=1303619#p1303619

I tested 3.10.2 too with the same result, the only usable kernel (i.e. without fan spinning during idle usage) is 3.5.6
Comment by Tobias Powalowski (tpowa) - Tuesday, 30 July 2013, 10:49 GMT
Please take this to upstream bug tracker, we cannot solve this.
Comment by Christian Hesse (eworm) - Thursday, 22 August 2013, 09:28 GMT
The module for your audio hardware is 'snd-hda-intel', no?
Can you please create a file /etc/modprobe.d/snd-hda-intel.conf with this single line:

options snd-hda-intel power_save_controller=Y power_save=1

Then rmmod and modprobe or simple reboot the system. Does that help?
Comment by Tobias Powalowski (tpowa) - Tuesday, 17 September 2013, 10:01 GMT
Status on 3.11.1?