Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#33088 - [linux] 3.7.0-1 acpi-cpufreq no longer autoloaded on AMD Phenom II

Attached to Project: Arch Linux
Opened by Marti (intgr) - Thursday, 13 December 2012, 21:57 GMT
Last edited by Evangelos Foutras (foutrelis) - Friday, 08 February 2013, 23:40 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 10
Private No


Description: After upgrading to Linux 3.7, my desktop machine isn't autoloading the acpi-cpufreq module at boot any more. I remember reading that recent versions of kernel are supposed to autoload processor-specific modules, is that right?
Manually loading it fixes the problem.

# cpufreq frequency-info
analyzing CPU 0:
no or unknown cpufreq driver is active on this CPU
boost state support:
Supported: no
Active: no

# modprobe acpi-cpufreq
# cpufreq frequency-info
analyzing CPU 0:
driver: acpi-cpufreq
CPUs which run at the same hardware frequency: 0
CPUs which need to have their frequency coordinated by software: 0
maximum transition latency: 4.0 us.
hardware limits: 800 MHz - 3.00 GHz
available frequency steps: 3.00 GHz, 2.30 GHz, 1.80 GHz, 800 MHz
available cpufreq governors: ondemand, performance
current policy: frequency should be within 800 MHz and 3.00 GHz.
The governor "ondemand" may decide which speed to use
within this range.
current CPU frequency is 800 MHz (asserted by call to hardware).
boost state support:
Supported: no
Active: no

# cat /proc/cpuinfo
processor : 0
vendor_id : AuthenticAMD
cpu family : 16
model : 4
model name : AMD Phenom(tm) II X4 940 Processor
stepping : 2
microcode : 0x10000db
cpu MHz : 800.000
cache size : 512 KB
physical id : 0
siblings : 4
core id : 0
cpu cores : 4
apicid : 0
initial apicid : 0
fpu : yes
fpu_exception : yes
cpuid level : 5
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc rep_good nopl nonstop_tsc extd_apicid pni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs skinit wdt hw_pstate npt lbrv svm_lock nrip_save
bogomips : 6002.31
TLB size : 1024 4K pages
clflush size : 64
cache_alignment : 64
address sizes : 48 bits physical, 48 bits virtual
power management: ts ttp tm stc 100mhzsteps hwpstate

[ ... snip 3 more cores ... ]
   dmesg.txt (58.3 KiB)
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Friday, 08 February 2013, 23:40 GMT
Reason for closing:  Fixed
Additional comments about closing:  linux 3.7.5-1
Comment by Ernest Grothauzen (Lone_Wolf) - Thursday, 17 January 2013, 13:55 GMT
same here on kernel 3.7.2-1, with an AMD opteron 2378.
Comment by Calvin Hobbes (calvin) - Tuesday, 22 January 2013, 16:57 GMT
Can confirm this on 3.7.3 and 3.7.4… Autoloading of the former powernow-k8 wasn't a problem, though.

Besides, with 3.7.3 having arrived in [core], the package category should be changed from [testing] to [core]…
Comment by jb (jbreizh) - Wednesday, 23 January 2013, 12:14 GMT
Same here with phenon ii x6 1090t on 3.7.4 !!!
Comment by Leonidas Spyropoulos (inglor) - Wednesday, 23 January 2013, 21:12 GMT
I am experiencing the same problem with my AMD FX 8120 on an ASUS Crosshair Formula V (BIOS v1705)
When I load the module manually dmesg reports the following:
[ 41.828034] acpi-cpufreq: overriding BIOS provided _PSD data

and now ACPI works
Comment by jb (jbreizh) - Thursday, 24 January 2013, 00:37 GMT
Same message with my phenon:
[ 300.329972] acpi-cpufreq: overriding BIOS provided _PSD data
Comment by Ypnose (Ypnose) - Thursday, 24 January 2013, 19:52 GMT
Same issue here with Phenom II X4 955.

Do you know if it was reported upstream?
Comment by jb (jbreizh) - Friday, 08 February 2013, 22:57 GMT
just to say that this bug is solve (in my case) with the last stable kernel. So I think it can be close.
By the way, the message: acpi-cpufreq: overriding BIOS provided _PSD data is still present and seems unrelated.
Have a nice day