Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#32935 - mkinitcpio consolefont hook fails to include font from vconsole.conf

Attached to Project: Arch Linux
Opened by Tom Killian (tomk) - Sunday, 02 December 2012, 10:02 GMT
Last edited by Dave Reisner (falconindy) - Saturday, 08 December 2012, 02:30 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Dave Reisner (falconindy)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No


When the consolefont hook is included in /etc/mkinitcpio.conf and mkinitcpio is run, it returns the following warning message:
consolefont: no font found in configuration

This occurs because /usr/lib/initcpio/install/consolefont references the non-existent $CONSOLEFONT variable, instead of the $FONT variable provided by vconsole.conf.

The attached patch fixes this, and also corrects an erroneous reference to locale.conf in the help() function.

Additional info:
* mkinitcpio 0.12.0-1

Steps to reproduce:
Set the FONT variable in /etc/vconsole.conf, include the consolefont hook in /etc/mkinitcpio.conf, run mkinitcpio.
This task depends upon

Closed by  Dave Reisner (falconindy)
Saturday, 08 December 2012, 02:30 GMT
Reason for closing:  Fixed
Additional comments about closing:  mkinitcpio-0.12.0-2