Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32669 - [autojump] 21.0.3-1 uses /usr/etc/profile.d/ instead of /etc/profile.d/

Attached to Project: Community Packages
Opened by Bernd Pol (bernarcher) - Thursday, 15 November 2012, 06:01 GMT
Last edited by Jaroslav Lichtblau (Dragonlord) - Saturday, 18 May 2013, 21:00 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Jaroslav Lichtblau (Dragonlord)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 17
Private No

Details

$ pacman -Ql autojump
autojump /usr/
autojump /usr/bin/
autojump /usr/bin/autojump
autojump /usr/bin/autojump_argparse.py
autojump /usr/bin/jumpapplet
autojump /usr/etc/
autojump /usr/etc/profile.d/
autojump /usr/etc/profile.d/autojump.bash
autojump /usr/etc/profile.d/autojump.sh
autojump /usr/share/
autojump /usr/share/autojump/
autojump /usr/share/autojump/icon.png
autojump /usr/share/man/
autojump /usr/share/man/man1/
autojump /usr/share/man/man1/autojump.1.gz
This task depends upon

Closed by  Jaroslav Lichtblau (Dragonlord)
Saturday, 18 May 2013, 21:00 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in autojump 21.5.8-1
Comment by Bernd Pol (bernarcher) - Thursday, 15 November 2012, 06:02 GMT
Also, the "j" command is not defined even after moving the contents to /etc/profile.d
Comment by Olivier Brunel (jjacky) - Thursday, 15 November 2012, 08:29 GMT
Yeah in addition to the wrong folder being used, support for zsh has apparently been removed from the package.
Comment by Maciej Chudak (macioosch) - Thursday, 15 November 2012, 11:17 GMT
Does autojump in zsh work after copying files from /usr/etc/profile.d to /etc/profile.d and restarting zsh? It did the trick for me with bash.
Comment by Olivier Brunel (jjacky) - Thursday, 15 November 2012, 12:08 GMT
No it doesn't, the file autojump.zsh (that should be in /etc/profile.d alongside autojump.{sh,bash}) is missing from the package (as well as file _j - that goes in /usr/share/zsh/site-functions - which is also required).
Comment by Joël Schaerer (lardon) - Friday, 16 November 2012, 08:22 GMT
This needs to be reported upstream.
Comment by Olivier Brunel (jjacky) - Friday, 16 November 2012, 15:07 GMT
It has been reported upstream; however, it would still be good to fix the package in the repo, since currently it is broken.
Comment by Noel Maersk (veox) - Friday, 16 November 2012, 19:21 GMT
I have tried building locally (from ABS), here's a rough autojump.PKGBUILD.patch (EDIT: see attachment).
Comment by Olivier Brunel (jjacky) - Friday, 16 November 2012, 19:36 GMT
Well, previous versions of the package did install files "manually" (not using the install.sh script), so simply reverting to it (w/ the new version) would work, I assume.

(And for people looking to install the latest version now, there's also an autojump-git in the AUR.)
Comment by John (graysky) - Saturday, 05 January 2013, 19:40 GMT
So 21.1.2 works just fine with zsh the attached PKGBUILD and as well does not point to the wrong location.
   PKGBUILD (1.3 KiB)
Comment by Olivier Brunel (jjacky) - Saturday, 05 January 2013, 19:44 GMT
No need for that, this has been fixed upstream now, and using:

./install.sh --global --destdir "${pkgdir}"

will work as expected.
Comment by John (graysky) - Saturday, 05 January 2013, 20:02 GMT
@jjacky - Must in git because 21.1.2 does not work as you say with zsh whereas the PKGBUILD I posted does.
Comment by Olivier Brunel (jjacky) - Saturday, 05 January 2013, 20:20 GMT
What? No it's been fixed, in 21.1.0 I believe.

I've used this with 21.2.1 for a little while, in fact I just upgraded to 21.3.0 -- it's been fixed, and it works (w/ zsh).
Comment by John (graysky) - Saturday, 05 January 2013, 20:23 GMT
Dunno what to tell you. Post a PKGBUILD.
Comment by Olivier Brunel (jjacky) - Saturday, 05 January 2013, 20:24 GMT Comment by William Ting (wting) - Saturday, 05 January 2013, 20:53 GMT
FYI, I've removed jumpapplet today as mentioned in this issue (tagged v21.3.0):
https://github.com/joelthelion/autojump/issues/172

That should remove the python2 dependency.

Also, looking at jjacky's PKGBUILD there's no need to replace python with python3. autojump is compatible with Python 2.6+ and 3.0+.
Comment by John (graysky) - Saturday, 05 January 2013, 21:34 GMT
EDIT: My mistake.
@jjk - Thank you. 0.21.3 build just fine with your PKGBUILD. Just gotta get Jaroslav to update and close out the task,
Comment by Olivier Brunel (jjacky) - Saturday, 05 January 2013, 21:42 GMT
Well, you're not using the URL from my PKGBUILD, because that URL does work. It doesn't use the same path as before, because github deprecated/removed that feature (downloads) a little while back (you'll notice there are no more links on github to the URL you gave) (See https://github.com/blog/1302-goodbye-uploads)

Check this instead - https://github.com/joelthelion/autojump/tags - which has the URL used in my PKGBUILD, and show 21.3.0 is the latest.
Comment by John (graysky) - Saturday, 05 January 2013, 21:55 GMT
Something is seriously f*cked-up with 0.21.3-it prevents me from logging in via lxdm. If I log in from a tty, I get:
/etc/profile.d/gpm.sh:4: command not found: pgrep
/home/facade/.zsh/lib/appearance.zsh:2: colors: function definition file not found
/home/facade/.zsh/lib/completion.zsh:20: command not found: whoami
/home/facade/.commonrc:1: command not found: whoami
/home/facade/.commonrc:1: command not found: uname
/home/facade/.zshrc:14: compinit: function definition file not found

EDIT: My bad... didn't read the readme.install -- adding the following fixes this.
[[ -s /etc/profile.d/autojump.sh ]] && . /etc/profile.d/autojump.sh
Comment by John (graysky) - Sunday, 06 January 2013, 12:42 GMT
Apparently I was mistaken - the problem I describe is still present. Here is the PKGBUILD I used:

pkgname=autojump
pkgver=21.3.0
pkgrel=1
pkgdesc="A faster way to navigate your filesystem from the command line"
arch=('any')
url="http://wiki.github.com/joelthelion/autojump"
license=('GPL3')
depends=('bash' 'python')
optdepends=('python2: needed for jumpapplet')
source=(https://github.com/joelthelion/${pkgname}/archive/release-v${pkgver}.tar.gz)
sha256sums=('217398c3135647f223356e055a1b84adb470385584d743baf7fe4d519fd78252')

package() {
cd ${pkgname}-release-v${pkgver}
./install.sh --global --destdir "${pkgdir}"
}

I have this as the first line in my ~/.zshrc
[[ -s /etc/profile.d/autojump.sh ]] && source /etc/profile.d/autojump.sh

I have also tried adding this to /etc/zsh/zprofile but it did not help:
[[ -s /etc/profile.d/autojump.zsh ]] && source /etc/profile.d/autojump.zsh
Comment by John (graysky) - Sunday, 06 January 2013, 13:51 GMT
OK! I think I got this figured out. The problem is that I had a ~/.autojump which I think was messing up my logins. When I deleted that dir, everything works normally.

I added the following line to /etc/zsh/zprofile which I think circumvents the need source it in each user's ~/.zshrc

SO... I recommended that we get the Arch Linux package to create this line in /etc/zprofile and forgot about the post_install message all together.

What do you guys think?

% cat /etc/zsh/zprofile
emulate sh -c 'source /etc/profile'
[[ -f /etc/profile.d/autojump.sh ]] && source /etc/profile.d/autojump.sh
Comment by Olivier Brunel (jjacky) - Sunday, 06 January 2013, 14:24 GMT
There's no need to do that, sourcing /etc/profile will result in sourcing /etc/profile.d/*.sh already...
Comment by John (graysky) - Sunday, 06 January 2013, 18:51 GMT
Thanks for that, jjacky. You are right. Seems as though the PKGBUILD needs to be updated removing that as well from the post_install message.
Comment by John (graysky) - Wednesday, 09 January 2013, 00:05 GMT
...so does the new PKGBUILD and version solve the original issue?
Comment by Olivier Brunel (jjacky) - Wednesday, 09 January 2013, 19:44 GMT
Yes.
Comment by John (graysky) - Wednesday, 09 January 2013, 19:57 GMT
What do you think, Jaroslav?
Comment by John (graysky) - Sunday, 24 February 2013, 21:37 GMT
v21.4.2 has been out of 23 days now. Where are we with this bug report and with the freshness of [community]/autojump in general?
Comment by John (graysky) - Saturday, 30 March 2013, 21:23 GMT
The attached patch brings this package up-to-date. It has been out-of-date since 2012-11-22. I believe the original bug in this report has been squashed. Can someone comment?

Loading...