Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32513 - [virtualbox-host-source] provides virtualbox-host-modules but doesn't, actually

Attached to Project: Community Packages
Opened by Ng Oon-Ee (ngoonee) - Wednesday, 07 November 2012, 09:47 GMT
Last edited by Sébastien Luttringer (seblu) - Friday, 07 December 2012, 02:04 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Ionut Biru (wonder)
Sébastien Luttringer (seblu)
Architecture All
Severity Very Low
Priority Low
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
virtualbox-host-modules contains the files virtualbox modules
virtualbox-host-source allows users to build the modules
*-source should not provide *-modules, as this would indicate that they should conflict (since *-modules would be unneeded)

Basically, I want to make an AUR package that provides virtualbox modules for all installed kernels (see nvidia-beta-all for an example) and it would need to depend on virtualbox-host-source for the source, but also needs to conflict with virtualbox-host-modules since it would also build the modules for the -ARCH kernel.

I could workaround this problem by simply hardcoding it not to build for -ARCH, but it seems to me that if virtualbox-host-source does not actually provide the virtualbox-modules, it should not have provides virtualbox-host-modules
This task depends upon

Closed by  Sébastien Luttringer (seblu)
Friday, 07 December 2012, 02:04 GMT
Reason for closing:  Not a bug
Comment by Sébastien Luttringer (seblu) - Sunday, 11 November 2012, 16:59 GMT
It provides because virtualbox requires virtualbox-host-modules.

It does not conflict because, virtualbox-host-source allow building for non official kernel and conflict with officiel kernel is handled by dkms.
So you can use official module when you boot with official kernel and custom autobuilded when you boot with your kernel.
Not to mention that it's going conflict during virtualbox-host-modules build with devtools.
Comment by Ng Oon-Ee (ngoonee) - Monday, 12 November 2012, 02:25 GMT
Hi Sebastien, thanks for the reply.

So the summary I'm understanding is that virtualbox-host-source is seen as providing builds for non official kernels, while virtualbox-host-modules provides for default kernel. So users with multiple kernels should expect to have both installed?

In that case I'll go for the workaround above (not to build for -ARCH). Thank you.
Comment by Sébastien Luttringer (seblu) - Sunday, 02 December 2012, 00:43 GMT
virtualbox-host-source provides a way to build kernel modules.

virtualbox-host-module is a builded version of kernel modules against current official arch kernel from virtualbox-host-source. Look PKGBUILD of virtualbox-host-modules.

Loading...