Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#31360 - [libreoffice-de] libreoffice fails to start with German language package

Attached to Project: Arch Linux
Opened by Mike (asphantix) - Friday, 31 August 2012, 13:03 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 04 September 2012, 14:09 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 9
Private No


libreoffice fails to start with German language package

with 'libreoffice-de' installed, libreoffice won't start instead it will be stuck in a splash screen loop

Additional info:
problem package: libreoffice-de-
libreoffice version: libreoffice

Steps to reproduce:
pacman -S libreoffice-de -> libreoffice won't start
pacman -Rs libreoffice-de -> libreoffice will start without any problems
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Tuesday, 04 September 2012, 14:09 GMT
Reason for closing:  Fixed
Comment by Piotr P (browcio) - Friday, 31 August 2012, 16:04 GMT
I have the same problem with libreoffice-pl-3.6.1-1

Downgrading language pack to 3.5.6-1 solved problem.
Comment by Maciej (loper) - Friday, 31 August 2012, 18:00 GMT
Yeah, with libreoffice-pl-3.5.6-1 and clucene works again
Comment by Marcos Alves Pintar (mapintar) - Friday, 31 August 2012, 18:08 GMT
I'm using "libreoffice-en-US" instead of "libreoffice-pt-BR", and works well.
Comment by vincent (la_poigne) - Saturday, 01 September 2012, 07:32 GMT
Same problem with libreoffice-fr.
Downgrading language solved problem.
Comment by Uli (Army) - Saturday, 01 September 2012, 09:32 GMT
Looks like - at least with libreoffice-de - it's looking for extensions. Installing the extensions (all of them?) seems to solve the problem according to I won't do that, for now I'll use libreoffice-en-US.
Comment by vincent (la_poigne) - Saturday, 01 September 2012, 09:41 GMT
Just tested with one extension and all works fine.
You need at least one extension or the group package libreoffice-extensions
Comment by Uli (Army) - Saturday, 01 September 2012, 09:58 GMT
Yes, confirmed.
Comment by david cheung (scruffidog) - Saturday, 01 September 2012, 19:58 GMT
Another confirmation of the flashing loop issue but with a slight twist:

it is happening with libreoffice-en-US.

I have the following installed:

local/libreoffice-calc 3.6.1-1 (libreoffice)
local/libreoffice-common 3.6.1-1 (libreoffice)
local/libreoffice-en-US 3.6.1-1
local/libreoffice-extension-pdfimport 3.6.1-1 (libreoffice-extensions)
local/libreoffice-impress 3.6.1-1 (libreoffice)
local/libreoffice-writer 3.6.1-1 (libreoffice)

I installed clucene separately and re-installed libreoffice-en-US which pulled in sdl (???) and then running soffice on cli gets this:

[dcheung@hydra ~]$ soffice
I18N: Operating system doesn't support locale "en_US"
Comment by Uli (Army) - Sunday, 02 September 2012, 05:59 GMT
One more thing: soffice starts fine here WITHOUT clucene installed!

% pacman -Qsq libreoffice

% pacman -Qs clucene
% echo $?
Comment by Andreas Radke (AndyRTR) - Sunday, 02 September 2012, 09:16 GMT
So far I can't confirm this issue. I'm using the german langpack on all my systems.

Feel free to diff the langpacks for missing files/directories. Because we only repackage the upstream rpm langpacks there's not much we can do here. Please investigate this further with upstream help if needed.
Comment by Uli (Army) - Sunday, 02 September 2012, 09:45 GMT
damnit, ignore this (refreshing with webkit browsers always reenters the comments...)
Comment by gyrvim (gyrvim) - Sunday, 02 September 2012, 11:16 GMT
Same problem with libreoffice-it 3.6.1

sudo pacman -Q | grep libreoffice
libreoffice-calc 3.6.1-2
libreoffice-common 3.6.1-2
libreoffice-impress 3.6.1-2
libreoffice-it 3.6.1-1
libreoffice-math 3.6.1-2
libreoffice-writer 3.6.1-2

Installing libreoffice-extension-presentation-minimizer (or another extension) and lcms2 ( solved the problem
Comment by axel (swordfish) - Sunday, 02 September 2012, 13:53 GMT
I can confirm the bug with the "de" langpack, too.

1. Update to libreoffice 3.6.1-1

2. libreoffice doesn't start, complaining about:

exception occurred raising singleton "/singletons/": loading component library failed: file:///usr/lib/libreoffice/program/../program/

3. Installed package clucene

4. libreoffice still fails to start with a flickering splash-screen

5. Installed "libreoffice-extension-pdfimport-3.6.1-1"

6. Libreoffice is working again.
Comment by Andreas Radke (AndyRTR) - Sunday, 02 September 2012, 14:02 GMT
Please everybody use LibO 3.6.1-2 from testing and try deleting ~/.config/libreoffice

Do you get some console output with the flickering screen? Please search for upstream reports. I remember some different starting issues in late RCs.
Comment by axel (swordfish) - Sunday, 02 September 2012, 14:12 GMT
I've just installed the 3.6.1-2 packages but didn't deleted the ~/.config/libreoffice. Libreoffice starts without any problems. I've even removed libreoffice-extension-pdfimport and libreoffice still starts as expected and I can work on my documents.
Comment by Jepaan (jepaan) - Sunday, 02 September 2012, 20:53 GMT
Had same issue with libreoffice-da and clucene.
Installed en-GB, which solved the issue. Then reinstalled da and removed en-GB, and not it works fine.
Comment by david cheung (scruffidog) - Monday, 03 September 2012, 01:16 GMT
ok, here's the weird part: I updated to 3.6.1-3 and still got the locale en_US mesg:

I18N: Operating system doesn't support locale "en_US"

which appears to be looping. Then as per AndyRTR's suggestion, ~/.config/libreoffice was nuked and soffice was re-invoked on the command line which gave the same locale warning, BUT it did not loop and was able to start successfully. My concern now is whether or not there some internal issues that's going to manifest in screwed up documents due to locale handling.

Also, when I look at my environmental variables, my LANG=C which I can't ever remember seeing prior to this whole systemd/rc.conf work. Not sure if it is related in any way, shape or form and more importantly, this is not meant to imply any bias towards or against systemd.
Comment by Andreas Radke (AndyRTR) - Monday, 03 September 2012, 10:19 GMT
Please everybody make sure you properly set LANG with systemd. Check "locale" output. Also please post some useful info about your desktop, architecture and everything that could be useful. A full strace could help and maybe readelf -d can find some missing dep.

Please someone try to apply that single commit for testing:

Further changes can be found here:
Comment by gyrvim (gyrvim) - Monday, 03 September 2012, 10:33 GMT
LC_COLLATE=C in /etc/locale.conf solved the problem.
Comment by Andreas Radke (AndyRTR) - Monday, 03 September 2012, 11:01 GMT
this is what I have on my working systems with systemd:

cat /etc/locale.conf
Comment by axel (swordfish) - Monday, 03 September 2012, 16:21 GMT
cat /etc/locale.conf

that's all in my case. Libreoffice 3.6.1-3 from today seems to run fine.

My environment: KDE 4.9.00 on x86_64
Comment by Andreas Radke (AndyRTR) - Monday, 03 September 2012, 20:35 GMT
Please test 3.6.1-4 that should solve all blinking splash screen issues when no extensions are installed and langpacks are used.

(Extension detections was broken even when the config dir was removed, it worked with old config dirs or when at least one extension got was installed)
Comment by Lukas Jirkovsky (6xx) - Tuesday, 04 September 2012, 06:28 GMT
LO 3.6.1-4 fixes the issue for me.
Comment by Laurent Carlier (lordheavy) - Tuesday, 04 September 2012, 09:50 GMT
fixed here with 3.6.1-4