FS#31269 - [linux] 3.5.x Toshiba Fn Keys not triggering acpi events on InsydeH20 BIOS 2.2

Attached to Project: Arch Linux
Opened by Kyle Van Berendonck (kvanberendonck) - Friday, 24 August 2012, 16:14 GMT
Last edited by Tobias Powalowski (tpowa) - Wednesday, 27 February 2013, 11:10 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No


Laptops made by Toshiba but stuck on InsydeH20 BIOS < version 2.2 (ie: most of them except the L300) don't have working Fn keys (events from Fn keys being pressed don't even pass through xev, however the Fn key does and the F1-F12 keys by themselves do).

I heard that this was fixed in InsydeH20 BIOS 2.2 however most vendors will not give support for this BIOS upgrade and many say that the issue should be handled upstream by the Linux kernel.

Additional info:

* package version(s)
Tested using regular acpi, toshiba_acpi, asus_acpi (failure to boot) and on a clean install with only default modules.

* config and/or log files etc.
None relevant. Events not logged by ACPI.

Steps to reproduce:
InsydeH20 BIOS < 2.2 version, boot Arch on laptop. Open xev and attempt to detect the Fn keys being pressed or check logs for absence of ACPI event occuring.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Wednesday, 27 February 2013, 11:10 GMT
Reason for closing:  No response
Comment by Stefan Wilkens (stefanwilkens) - Tuesday, 18 September 2012, 12:22 GMT
Does dropping down to 3.3.6-ARCH (or 3.3 vanilla for that matter) solve this for you?
Comment by Kyle Van Berendonck (kvanberendonck) - Thursday, 20 September 2012, 10:53 GMT
Tried the latest mainline and it doesn't help. It also generates a strange behavior where the brightness down button clears the console in tty1.

As for 3.3.6-ARCH I'll try compiling that and giving it a shot sometime this weekend.
Comment by Kyle Van Berendonck (kvanberendonck) - Wednesday, 26 September 2012, 03:41 GMT
I haven't yet dropped down to 3.36 because I'm not sure how to build older versions, but I tried mainline with this patch: ( https://bugzilla.kernel.org/show_bug.cgi?id=47861 ) and it didn't seem to do anything.

URGENT: Latest update for our BIOS from Toshiba (2.1) psk36a_bios_210 causes the battery to not be present at all. There is only the AC power device present in /sys/class/power_supply whereas before the bios update from 2.0 there was a BAT1 device. As a consequence, things that tell the remaining battery time have stopped working. This happens both under stock kernel of a fresh arch install, under the live cd and under the patched mainline kernel. Battery works fine in Windows 7 and 8.

What files do you want me to upload to diagnose?
Comment by Greg (dolby) - Saturday, 17 November 2012, 07:16 GMT
The URGENT part is a seperate issue you should report to the kernel bugzilla.
Are you still having both problems?
Comment by Kyle Van Berendonck (kvanberendonck) - Saturday, 17 November 2012, 07:30 GMT
Actually, the battery problem happened to be a DSDT issue. The Fn key problem still persists though, even in 3.7.
Comment by Peter Wu (Lekensteyn) - Saturday, 17 November 2012, 16:51 GMT
The battery fix is here:

What kind of Fn keys do not work? E.g. do mute, volume up/down work while brightness up/down do not work? You might have to file a bug at BZ if there is no bugfix yet.
Comment by Tobias Powalowski (tpowa) - Wednesday, 23 January 2013, 15:01 GMT
Status on 3.7.x?