Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30190 - [kdelibs] kdelibs 4.8.4 causes severe instability with KDE apps if Nepomuk is enable

Attached to Project: Arch Linux
Opened by Damien Gombault (Desintegr) - Friday, 08 June 2012, 09:16 GMT
Last edited by Andrea Scarpino (BaSh) - Thursday, 14 June 2012, 09:29 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andrea Scarpino (BaSh)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 17
Private No

Details

I have just upgraded to KDE 4.8.4.
Thank you Andrea for all your work.

KDE 4.8.3 was really stable and the fresh new released KDE 4.8.4 is really unstable :
- when I launch Kjots, I get an Akonadi Nepomuk Feeded crash : http://pastebin.com/uci5krvw
- when I launch KMail, I get a crash : http://pastebin.com/9zKESP4y
- when I launch Gwenview, I get a crash : http://pastebin.com/yMihgcGm
- when I click an icon in Dolphin, I get a crash : http://pastebin.com/CCB69Wzg

Workaround : disable Nepomuk Semantic Desktop in System Settings.

I open a topic in the forum : https://bbs.archlinux.org/viewtopic.php?pid=1112869#p1112869
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Thursday, 14 June 2012, 09:29 GMT
Reason for closing:  Fixed
Additional comments about closing:  kdelibs 4.8.4-2
Comment by Ike Devolder (BlackEagle) - Friday, 08 June 2012, 15:04 GMT
ok i can confirm problems with kmail on i686 (when hitting reply everything crashes) downgrading do 4.8.3 did solve the problem
Comment by Hussam Al-Tayeb (hussam) - Friday, 08 June 2012, 15:09 GMT
This regressed in kdelibs 4.8 branch either on the 29th or 30th of April.
someone filed a bug. they duped it to something that was opened a year ago eventhough it is a new regression.
Comment by Hussam Al-Tayeb (hussam) - Friday, 08 June 2012, 15:41 GMT Comment by Ike Devolder (BlackEagle) - Friday, 08 June 2012, 17:29 GMT
i can also confirm that the problem goes away with the workaround mentioned in: https://bbs.archlinux.org/viewtopic.php?pid=1112869#p1112869
Comment by Hussam Al-Tayeb (hussam) - Friday, 08 June 2012, 18:22 GMT
the workaround is completely disabling nepomuk which some people use and need.
Comment by Jonathan Dlouhy (oboedad55) - Friday, 08 June 2012, 20:11 GMT
Same problems here, disabling nepomuk "solves" the crashes in Dolphin and Kmail, but renders Kmail less functional.
Comment by Hussam Al-Tayeb (hussam) - Saturday, 09 June 2012, 08:13 GMT Comment by Hardeep (hardeep) - Saturday, 09 June 2012, 10:02 GMT
I've configured akonadi to use sqlite. For me, Kmail opens fine, but the moment I try to open any email or compose a new mail, it crashes. As mentioned by others, once Nepomuk semantic desktop is disabled, Kmail works fine.
Comment by Hussam Al-Tayeb (hussam) - Saturday, 09 June 2012, 10:21 GMT
I mentioned the bad checkin in upstream report. hopefully they will take look at it.
Comment by Andrea Scarpino (BaSh) - Sunday, 10 June 2012, 07:52 GMT Comment by Jonathan Dlouhy (oboedad55) - Sunday, 10 June 2012, 08:06 GMT
That fixes it, thanks. Will the 4.8.4 updates eventually reflect this update?
Comment by Hussam Al-Tayeb (hussam) - Sunday, 10 June 2012, 16:00 GMT
soprano 2.7.56 fixes it (there is an update to 2.7.57 too)
Comment by Zbynek Novotny (clayman) - Monday, 11 June 2012, 04:56 GMT
Vouching for Andrea's solution as well. Soprano 2.7.56 solves KMail's crashing for me. Thanks!
Comment by Hardeep (hardeep) - Monday, 11 June 2012, 07:57 GMT
Thanks Andrea. Latest version of soprano from kde-unstable fixed it.
Comment by Hussam Al-Tayeb (hussam) - Monday, 11 June 2012, 11:48 GMT
They should just up the dependency even if in 4.8.x branch.
This is exactly why versioned depedencies are crucial in linux software packaging.
Comment by Simone Lazzaris (ziopera) - Monday, 11 June 2012, 14:15 GMT
I join to the chorus. Here I've got crashes on kmail and gwenview, fixed by the package in unstable.
Comment by Jochen (Parzival) - Tuesday, 12 June 2012, 06:23 GMT
Pretty please, with sugar on top, can we have a bugfix for stable, pleease?
Comment by Andrea Scarpino (BaSh) - Thursday, 14 June 2012, 06:25 GMT
I'm pushing kdelibs 4.8.4-2 to [extra] which should fixes this. Please try it and let we know.
Thanks!
Comment by Damien Gombault (Desintegr) - Thursday, 14 June 2012, 09:28 GMT
I have upgraded to kdelib 4.8.4-2 : no crash with Kjots, Kmail, Dolphin and Gwenview.

Thank you very much.

Loading...