Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29182 - [btrfs-progs] fsck.btrfs missing error when building images

Attached to Project: Arch Linux
Opened by John (graysky) - Thursday, 29 March 2012, 20:56 GMT
Last edited by Dave Reisner (falconindy) - Thursday, 29 March 2012, 23:17 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description: mkinitcpio reports the following when I attempt to build an image. I don't know if this is the fault of btrfs-progs, or of mkinitcpio.... or of me :)

$ sudo mkinitcpio -p linux

==> Building image from preset: 'default'
-> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 3.3.0-1-ARCH
-> Parsing hook: [base]
-> Parsing hook: [udev]
-> Parsing hook: [autodetect]
-> Parsing hook: [pata]
-> Parsing hook: [scsi]
-> Parsing hook: [sata]
-> Parsing hook: [filesystems]
-> Parsing hook: [usbinput]
-> Parsing hook: [fsck]
==> ERROR: file not found: `fsck.btrfs'
==> WARNING: No fsck helpers found. fsck will not be run on boot.
...

I have [testing] enabled and am up-to-date.

Additional info:
* package version(s)
testing/btrfs-progs 0.19.20120328-1 [installed]
core/mkinitcpio 0.8.5-1 [installed]

Steps to reproduce:
Boot or chroot into a btrfs root filesystem, then attempt to run mkinitcpio.
This task depends upon

Closed by  Dave Reisner (falconindy)
Thursday, 29 March 2012, 23:17 GMT
Reason for closing:  Not a bug
Additional comments about closing:  btrfsck doesn't play well with the fsck helper
Comment by Dave Reisner (falconindy) - Thursday, 29 March 2012, 21:02 GMT
No bug here. fsck.btrfs doesn't exist. btrfsck is called as such presumably because it doesn't have the same userlevel API as a proper fsck tool (i.e. supporting the flags mentioned by the manpage for fsck.ext4).
Comment by John (graysky) - Thursday, 29 March 2012, 21:45 GMT
Really? The only util I'm aware of that doesn't integrate with fsck is the one that xfs uses. This alone could be reason not to use it btrfs :/
Comment by Dave Reisner (falconindy) - Thursday, 29 March 2012, 21:55 GMT
Really, read the manpa... oh wait, it's useless. Just check the --hel... oh hrm. That doesn't exist. Better read the source code to find the flags.

Regardless of what this utility does, it doesn't support being called by the fsck helper yet, which is what mkinitcpio relies on. It would be useful to find out from upstream what their long term plan is -- if btrfsck will one day be called fsck.btrfs and integrate with all the proper flags of a standard fsck helper.
Comment by John (graysky) - Thursday, 29 March 2012, 22:51 GMT
Thanks, Dave. Avi Miller at Oracle suggested that I post to the ML but he was pretty sure that btrfs does not play with the API. I posted:linux-btrfs@vger.kernel.org/msg15624.html"> http://www.mail-archive.com/linux-btrfs@vger.kernel.org/msg15624.html

I will request that this report get closed as it doesn't seem to be any bug or problem with our packages.

Loading...