Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29019 - Plasma-desktop do not start and uses all ressources.

Attached to Project: Arch Linux
Opened by Radon (Ekaradon) - Tuesday, 20 March 2012, 19:51 GMT
Last edited by Andrea Scarpino (BaSh) - Tuesday, 20 March 2012, 21:09 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When you install KDE 4.8.1 on a 64 architecture (on 32, there is no bug) with gstream, and then edit inittab in order to have a login screen, you will have an issue.
You will be able to login normally, but then, the splash screen stays a really long time, and when you make a top on the process, you will see plasma-desktop with 100% charge on CPU, and the memory is little by little fill.
Fix I've found is to use vlc phonon, then it starts normally.
I've met this issue with both last versions and test versions.

Seems similar at this issue :
https://bugs.archlinux.org/task/28849#close
But in my case, after a long time, the black screen with only the cursor visible (and movable) appears, not need to kill plasma-desktop.
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Tuesday, 20 March 2012, 21:09 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#26012 
Comment by Andrea Scarpino (BaSh) - Tuesday, 20 March 2012, 20:51 GMT
Do you have some ttf package installed? (see  FS#26012 )
Comment by Radon (Ekaradon) - Tuesday, 20 March 2012, 20:56 GMT
Oh, I'd not installed ttf package when I met this bug...
Strange like bug.
Comment by Andrea Scarpino (BaSh) - Tuesday, 20 March 2012, 20:57 GMT
Check the `pacman -Qs ttf` output
Comment by Radon (Ekaradon) - Tuesday, 20 March 2012, 21:01 GMT
My output :
local/ttf-dejavu 2.33-2
Font family based on the Bitstream Vera Fonts with a wider range of characters
local/ttf-freefont 20100919-2
Set of free outline fonts covering the Unicode character set
But I installed theses packages after make my kde installation working by switching of phonon. So, except if phonon-vlc has like dependencies a ttf package, the fix didn't involved any ttf packages.
Comment by Andrea Scarpino (BaSh) - Tuesday, 20 March 2012, 21:05 GMT
try {re}moving your ~/.kde4 dir then. Or the kdecache-* dirs in /var/tmp/
Comment by Radon (Ekaradon) - Tuesday, 20 March 2012, 21:08 GMT
I've already test theses solutions when I was confronted to this issue, but theses moves didn't change anything.
But, like I've said, my bug is now fixed by installing phonon-vlc (not sure to have make my message clear because I'm not good in english), so why do you want that I move my ~/.kde directory or my cache ?

Loading...