Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28490 - [sword] xiphos fails to index (+ ICU issues that may be related)

Attached to Project: Community Packages
Opened by Andrei Arici (distrohopperarched) - Friday, 17 February 2012, 15:59 GMT
Last edited by Alexander F Rødseth (xyproto) (trontonic) - Monday, 21 May 2012, 10:25 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Alexander F Rødseth (xyproto) (trontonic)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Trying to index Bibles results in "Index failed".

Starting from a terminal will fill it with messages like:
UTF8Transliterator: ICU: no resource index to load
UTF8Transliterator: ICU: status U_MISSING_RESOURCE_ERROR

Additional info:
* package version(s) - current

Steps to reproduce:
Install latest Xiphos, start Xiphos from the command line, try to index.
This task depends upon

Closed by  Alexander F Rødseth (xyproto) (trontonic)
Monday, 21 May 2012, 10:25 GMT
Reason for closing:  Upstream
Additional comments about closing:  The problems with xiphos and/or sword doesn't look like they will be fixed any time soon.
Comment by Alexander F Rødseth (xyproto) (trontonic) - Saturday, 18 February 2012, 10:18 GMT
What are the steps to reproduce? I can't find a choice named index and when clicking around and searching, everything works fine here.
Which version of xiphos is this? I assume it is 3.1.4-9? Some times mirrors are slow to update packages. The version number is good to have in the bug report in any case, for the future.
Which version of the icu package do you have? Here it's 4.8.1.1-1.
What happens if you start xiphos like this:
LC_ALL=C xiphos

Thanks for reporting.
Comment by Andrei Arici (distrohopperarched) - Saturday, 18 February 2012, 18:20 GMT
community/xiphos 3.1.4-9 [installed]
extra/icu 4.8.1.1-1 [installed]

Module Manager (F4) - Mantainance - Selecting certain Bibles - Hitting Index/Delete Index will result in an error.
I pulled one single Bible after installing, didn't move a folder from another folder just to make sure I don't mess anything up.
This is needed so that you can search STRONGS number with lemma:H1234. This disables fast searching, as well as searching in depth. Clucene indexing is needed for both.

I'm no programmer but looking around the web, I found similar issues and maybe all is missing is an --with-icusword switch.

Here's the output you requested. Even without LC-ALL=C, it's full with ICU errors.
LC_ALL=C xiphos
** Message: MAINTAINER_MODE
** Message: /usr/share/xiphos/languages
UTF8Transliterator: ICU: no resource index to load
UTF8Transliterator: ICU: status U_MISSING_RESOURCE_ERROR
** Message: create main_mgr time is 0.025178
Number of Text modules = 1
Number of Commentary modules = 0
Number of Dict/lex modules = 0
Number of Book modules = 0
Number of Percomm modules = 0
Number of Devotion modules = 0
Number of Prayer modules = 0

Starting xiphos-3.1.4
Building Xiphos interface

** Message: MAINTAINER_MODE
** Message: MAINTAINER_MODE
** Message: /usr/share/xiphos/navbar_versekey.glade
** Message: context_id: 1
message: Welcome to Xiphos
UTF8Transliterator: ICU: no resource index to load
UTF8Transliterator: ICU: status U_MISSING_RESOURCE_ERROR
** Message: create main_mgr time is 0.001237
Starting sword-1.6.2
Initiating SWORD
path to sword: /home/flow/.sword/
SWORD locale is en
Checking for SWORD Modules
Number of Text modules = 1
Number of Commentary modules = 0
Number of Dict/lex modules = 0
Number of Book modules = 0
Number of Percomm modules = 0
Number of Devotion modules = 0
Number of Prayer modules = 0

Initiating Xiphos
UTF8Transliterator: ICU: no resource index to load
UTF8Transliterator: ICU: status U_MISSING_RESOURCE_ERROR
** Message: create SWMgr time is 0.001321
UTF8Transliterator: ICU: no resource index to load
UTF8Transliterator: ICU: status U_MISSING_RESOURCE_ERROR
** Message: create main_mgr time is 0.001194
Displaying Xiphos
** Message: on_notebook_main_switch_page
** Message: mod_name = HebModern
done

total time is 1.224118
** Message: MAINTAINER_MODE
** Message: /usr/share/xiphos/module-manager.glade
UTF8Transliterator: ICU: no resource index to load
UTF8Transliterator: ICU: status U_MISSING_RESOURCE_ERROR
** Message: create SWMgr time is 0.000524
UTF8Transliterator: ICU: no resource index to load
UTF8Transliterator: ICU: status U_MISSING_RESOURCE_ERROR
** Message: create SWMgr time is 0.000745
UTF8Transliterator: ICU: no resource index to load
UTF8Transliterator: ICU: status U_MISSING_RESOURCE_ERROR
** Message: total time is 0.518057
UTF8Transliterator: ICU: no resource index to load
UTF8Transliterator: ICU: status U_MISSING_RESOURCE_ERROR
** Message: create main_mgr time is 0.018867
Number of Text modules = 1
Number of Commentary modules = 0
Number of Dict/lex modules = 0
Number of Book modules = 0
Number of Percomm modules = 0
Number of Devotion modules = 0
Number of Prayer modules = 0

UTF8Transliterator: ICU: no resource index to load
UTF8Transliterator: ICU: status U_MISSING_RESOURCE_ERROR
** Message: create SWMgr time is 0.001186
UTF8Transliterator: ICU: no resource index to load
UTF8Transliterator: ICU: status U_MISSING_RESOURCE_ERROR
** Message: create SWMgr time is 0.001320
** Message: total time is 0.082957
index HebModern
UTF8Transliterator: ICU: no resource index to load
UTF8Transliterator: ICU: status U_MISSING_RESOURCE_ERROR
** Message: create SWMgr time is 0.003168
UTF8Transliterator: ICU: no resource index to load
UTF8Transliterator: ICU: status U_MISSING_RESOURCE_ERROR
** Message: create SWMgr time is 0.001324
** Message: on_destroy
UTF8Transliterator: ICU: no resource index to load
UTF8Transliterator: ICU: status U_MISSING_RESOURCE_ERROR
** Message: create main_mgr time is 0.003227
Number of Text modules = 1
Number of Commentary modules = 0
Number of Dict/lex modules = 0
Number of Book modules = 0
Number of Percomm modules = 0
Number of Devotion modules = 0
Number of Prayer modules = 0

UTF8Transliterator: ICU: no resource index to load
UTF8Transliterator: ICU: status U_MISSING_RESOURCE_ERROR
** Message: create SWMgr time is 0.001804
** Message: on_destroy
UTF8Transliterator: ICU: no resource index to load
UTF8Transliterator: ICU: status U_MISSING_RESOURCE_ERROR
** Message: create main_mgr time is 0.007117
Number of Text modules = 1
Number of Commentary modules = 0
Number of Dict/lex modules = 0
Number of Book modules = 0
Number of Percomm modules = 0
Number of Devotion modules = 0
Number of Prayer modules = 0

UTF8Transliterator: ICU: no resource index to load
UTF8Transliterator: ICU: status U_MISSING_RESOURCE_ERROR
** Message: create SWMgr time is 0.001271
Comment by Alexander F Rødseth (xyproto) (trontonic) - Sunday, 19 February 2012, 02:06 GMT
Thank you for the additional information, I'll look at it.
Comment by Andrei Arici (distrohopperarched) - Sunday, 19 February 2012, 20:05 GMT
Please confirm that you've been able to reproduce the bug. My system is up to date.
Comment by Alexander F Rødseth (xyproto) (trontonic) - Monday, 20 February 2012, 09:01 GMT
Confirmed. However, I see that 3.1.5 was out yesterday, which may fix this bug. If not, please report it upstream (directly to the developers of Xiphos).
I'm working on packaging 3.1.5, but it doesn't compile as of yet.
Comment by Alexander F Rødseth (xyproto) (trontonic) - Monday, 20 February 2012, 09:12 GMT
This bug is fixed in Xiphos 3.1.5:
http://xiphos.org/development/release-notes/

(search for 3022383)
Comment by Alexander F Rødseth (xyproto) (trontonic) - Monday, 20 February 2012, 15:42 GMT
I reopened this bug because Xiphos can't be updated to 3.1.5 until the next version of sword is released. Xiphos currently only builds with the development version of Sword.
I'm in contact with one of the Xiphos developers and have just tested a patch for compiling the new Xiphos with the current version of Sword, but it didn't compile.
I'll close this bug when I can release Xiphos 3.1.5.
Comment by Stefan Husmann (stefanhusmann) - Monday, 20 February 2012, 22:11 GMT
My AUR packages sword-svn and xiphos-webkit-svn can be used as workaround.
xiphos-svn will not help here and should be removed.

sword-svn: https://aur.archlinux.org/packages.php?ID=56768

xiphos-webkit-svn: https://aur.archlinux.org/packages.php?ID=53578

xiphos-svn: https://aur.archlinux.org/packages.php?ID=24878
Comment by Alexander F Rødseth (xyproto) (trontonic) - Monday, 20 February 2012, 22:54 GMT
Updated the xiphos package to 3.1.5. It seems like this bug is still present. Can someone please confirm this? Thanks.
Comment by Andrei Arici (distrohopperarched) - Tuesday, 21 February 2012, 07:30 GMT
Confirmed. Updated to 3.1.5-1 this morning, indexing fails.
I can also confirm that Stefan Husmann's xiphos-webkit-svn version does the trick.
Comment by Alexander F Rødseth (xyproto) (trontonic) - Tuesday, 21 February 2012, 07:46 GMT Comment by Andrei Arici (distrohopperarched) - Tuesday, 21 February 2012, 08:17 GMT
Thank you.

Not only are errors gone with the webkit version, but there are icons that are displaying the un/indexed state of a Bible. So I guess it's all related.
Comment by Alexander F Rødseth (xyproto) (trontonic) - Monday, 27 February 2012, 08:04 GMT
Xiphos updated the 3.1.5 sources (without bumping the version number), so a patch is no longer needed to build it. Updated the package accordingly, but this bug is still there.
Comment by Andrei Arici (distrohopperarched) - Tuesday, 28 February 2012, 09:09 GMT
As a side note, keeping in mind that this bug, disables "half" of your ability to search, completely cuts you off from searching strong's numbers, prevents you from searching optimized indexes, thus restricting you to slower searches, I'd wonder if the severity of this bug (currently set to medium) is appropriate. 5 on sourceforge ?

Given that the functionality is there, (it doesn't need to be coded), this fracture, essentially makes Xiphos into a pocket knife that won't draw, for no obvious reason, because the webkit version is fixed.
Comment by Alexander F Rødseth (xyproto) (trontonic) - Tuesday, 28 February 2012, 10:17 GMT
It's an open question if the currently missing functionality is "essential" or not, but a change in Severity here is highly unlikely to affect how quickly upstream will fix the bug.

As far as I can tell, the functionality in question is missing from the official release of Xiphos.

If waiting for an update to the official package becomes unbearable (I don't think it is, yet), the usual course of action is to move the package to unsupported (AUR) instead of packaging the development versions as the official package.

Restless users can use the packages from AUR or nag upstream (preferable) :)

Hope that was clarifying.
Comment by Alexander F Rødseth (xyproto) (trontonic) - Monday, 05 March 2012, 22:35 GMT
Changing severity to "High" if it makes anyone happy :)
Comment by Alexander F Rødseth (xyproto) (trontonic) - Sunday, 11 March 2012, 16:29 GMT
This bug will be fixed once sword + xiphos has a new release. Nothing has happened on the sourceforge bug so far.
Comment by Alexander F Rødseth (xyproto) (trontonic) - Monday, 12 March 2012, 23:40 GMT
Talked to a nice sword dev on irc, and a new release of sword is expected "around the turn of the month".
Comment by Alexander F Rødseth (xyproto) (trontonic) - Friday, 13 April 2012, 18:39 GMT
No new release yet.
Comment by Alexander F Rødseth (xyproto) (trontonic) - Friday, 20 April 2012, 14:02 GMT
Latest news is that it will be released "when ready".
Comment by Alexander F Rødseth (xyproto) (trontonic) - Wednesday, 02 May 2012, 13:30 GMT
No new release yet.
Comment by Alexander F Rødseth (xyproto) (trontonic) - Wednesday, 16 May 2012, 18:12 GMT
No fix for the last two months, considering moving this package to unsupported.
Comment by Andrei Arici (distrohopperarched) - Thursday, 17 May 2012, 15:42 GMT
I just filed two serious bugs for the current version, as always, the SVN version is not affected.
Comment by Alexander F Rødseth (xyproto) (trontonic) - Saturday, 19 May 2012, 02:12 GMT
Moving to unsupported.

Loading...