Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28267 - [pm-utils] 1.4.1-3 Failed hooks do not inhibit pm-actions

Attached to Project: Arch Linux
Opened by Nathan Hulse (rufflove) - Sunday, 05 February 2012, 16:28 GMT
Last edited by Jan de Groot (JGC) - Thursday, 12 September 2013, 12:39 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:

Hooks that produce an exit code other than 0 do not inhibit pm-actions because the exit status of log is used instead (which always returns 0).

A bug was submitted upstream roughly 14 months ago and a patch provided (see https://bugs.freedesktop.org/show_bug.cgi?id=32210), but the issue has yet to be resolved. I am therefore submitting a bug here in the hope that a fix may be deemed appropriate in the case, given that the matter has remained outstanding this long.

Steps to reproduce:

1) Create a hook that returns exit status 1
2) Execute pm-suspend
This task depends upon

Closed by  Jan de Groot (JGC)
Thursday, 12 September 2013, 12:39 GMT
Reason for closing:  Won't implement
Additional comments about closing:  We will not fix this. pm-utils is on our list of stuff getting dropped.
Comment by Benjamin Robin (benjarobin) - Saturday, 23 June 2012, 15:19 GMT
Fix attached, please patch pm-utils package since this issue is not fixed upstream...

Loading...