Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#25771 - [smbclient] Breaking xbmc

Attached to Project: Arch Linux
Opened by lisa martin (lymphatik) - Friday, 26 August 2011, 14:09 GMT
Last edited by Ionut Biru (wonder) - Sunday, 28 August 2011, 09:21 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 13
Private No

Details

Description: after updating to smbclient 3.6.0-4 I get invalid pointer error when I try to launch xbmc. If I go back to smbclient 3.6.0-1 everything works fine


Additional info:
* package version(s) smbclient-3.6.0-4



Steps to reproduce: just install smbclient-3.6.0-4 and xbmc
This task depends upon

Closed by  Ionut Biru (wonder)
Sunday, 28 August 2011, 09:21 GMT
Reason for closing:  Fixed
Additional comments about closing:  smbclient-3.6.0-7
Comment by Carlos (cyberconan) - Friday, 26 August 2011, 14:55 GMT
Same bug and same temporal solution.
Comment by Tobias Powalowski (tpowa) - Friday, 26 August 2011, 15:00 GMT
Does rebuilding xbmc help?
Comment by Carlos (cyberconan) - Friday, 26 August 2011, 15:03 GMT
Maybe...
Comment by Tobias Powalowski (tpowa) - Friday, 26 August 2011, 15:07 GMT
Please do that and confirm.
Comment by Jakob Matthes (jakobm) - Friday, 26 August 2011, 17:29 GMT
I rebuilt xbmc without improvement.
See attachment for trace and crashlog, I don't know how to debug this.
Comment by lisa martin (lymphatik) - Friday, 26 August 2011, 18:57 GMT
I rebuilt xbmc-git and got the same error.
Comment by Ionut Biru (wonder) - Friday, 26 August 2011, 20:11 GMT
maybe is related to  FS#25774  and that samba is totally busted now
Comment by Ike Devolder (BlackEagle) - Saturday, 27 August 2011, 10:36 GMT
i can also confirm the problem is fully related to smbclient 3.6.0-4

rebuilding does not bring solution, only downgrading smbclient
Comment by Luke (masteryod) - Saturday, 27 August 2011, 11:13 GMT
yep, same here, downgrade to 3.6.0-1 helps

[edit]

upgrade to smbclient-3.6.0-5-x86_64 - didn't solved this either:
Comment by Dario (DmA) - Saturday, 27 August 2011, 11:59 GMT Comment by Jakob Matthes (jakobm) - Saturday, 27 August 2011, 12:44 GMT
I rebuilt it, it now just fails with "cannot open shared object file", exactly the same issue as in  FS#25774 
Comment by John (graysky) - Saturday, 27 August 2011, 14:49 GMT
Not really adding to the solution here but I can confirm this breakage on my x86_64 box.
Comment by S├ębastien Luttringer (seblu) - Saturday, 27 August 2011, 19:40 GMT
same issue with smbclient-3.6.0-6
Comment by Ike Devolder (BlackEagle) - Sunday, 28 August 2011, 08:16 GMT
it looks like its all working fine with 3.6.0-7

thx
Comment by Luke (masteryod) - Sunday, 28 August 2011, 08:50 GMT
smbclient-3.6.0-7 seems to be ok, good work people, thanks! :)
Comment by John (gee) - Sunday, 28 August 2011, 09:20 GMT
Same here, it works with -7.

Loading...