Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#25337 - [grub,grub2] don't handle new kernel naming sheme

Attached to Project: Arch Linux
Opened by Ike Devolder (BlackEagle) - Sunday, 31 July 2011, 13:18 GMT
Last edited by Ronald van Haren (pressh) - Wednesday, 03 August 2011, 19:59 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ronald van Haren (pressh)
Architecture All
Severity High
Priority High
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

grub2-common :: /etc/grub.d/10_linux contains kernel for the creation of normal and fallback entries

this is set with a patch

new patch attached for the initramfs-linux naming of the images

Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Ronald van Haren (pressh)
Wednesday, 03 August 2011, 19:59 GMT
Reason for closing:  Fixed
Additional comments about closing:  grub 0.97-18 and grub2 1.99-4
Comment by Matthias Dienstbier (fs4000) - Sunday, 31 July 2011, 19:50 GMT
This change would make grub2 incompatible to kernel26-lts. I admit that something needs to change here, but we shouldn't do it now. When all kernel packages use the new naming scheme vmlinuz-* and initramfs-*.img we can drop most parts of that patch.
We also don't need that UUID= to /dev/disk/by-uuid/ change anymore because mkinitcpio is capable of handling this now.
Comment by Ike Devolder (BlackEagle) - Monday, 01 August 2011, 06:41 GMT
sorry but then the patch needs extending because with the current initramfs-linux naming of the images grub2 will not detect the image at all if you dont leave the compat symlinks there

should it have been initrd-${_kernelname}.img then the patch above can be removed ( then the automatic fallback entry will need to be entered manually )

when i'm back on a linux machine i will update the patch so kernel26-lts stays usable too
Comment by Matthias Dienstbier (fs4000) - Monday, 01 August 2011, 14:04 GMT
I reworked the patch to ignore vmlinuz26 compat symlink and to include the new fallback naming scheme. I hope this does what you want.
It will not work with the kernel26 package (but with the new linux package).
Comment by Ronald van Haren (pressh) - Tuesday, 02 August 2011, 07:23 GMT
Thanks for the patch.

[strike]Please don't combine multiple (unrelated) fixes in one patch. (I mean the color stuff... I'm not even sure that is the correct way to do it, but please file another bug report if you think it is broken now).[/strike] Sorry, it was already in the patch I applied, I didn't look

I'll take a look at the rest of your patch later today.
Comment by Ronald van Haren (pressh) - Tuesday, 02 August 2011, 07:35 GMT
Changed topic title to reflect that grub in [core] is also affected.
Comment by Ike Devolder (BlackEagle) - Wednesday, 03 August 2011, 17:42 GMT
ONLY CONCERNING GRUB2

just tested with a small update

for indication
installed linux-bede (without kernel26 compat links)
installed kernel26-lts

output: see ha.cfg

update: archlinux_grub2_mkconfig_fixes.patch.new (updated patch)
to reflect the changes in the patch: archlinux_grub2_mkconfig_fixes.patch.diff
Comment by Ronald van Haren (pressh) - Wednesday, 03 August 2011, 19:59 GMT
Thanks Matthias (and Ike), your patch seems to work just fine, I applied it in 1.99-4

Loading...