Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#25225 - [gnome-vfs] does not work with libgcrypt 1.5.0

Attached to Project: Arch Linux
Opened by Patrick Melo (patrickmelo) - Friday, 22 July 2011, 19:42 GMT
Last edited by Ionut Biru (wonder) - Tuesday, 26 July 2011, 10:41 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ionut Biru (wonder)
Jan Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No



the current gnome-vfs package does to work and fails to compile against libgcrypt 1.5.0
It seems that with libgcrypt 1.5 the compiler lib flags have changed.

I have a package in AUR that's already pacthed and working, and the patch is attatched in this bug report.

I hope it helps.

AUR package:

Additional info:
package versions: libgcrypt 1.5.0-1 and gnome-vfs 2.24.4-3

Steps to reproduce:
try to use any software that uses libgnomevfs (SoundConverter as an example)
This task depends upon

Closed by  Ionut Biru (wonder)
Tuesday, 26 July 2011, 10:41 GMT
Reason for closing:  Fixed
Additional comments about closing:  gnome-vfs 2.24.4-4
Comment by Stefan Husmann (stefanhusmann) - Sunday, 24 July 2011, 09:40 GMT
Also my AUR package amide is affected.