Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#25198 - [soundconverter] fail to start

Attached to Project: Community Packages
Opened by Diep Pham Van (favadi) - Thursday, 21 July 2011, 02:51 GMT
Last edited by Stefan Husmann (stefanhusmann) - Tuesday, 26 July 2011, 22:19 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Jan de Groot (JGC)
Stefan Husmann (stefanhusmann)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
soundconverter fail to start.

Start from the console:

SoundConverter 1.5.4
error: /usr/lib/libgnomevfs-2.so.0: undefined symbol: gcry_control
SoundConverter needs gnome-python 2.10!

Additional info:
* package version: soundconverter 1.5.4-1



Steps to reproduce:
fresh install archlinux and install soundconverter.
This task depends upon

Closed by  Stefan Husmann (stefanhusmann)
Tuesday, 26 July 2011, 22:19 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed by fix of gnome-vfs package
Comment by Stefan Husmann (stefanhusmann) - Friday, 22 July 2011, 00:13 GMT
Confirmed. No solution available.
Comment by Patrick Melo (patrickmelo) - Friday, 22 July 2011, 19:31 GMT
Hi there, I was having the same problem.

The problem is related to the gnome-vfs package, it needed to be patched and recompiled against libgcrypt 1.5.0.
I've made a package that solves the problem (http://aur.archlinux.org/packages.php?ID=50918)

I've attached the patch.

I hope it helps.
Comment by Patrick Melo (patrickmelo) - Friday, 22 July 2011, 19:33 GMT
Does anyone know how can I reach the official maintainer to give him the patch?
Comment by Stefan Husmann (stefanhusmann) - Saturday, 23 July 2011, 06:09 GMT
The normal way is to file a bug report for gnome-vfs. But I added him to the assignees of this bug report.
Comment by Patrick Melo (patrickmelo) - Saturday, 23 July 2011, 06:11 GMT
Thanks, I've filed a bug report for gnome-vfs :)
Comment by Stefan Husmann (stefanhusmann) - Saturday, 23 July 2011, 08:23 GMT
Thank you.
Comment by Stefan Husmann (stefanhusmann) - Tuesday, 26 July 2011, 22:18 GMT
As the gnome-vfs bug report was closed "Fixed", and I can run soundconverter without problems now, I close this, too.

Loading...