Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#25145 - [vlc] fail on start - with workaround

Attached to Project: Arch Linux
Opened by paul (pwt) - Saturday, 16 July 2011, 16:49 GMT
Last edited by Giovanni Scafora (giovanni) - Friday, 12 August 2011, 21:37 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Giovanni Scafora (giovanni)
Architecture i686
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
vls fails to start with the following message:

VLC media player 1.1.11 The Luggage (revision exported)
Blocked: call to unsetenv("DBUS_ACTIVATION_ADDRESS")
Blocked: call to unsetenv("DBUS_ACTIVATION_BUS_TYPE")
[0x1986120] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Blocked: call to setlocale(6, "")
vlc: symbol lookup error: /usr/lib/libXrandr.so.2: undefined symbol: XextFindDisplay

In fact, during the install process, a command in the postinst script fails to run. Simply executing the comand in a terminal solves the issue:
/usr/lib/vlc/vlc-cache-gen -f usr/lib/vlc/plugins

Additional info:
* package version(s): 1.1.11-1
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Giovanni Scafora (giovanni)
Friday, 12 August 2011, 21:37 GMT
Reason for closing:  Works for me
Comment by Jeff Cook (cookiecaper) - Saturday, 16 July 2011, 19:42 GMT
Same problem here. Wasn't aware running vlc-cache-gen could fix the problem, I've been compiling from ABS. This has occurred for me on 1.1.10, too.

See also https://bbs.archlinux.org/viewtopic.php?pid=961702 -- several others have the same issue.
Comment by Jeff Cook (cookiecaper) - Sunday, 17 July 2011, 17:08 GMT
fyi, /usr/lib/vlc/vlc-cache-gen -f usr/lib/vlc/plugins segfaults for me even when invoked directly from the shell until I rebuild the VLC package.
Comment by Giovanni Scafora (giovanni) - Monday, 18 July 2011, 22:02 GMT
vlc works fine on my local machine, so I cannot reproduce that issue.
Comment by Jeff Cook (cookiecaper) - Monday, 18 July 2011, 22:09 GMT
I'm running x86_64, not sure if that has anything to do with it or not.
Comment by Giovanni Scafora (giovanni) - Monday, 18 July 2011, 22:12 GMT
me too...I'm running arch linux on i686 and x86_64 and vlc works fine for both architectures here.
I cannot reproduce this issue on my local machine...
Comment by paul (pwt) - Monday, 18 July 2011, 22:25 GMT
I am running arch i686 with kernel26-lts.

Giovanni, have you tried removing vlc and all config files and reinstalling it. We have a segfault on the install script.
Comment by John (forkboy) - Tuesday, 19 July 2011, 07:40 GMT
Is this the same issue as https://bbs.archlinux.org/viewtopic.php?id=121932? If so installing libxpm fixes it.
Comment by Giovanni Scafora (giovanni) - Tuesday, 19 July 2011, 08:21 GMT
I'm adding libxpm as depends in vlc-1.1.11-2
Please, try out and let me know.
Comment by Jeff Cook (cookiecaper) - Tuesday, 19 July 2011, 09:49 GMT
Sadly, this does not fix the issue for me. I already had libxpm installed.

>(2/2) upgrading vlc [##############################################] 100%
>/tmp/alpm_ebtvjR/.INSTALL: line 1: 3261 Segmentation fault usr/lib/vlc/vlc-cache-gen -f usr/lib/vlc/plugins

Still get this segmentation fault on the install script after the upgrade to 1.1.11-2.

When I try to start VLC:
$ vlc
VLC media player 1.1.11 The Luggage (revision exported)
Blocked: call to unsetenv("DBUS_ACTIVATION_ADDRESS")
Blocked: call to unsetenv("DBUS_ACTIVATION_BUS_TYPE")
[0x1bbc200] main libvlc error: option http-user-agent does not exist
[0x1bbc200] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Blocked: call to setlocale(6, "")
vlc: symbol lookup error: /usr/lib/libXrandr.so.2: undefined symbol: XextFindDisplay
Comment by Giovanni Scafora (giovanni) - Tuesday, 19 July 2011, 09:52 GMT
I cannot reproduce that issue on my local machine and I haven't got any segmentation fault on the install script after the upgrade.
Comment by Jeff Cook (cookiecaper) - Tuesday, 19 July 2011, 10:05 GMT
This does *NOT* occur on my laptop, which is a very recent installation of Arch. I suppose that installs that have been around for a while have a conflict somewhere. Perhaps someone should attempt to debug the segfault in the installation script. Please note that VLC *does* work for me after I compile the PKGBUILD from ABS. My suspicion is that some X.org files are getting fuddled, perhaps it also involves usage of some X.org/video related *-git packages. I can try on my older laptop soon and see if I get the segfault there.
Comment by Jeff Cook (cookiecaper) - Tuesday, 19 July 2011, 10:34 GMT
If I run vlc-cache-gen with sudo there is no segmentation fault and VLC presents a "remote control" interface instead killing itself with a fatal error. strace appeared like there was a permissions error somewhere. This is still not solved but a step in the right direction -- any ideas on which directories specifically I should chmod?

I now see this:

$ vlc
VLC media player 1.1.11 The Luggage (revision exported)
[0x1c73f50] main stream error: possibly corrupt module cache
[0x1ca5fb0] main demux meta error: possibly corrupt module cache
[0x1cb0680] main xml error: possibly corrupt module cache
Blocked: call to unsetenv("DBUS_ACTIVATION_ADDRESS")
Blocked: call to unsetenv("DBUS_ACTIVATION_BUS_TYPE")
[0x1b91200] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[0x1c6fff0] main interface error: possibly corrupt module cache
[0x1c6fff0] main interface error: possibly corrupt module cache
[0x1c6fff0] [rc] lua interface: Listening on host "*console".
VLC media player 1.1.11 The Luggage
Remote control interface initialized. Type `help' for help.
Comment by Giovanni Scafora (giovanni) - Saturday, 30 July 2011, 17:10 GMT
I've tried removing vlc and all config files and reinstalling it, and I have not a segfault on the install script.
I've never reproduced this problem on my local machines.

Loading...