Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#24532 - [mkvtoolnix] enable Qt GUI

Attached to Project: Arch Linux
Opened by Ruben Van Boxem (rubenvb) - Wednesday, 01 June 2011, 14:16 GMT
Last edited by Maxime Gauduin (Alucryd) - Sunday, 11 October 2015, 14:20 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Giovanni Scafora (giovanni)
Maxime Gauduin (Alucryd)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:
The mkvtoolnix source has a Qt Gui. This should be enabled and the gtk dependency should be optional.

Additional info:
* package version: 4.8.0-2
This task depends upon

Closed by  Maxime Gauduin (Alucryd)
Sunday, 11 October 2015, 14:20 GMT
Reason for closing:  Fixed
Additional comments about closing:  8.4.0-2
Comment by Andrea Scarpino (BaSh) - Wednesday, 01 June 2011, 14:56 GMT
I don't use this package, but I'd like to understand why the maintainer should enable the Qt gui which is disabled by default:
--enable-qt compile the Qt version of the GUIs (no)
Comment by Ruben Van Boxem (rubenvb) - Wednesday, 01 June 2011, 15:46 GMT
@Andrea: Then I can use it without the ugly QtCurve GTK widgets. The mkvtoolnix author added the feature for reason. Perhaps this package should be split into three:
--> mkvtoolnix: commandline, without gui
--> mkvtoolnix-gui: gtk/wxwidgets frontend
--> mkvtoolnix-qt: Qt gui

It'd be nice to have, and won't cause that much problems. (There's already a mkvtoolnix-nogui in AUR, but then of course no matching gui packages)
Comment by Andrea Scarpino (BaSh) - Wednesday, 01 June 2011, 15:57 GMT
What I mean is that IF the maintainer enable the Qt gui, the GTK users will ask him to enable the GTK gui. In that case we should keep the default I guess.

Anyway a three-splitted package is the best option.
Comment by Artem A Klevtsov (unikum) - Friday, 10 June 2011, 19:36 GMT
How I should change the PKGBUILD to build mkvtoolnix with Qt GUI?
./configure --prefix=/usr \
--with-boost-libdir=/usr/lib \
--enable-qt
./drake
That's right?
Comment by nyfair (nyfair) - Tuesday, 28 July 2015, 13:21 GMT
4 years later, the Qt GUI becomes default and it will even warn you that the wxWidgets ones were deprecated.
Comment by Benjamin Robin (benjarobin) - Tuesday, 22 September 2015, 12:27 GMT
This bug report is kind of a duplicate of this one : https://bugs.archlinux.org/task/45439

Loading...