Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#24207 - [kernel26] xen support missing in i686

Attached to Project: Arch Linux
Opened by Yang (hongy19) - Tuesday, 10 May 2011, 11:51 GMT
Last edited by Thomas Bächler (brain0) - Tuesday, 10 May 2011, 18:49 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture i686
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
For stock kernel26, the X86_64 has the xen support, but i686 missing this

Additional info:
* package version(s)
kernel26 2.6.38.5-1
* config and/or log files etc.


Steps to reproduce:
when grep the /proc/config.gz, there is no xen related items. But in x86_64, there are xen support. I don't know why.

[hongy19@Archlinux ~]$ zgrep -i xen /proc/config.gz
CONFIG_XEN=y
CONFIG_XEN_DOM0=y
CONFIG_XEN_PRIVILEGED_GUEST=y
CONFIG_XEN_PVHVM=y
CONFIG_XEN_MAX_DOMAIN_MEMORY=128
CONFIG_XEN_SAVE_RESTORE=y
# CONFIG_XEN_DEBUG_FS is not set
CONFIG_PCI_XEN=y
CONFIG_XEN_PCIDEV_FRONTEND=m
CONFIG_XEN_BLKDEV_FRONTEND=m
CONFIG_NETXEN_NIC=m
CONFIG_XEN_NETDEV_FRONTEND=m
CONFIG_XEN_KBDDEV_FRONTEND=m
CONFIG_HVC_XEN=y
CONFIG_XEN_FBDEV_FRONTEND=m
# Xen driver support
CONFIG_XEN_BALLOON=y
CONFIG_XEN_SCRUB_PAGES=y
CONFIG_XEN_DEV_EVTCHN=m
CONFIG_XEN_BACKEND=y
CONFIG_XENFS=m
CONFIG_XEN_COMPAT_XENFS=y
CONFIG_XEN_SYS_HYPERVISOR=y
CONFIG_XEN_XENBUS_FRONTEND=m
CONFIG_XEN_GNTDEV=m
CONFIG_XEN_PLATFORM_PCI=m
CONFIG_SWIOTLB_XEN=y
This task depends upon

Closed by  Thomas Bächler (brain0)
Tuesday, 10 May 2011, 18:49 GMT
Reason for closing:  Won't fix
Comment by Ike Devolder (BlackEagle) - Tuesday, 10 May 2011, 15:48 GMT
that is very normal,

the default i686 kernel has also no highmem support, and no 64 bit memory addressing

as a result of that there is no xen support available ( if i'm correct )
Comment by Yang (hongy19) - Tuesday, 10 May 2011, 16:38 GMT
but kernel26-xen(2.6.37) in AUR support xen. So I guess highmem is not a reason?
Comment by Thomas Bächler (brain0) - Tuesday, 10 May 2011, 18:49 GMT
It's missing because we don't want to enable HIGHMEM on i686, HIGHMEM is a dependency for Xen. It's missing because we don't think it is needed on i686. Use x86_64.

Loading...