Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23701 - [udisks] udisks 1.0.3 fails to mount ntfs drive with kde

Attached to Project: Arch Linux
Opened by Victor Gavrish (loonyphoenix) - Monday, 11 April 2011, 15:02 GMT
Last edited by Ionut Biru (wonder) - Tuesday, 03 May 2011, 20:33 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Ionut Biru (wonder)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:
testing udisks fails to mount my external ntfs drive with the error:
org.freedesktop.UDisks.Error.Failed: Requested filesystem type is neither
well-known nor in /proc/filesystems nor in /etc/filesystems

I understand this is an upstream problem, but since arch saw fit to package an unreleased version of udisks maybe a workaround could also be arranged?.. :)

Reported the bug upstream too, of course:

https://bugs.kde.org/show_bug.cgi?id=270689
This task depends upon

Closed by  Ionut Biru (wonder)
Tuesday, 03 May 2011, 20:33 GMT
Reason for closing:  Fixed
Additional comments about closing:  1.0.3-2
Comment by Ionut Biru (wonder) - Monday, 11 April 2011, 15:09 GMT Comment by Jason Miesionczek (atmospherian) - Tuesday, 12 April 2011, 15:52 GMT
workaround:

# cp /proc/filesystems /etc
# vi /etc/filesystems
append vfat and ntfs to this list and save

once you do that you should be able to mount the drives. just did this and it worked for me, YMMV.
Comment by Ionut Biru (wonder) - Tuesday, 12 April 2011, 16:05 GMT
here is the upstream report https://bugs.freedesktop.org/show_bug.cgi?id=32232

you can add a comment saying that the current implementation breaks mounting usb external ntfs partitions
Comment by Anonymous Submitter - Wednesday, 13 April 2011, 10:51 GMT
THis also occurs with pcmanfm-git (+ libfm-git) for external usb drives with ntfs-3g.
Comment by Ionut Biru (wonder) - Saturday, 30 April 2011, 15:42 GMT
i don't see anyone commenting upstream. I'm going to close this bug as not a bug since it works fine with nautilus
Comment by Alessandro Nakamuta (alessandro_ufms) - Sunday, 01 May 2011, 18:34 GMT
I've installed kde today and I had this problem. The /etc/filesystems trick works for me.
Comment by Benjamin Robin (benjarobin) - Monday, 02 May 2011, 19:07 GMT
echo "ntfs" >> /etc/filesystems
Solved the problem.
Adding /etc/filesystems to the ntfs-3g package doesn't look like a good idea... But this will be great to fix this problem ASAP :-)

Edit: Never mind, it's looks like it's fixed in the commit of 2011-03-15 by David Zeuthen. We just need to wait the new release, or we can patch our package
Comment by Ionut Biru (wonder) - Monday, 02 May 2011, 19:10 GMT
see my comment. I won't do anything until i see something upstream.
Comment by Ionut Biru (wonder) - Monday, 02 May 2011, 23:16 GMT
@Benjamin what are you talking about? our udisks is from 10 april, last commit is from 5 april which means that it contains that "fix".

I already pointed out why ntfs mounting is broken and the upstream bug report.
Comment by Mihai Militaru (akephalos) - Tuesday, 03 May 2011, 04:51 GMT
I'm having this problem for the first time (udisks 1.0.3-1).
Comment by Benjamin Robin (benjarobin) - Tuesday, 03 May 2011, 19:14 GMT
There is just a missing comma at line ~ 5905

static const gchar *well_known_filesystems[] =
{
"btrfs",
"ext2",
"ext3",
"ext4",
"udf",
"iso9660",
"xfs",
"jfs",
"nilfs",
"reiserfs",
"reiser4",
"msdos",
"umsdos",
"vfat",
"exfat" <---- Missing comma
"ntfs",
NULL,
};
Comment by Ionut Biru (wonder) - Tuesday, 03 May 2011, 19:35 GMT
good catch. i'll push a fix soon

Loading...