Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#23644 - [gnome-tweak-tool] - crash on start

Attached to Project: Arch Linux
Opened by Ng Oon-Ee (ngoonee) - Friday, 08 April 2011, 03:56 GMT
Last edited by Andrea Scarpino (BaSh) - Monday, 15 October 2012, 10:16 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ionut Biru (wonder)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No


Caching gsettings: <gtweak.gsettings._GSettingsSchema: org.gnome.desktop.interface>
Caching gconf: <gtweak.gconf.GConfSetting: /apps/metacity/general/titlebar_font> (--short-docs)
Caching gconf: <gtweak.gconf.GConfSetting: /apps/metacity/general/titlebar_font> (--long-docs)
Caching gconf: <gtweak.gconf.GConfSetting: /apps/metacity/general/titlebar_font> (--short-docs)
Caching gsettings: <gtweak.gsettings._GSettingsSchema: org.gnome.settings-daemon.plugins.xsettings>

GLib-GIO-ERROR **: Settings schema '' is not installed

[1] 1377 abort (core dumped) gnome-tweak-tool

Additional info:
* package version(s)
gnome-tweak-tool-3.0.0-1, fully updated from [testing]/[community-testing] without [gnome-unstable]

Steps to reproduce:
Just start it.
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Monday, 15 October 2012, 10:16 GMT
Reason for closing:  Fixed
Additional comments about closing:  gnome-tweak-tool 3.6.0-1
Comment by Ionut Biru (wonder) - Friday, 08 April 2011, 05:28 GMT
i guess you chose not to install gnome-shell? it seems that gnome-tweak-tool doesn't silently ignore schemas and hide them, instead it crashes.

This is a crash and it should be reported upstream.

Please do it and paste the link
Comment by Ng Oon-Ee (ngoonee) - Friday, 08 April 2011, 05:39 GMT Comment by Thor (thorflanders) - Sunday, 08 May 2011, 08:15 GMT
Clean install, 32-bit setup here, using the (classic) fallback settings here, dont like the fanfare, but that's personal.
Anyway, same for the 32-bit setting, and in fallback, and a clean upgreade. Dump is identical to the one posted. Not re-posting the obvious, and not pushing, anymore...

Waiting and seeing...

Comment by Lukas Sabota (punkrockguy318) - Wednesday, 25 May 2011, 03:06 GMT
Can also confirm here on my 64bit XFCE desktop. Dump is also identical on my machine
Comment by György Balló (City-busz) - Sunday, 02 October 2011, 03:42 GMT
Please add gnome-shell as dependency, because it's still not fixed by upstream in version 3.2.0.
Comment by György Balló (City-busz) - Friday, 24 August 2012, 07:28 GMT
It still requires a dependency on gnome-shell, but it was wrongly removed from 3.3.4-1 package.
Comment by Greg (dolby) - Monday, 15 October 2012, 03:03 GMT
Still a problem in 3.6 from gnome-unstable? Upstream report has been fixed since January.
Comment by György Balló (City-busz) - Monday, 15 October 2012, 03:38 GMT
I've just checked gnome-tweak-tool version 3.6.0, and it fixes the problem, so gnome-shell is no longer requires as a dependency!