Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#23392 - [eclipse] isn't compatible with xulrunner 2.0

Attached to Project: Arch Linux
Opened by XazZ (XazZ) - Tuesday, 22 March 2011, 22:29 GMT
Last edited by Paul Mattal (paul) - Sunday, 26 June 2011, 11:21 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Paul Mattal (paul)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 12
Private No


Eclipse crashes for me whenever I try to use it's code completion feature.
I believe it's due to the xulrunner update.
Maybe eclipse needs a rebuild?

Additional info:
* package version(s)
Eclipse 3.6.2-1

* config and/or log files etc.
Updated packages:
upgraded cairo (1.10.2-1 -> 1.10.2-2)
installed libnotify (0.7.1-1.1)
upgraded xulrunner ( -> 2.0-1)
upgraded firefox (3.6.15-1 -> 4.0-1)
upgraded flashplugin ( ->
installed libsoup (2.32.2-1)
installed libwebkit (1.2.7-1)
upgraded libproxy (0.4.6-3 -> 0.4.6-4)
upgraded linux-firmware (20110201-1 -> 20110227-1)
upgraded openal (1.12.854-2 -> 1.13-1)
upgraded vlc (1.1.7-5 -> 1.1.7-6)

Eclipse's crash log says:
# Problematic frame:
# C []

I attached a part of the crash log.

Steps to reproduce:
Try to use Eclipse's code completion (in a Java project type "System." and press CTRL+Space).

PS: I won't have access to my computer until Sunday, so if you need more information you may have to wait until then (sorry for that).
This task depends upon

Closed by  Paul Mattal (paul)
Sunday, 26 June 2011, 11:21 GMT
Reason for closing:  Fixed
Additional comments about closing:  Resolved with eclipse 3.7-1.
Comment by Andrea Scarpino (BaSh) - Tuesday, 22 March 2011, 23:23 GMT
Seems that eclipse isn't compatible with xulrunner 2.0, see ubuntu changelog:
Comment by Shang Cai (shangc) - Wednesday, 23 March 2011, 06:33 GMT
downgrading xulrunner to solves the problem, if you are not using firefox 4
Comment by Maxwell Draven (Ravenman) - Wednesday, 23 March 2011, 13:58 GMT
I have this issue too, I'm using Firefox 4.0 in my machine. What can I do? (Downgrade isn't a valid choice for me).
Comment by Ionut Biru (wonder) - Wednesday, 23 March 2011, 14:04 GMT
somebody posted a solution in the forums:

in /usr/share/eclipse/eclipse.ini add this following line

Comment by Maxwell Draven (Ravenman) - Wednesday, 23 March 2011, 21:02 GMT
@Wonder: Thanks by your help but didn't works for me. The console shows this:

[user@archer_pc ~]$ eclipse
# A fatal error has been detected by the Java Runtime Environment:
# SIGSEGV (0xb) at pc=0x625be5a5, pid=1623, tid=3077576384
# JRE version: 6.0_22-b22
# Java VM: OpenJDK Client VM (19.0-b09 mixed mode linux-x86 )
# Derivative: IcedTea6 1.10
# Distribution: Custom build (Wed Mar 2 23:13:58 UTC 2011)
# Problematic frame:
# C []
# An error report file with more information is saved as:
# /home/user/hs_err_pid1623.log
# If you would like to submit a bug report, please include
# instructions how to reproduce the bug and visit:
/usr/bin/eclipse: line 4: 1623 Aborted ${ECLIPSE_HOME}/eclipse "$@"
Comment by Ayr0 (ayr0) - Thursday, 24 March 2011, 03:47 GMT
You need to add the following line to eclipse.ini


Save, and the crashes will go away.
Comment by Maxwell Draven (Ravenman) - Thursday, 24 March 2011, 15:27 GMT
@Ayr0 Thank you very much, the workaround worked for me and the crashes gone away.
Comment by Benjamin Robin (benjarobin) - Sunday, 27 March 2011, 10:38 GMT
I have created a bug report:
The right solution (for me) is using : -Dorg.eclipse.swt.browser.UseWebKitGTK=true
If I use -Dorg.eclipse.swt.browser.XULRunnerPath==/usr/lib/xulrunner-2.0/ it doesn't crash, but the documentation looks ugly.
Comment by Thor (thorflanders) - Wednesday, 30 March 2011, 07:32 GMT

Just updated yesterday, went from xulrunner-1.9.2 to xulrunner-2.0, FireFox became FireFox 4.
I use Eclipse Helios 3.6.2-1.

Symptoms : hovering over a Class name should produce a yellow-ish popup with package info. Eclipse crashes there.
- running from the console with "-debug" as parameter but there is nothing right after the crash, a lot before, nothing after. (cannot find eclipse.log - did a system seek)
- forcing eclipse to use the old xulrunner with "- Dorg.eclipse.swt.browser.XULRunnerPath==/usr/lib/xulrunner-1.9.2/" (tnx ayr0) but that failed, as well as the original setting -Dorg.eclipse.swt.browser.XULRunnerPath==/usr/lib/xulrunner-2.0/
- tried this line too : -Dorg.eclipse.swt.browser.UseWebKitGTK=true without any luck...

Occasiolnally this is what I do get:

[CODE]** (bug-buddy:9290): CRITICAL **: Failed to parse arguments: Cannot open display:[/CODE]

Sorry I cannot give any feedback, dont know where these logs are...not where they _should_ be anyway.

Hoping for a solution

PS : this is my first bug report, I hope to have followed the guidelines somewhat...
EDIT : @ Benjamin Robin : I read the bug report you entered and applied the command line that worked for you, where you force elcipse to use the "proper" xulrunner - this workaround seems to work for me too, thanks for this invaluable help!
Comment by Benjamin Robin (benjarobin) - Wednesday, 30 March 2011, 08:45 GMT
To run eclipse with WebKit, you need to install webkit :) => pacman -S libwebkit
Then start eclipse this way: eclipse -vmargs -Dorg.eclipse.swt.browser.UseWebKitGTK=true
Or just add: -Dorg.eclipse.swt.browser.UseWebKitGTK=true at the end of this file: /usr/share/eclipse/eclipse.ini
Comment by Flavio Coutinho da Costa (flaviocdc) - Wednesday, 06 April 2011, 02:08 GMT
Adding "-Dorg.eclipse.swt.browser.UseWebKitGTK=true" also fixed my problem.
Comment by pete (drg006) - Monday, 23 May 2011, 16:45 GMT
I'm seeing this problem again but the work-around (-Dorg.eclipse.swt.browser.UseWebKitGTK=true) is no longer working.
Comment by pete (drg006) - Monday, 23 May 2011, 16:58 GMT
Work-around: sudo ln -s /usr/lib/ /usr/lib/
Comment by Benjamin Robin (benjarobin) - Monday, 23 May 2011, 17:23 GMT
Did you read the official bug report : and/or ?
Eclipse is not compatiible with xulrunner 2 and libwebkit > 1.3
The workaround for now is to install old libwebkit (1.2.7)
Comment by Mehmet Ozgur Bayhan (matafleur) - Sunday, 12 June 2011, 10:11 GMT
Is there any chance to merge xulrunner version like python 2.x and 3.x?

I use a workaround solution with xulrunner 1.9.x and firefox4 with static libraries.But it is not a good solution like all above posts over here.
Comment by Benjamin Robin (benjarobin) - Sunday, 12 June 2011, 14:31 GMT
The only right solution is to install eclipse 3.7 (It's stable and in version RC)
I personnaly use an other solution : Copy the lib of libwebkit 1.2.7 into /usr/lib/ but I will upgrade to 3.7 soon.
Comment by Mehmet Ozgur Bayhan (matafleur) - Sunday, 12 June 2011, 15:52 GMT
Not right so much.Some plugins for eclipse still needs 3.4 3.5 or 3.6.So somebody still needs older versions of eclipse(especially j2ee users).Newer is the best is not true everytime.