Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23381 - [nvidia,xorg,kernel] Resizing windows halts graphics

Attached to Project: Arch Linux
Opened by João Rodrigues (gothicknight) - Tuesday, 22 March 2011, 10:36 GMT
Last edited by Ionut Biru (wonder) - Thursday, 16 June 2011, 09:36 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan de Groot (JGC)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 51
Private No

Details

Description:

When resizing a terminal window (konsole) under KDE 4.6.1 [extra] with Nvidia from [testing] plus kernel 2.6.28 [testing] it will halt the entire desktop only leaving the SysRq keys available to reboot the system safely.

I will test if downgrading to stable nvidia/kernel solves the problem.

Additional info:
* package version(s)
KDE: 4.6.1
kernel26: 2.6.38.1
nvidia: 270.30-1
* config and/or log files etc.
N/A


Steps to reproduce:
Just resize konsole.
This task depends upon

Closed by  Ionut Biru (wonder)
Thursday, 16 June 2011, 09:36 GMT
Reason for closing:  Fixed
Additional comments about closing:  nvidia 275.09.07
Comment by João Rodrigues (gothicknight) - Tuesday, 22 March 2011, 10:53 GMT
Confirmed the combination of nvidia/xorg/kernel from testing is the reason for this issue. Reverting back to extra shows no issues.
Comment by widowild (wido) - Tuesday, 22 March 2011, 14:50 GMT
me too with a gnome-terminal and gvim (nvidia,xorg,kernel) from testing
Comment by Johan Thorén (kveras) - Tuesday, 22 March 2011, 15:59 GMT
I had the same problem, but changing from Terminus-font to monospace solved the problem.
Comment by João Rodrigues (gothicknight) - Wednesday, 23 March 2011, 23:22 GMT
Testing with gnome-shell [gnome-unstable] window resize works just fine.
Comment by Bogdan (JokerBoy) - Thursday, 24 March 2011, 22:20 GMT
same here with kde+urxvt and nvidia+xorg+kernel from testing.
Comment by Joshua Reno (mrsaturn) - Friday, 25 March 2011, 00:54 GMT
this also happens to me, latest nvidia and kernel from testing, however i do not experience freezes and if any window is large enough you only get a pure black window. happens to every desktop environment/wm etc.
Comment by Bogdan (JokerBoy) - Saturday, 26 March 2011, 18:32 GMT
I think it's related to nvidia driver 270.30. I'm not using testing, but while maximizing a thumb (js code) in firefox my system freeze for ~30 sec.

Attached something from dmesg.
   nvrm.log (0.3 KiB)
Comment by Andreas (misc) - Monday, 28 March 2011, 18:20 GMT
I get similar freezes lately, most often when I open a new tab in Chromium. Same kernel & nvidia, but xmonad. The attachment shows what Xorg.0.log will (apparently only occasionally) contain.
Comment by Andreas (misc) - Monday, 28 March 2011, 18:21 GMT
Whoops, there it is.
   Xorg.log (1.7 KiB)
Comment by Bogdan (JokerBoy) - Monday, 28 March 2011, 18:59 GMT Comment by Gábor (Arpione) - Wednesday, 13 April 2011, 11:28 GMT
I can confirm this with Openbox. Tested with sakura and terminator. Only transparent windows with borders stop graphics update, transparent and borderless windows don't.

Tested with:
kernle26: 2.6.38.2-1
nvidia: 270.30-4, 270.41.03-1
Comment by Armando M. Baratti (ambaratti) - Thursday, 14 April 2011, 02:20 GMT
The same here using lxde + openbox.

It seems to affect terminals that use vte (tested with xfce's terminal, lxterminal).
Terminals that don't use vte worked fine (tested with xterm, mrxvt, urxvt from package rxvt-unicode ).
Using transparent window for xfce's terminal and urxvt.

Here, after resizing, but before freezing, the screen blinks.
Horizontal resizing cause freezings every time.
Vertical resizings, if done carefully (slowly), not.

Using xfce as my DE and xfce's terminal, the problem does not occurs.

I'm not using testing.
Changing font to monospace doesn't fix it for me.

arch=i686
kernel26 2.6.38.2-1
nvidia 270.41.03-1
nvidia-utils 270.41.03-1
vte 0.26.2-1
lxterminal 0.1.9-1
terminal 0.4.7-1
Comment by Aurelieng (aurelieng) - Friday, 15 April 2011, 05:05 GMT
Same problem here on x64 with:

kernel26 2.6.38.2-1
nvidia 270.41.03-1
nvidia-utils 270.41.03-1
xf86-input-evdev 2.6.0-3
xf86-input-keyboard 1.6.0-2
xf86-input-mouse 1.7.0-2
xf86-input-synaptics 1.4.0-2
xkeyboard-config 2.2.1-1
xorg-server 1.10.0.902-1
xorg-server-common 1.10.0.902-1
xorg-server-xvfb 1.10.0.902-1

Interestingly, this problem is solved by downgrading the following packages:
xf86-input-evdev 2.6.0-2
xf86-input-keyboard 1.6.0-1
xf86-input-mouse 1.7.0-1
xf86-input-synaptics 1.4.0-1
xkeyboard-config 2.1-1
xorg-server 1.9.4.901-1
xorg-server-common 1.9.4.901-1
xorg-server-xvfb 1.9.4.901-1


Additionnaly, since I have a logitech mouse, I recompiled xorg-server 1.10.0.902-1 with a QUEUE_SIZE of 4096 in mi/mieq.c (see the two links posted above by Bogdan, https://bugs.archlinux.org/task/23381#comment74114), X does not freeze anymore, but a lot of randomly moving and randomly colored pixels start to appear on the screen. Their number increase until the computer is restarted (strangely, restarting X is not enough). It might be a different issue, though.

Comment by paul (poil) - Friday, 15 April 2011, 09:13 GMT
Same here on x64 + openbox + lxde

confirmed it is fixed by:
downgraded to xorg-server 1.9.4.901-1 and xf86-input-evdev 2.6.0-2.
appears to be ok with this combination.
Comment by paul (poil) - Friday, 15 April 2011, 13:12 GMT
Sorry double posted by mistake
Comment by Jan de Groot (JGC) - Friday, 15 April 2011, 14:46 GMT
Fun to see all these "me too" notifications, but this really doesn't help anything. The only one who can fix this bug is Nvidia. Stop adding stupid comments.
As for the QUEUE_SIZE "fix": that just hides the problem. The real problem is a buggy driver that freaks out and causes a filled up event queue.
Comment by Diego Viola (diegoviola) - Sunday, 17 April 2011, 04:10 GMT
Same problem here on Arch Linux (x86-64).

nvidia 270.41.03-1
kernel26 2.6.38.2-1
xorg-server 1.10.1-1

GeForce 9500 GT

The problem happens when I resize konsole on KDE 4.6.2.
Comment by Armando M. Baratti (ambaratti) - Thursday, 21 April 2011, 14:16 GMT
As I think 'all these "me too" notifications' provides *important* bits of information to help in solving the problem (and I judge it's a somewhat relevant one not being able to resize a terminal), I'll add some more "stupid comments":

nvidia 270.41.06, doesn't solve the problem.

Maybe the problem could not be a buggy driver.
Maybe the problem could be with vte (since it seems to occur only on vte based terminals).
Maybe the problem have anything to do with changes on kernel 2.6.38.
Maybe it's a conjunction of factors.

I don't know. I don't have the technical expertise on kernel or video drives to understand it.
What I know is that just waiting passively for the problem to solve by itself, don't seems the best thing to do.

The bug was already posted on nvidia's bug tracker? (I could not found one on their site).
Comment by Jan de Groot (JGC) - Thursday, 21 April 2011, 14:35 GMT
The point is that only nvidia can debug this problem, as they're the only ones with all the debugging information. Nvidia drivers replace half of the graphic stack inside Xorg, so there's no way someone without nvidia sources can debug this problem. The nvnews forums are filled quite well with this problem, but so far no nvidia employee responded to any of those threads.

As for the useless comments: almost everyone is posting the same "solution", which is not a real solution at all. I see this a lot on the Ubuntu bugtracker: lots of people saying the same or just adding "me too". When we hit a bug that exists in Ubuntu, that bug will show up in google results when we try to search for an error message, but no solution can be found because scrolling 100+ "me too" messages is not productive.
Comment by James Jones (jajones) - Thursday, 21 April 2011, 20:53 GMT
NVIDIA is aware of this problem, and we have reproduced it internally. Thanks for finding out downgrading X components works around the issue. That will help us investigate.

We do monitor the nvnews.net forums and track bugs reported there, but we don't always have time to post replies to every issue.
Comment by Giovanni Condello (nanomad) - Saturday, 30 April 2011, 14:55 GMT
Can anyone provide a link to the older xorg packages?
Comment by Bogdan (JokerBoy) - Saturday, 30 April 2011, 14:57 GMT
http://catalyst.apocalypsus.net/repo/xorg19

but you'll have to downgrade your nvidia driver as well.
Comment by Alexey Alekseev (LinuxUser) - Saturday, 30 April 2011, 18:00 GMT Comment by Gábor (Arpione) - Saturday, 30 April 2011, 18:11 GMT
For me it was enough to downgrade xorg-server, xorg-server-common and xf86-input-evdev. The kernel and nvidia related packages are all upgraded to latest stable.
Comment by Giovanni Condello (nanomad) - Saturday, 30 April 2011, 19:20 GMT
Downgrading ONLY xorg-server, xorg-server-common and xf86-input-evdev worked for me too.

edit: Why the closure was requested? It's still not fixed AFAIK
Comment by Ryan Gillette (dabbill) - Saturday, 30 April 2011, 19:24 GMT
I didnt mean to hit that button :(
Comment by Sebastian Hörberg (zebh) - Saturday, 14 May 2011, 18:01 GMT
Wanted to confirm that I suffer from this bug as well.
But after I downgraded (as of today):
xorg-server
xorg-common
xf86-input-evdev
to the versions listed by Alexey Alekseev above, the issue seems to have been "fixed".

Kernel: 2.6.38.x (currently .6-2, but have had the issue with multiple revs)
Gfx: nVidia (blob: 270.41.03-1, nouveau: 0.0.16_git20110316-2 both from [extra])

Attaching backtrace from my Xorg.0.log
Comment by Joshua Reno (mrsaturn) - Friday, 20 May 2011, 22:37 GMT
my problem still exists on latest nvidia and the 275 beta.
Comment by Armando M. Baratti (ambaratti) - Saturday, 21 May 2011, 14:33 GMT
It was not fixed in nvidia 270.41.19.

Above I've said it seems to work on non-vte based terminals (like urxvt), but I was wrong.
It only works with urxvt if the terminal isn't using composition (transparency).

Tomorrow it'll be 2 months from the open of this ticket.
It seems to be a very tough one to nvidia to fix.
Comment by Jeff (jeffathehutt) - Sunday, 22 May 2011, 18:42 GMT
I can confirm that downgrading the xorg-server, xorg-server-common and xf86-input-evdev packages to the versions listed above fixed the problem for me. I was experiencing this bug with both Nvidia drivers and Nouveau drivers. Also, this bug seems to affect the latest Ubuntu as well, so it might not be Arch specific.

I have a GeForce GT 220. All software except the packages listed above are the latest versions.
Comment by Armando M. Baratti (ambaratti) - Tuesday, 31 May 2011, 01:04 GMT
The problem persists with xorg-server 1.10.2 (that fixed many bugs: http://lists.freedesktop.org/archives/xorg/2011-May/053143.html) .

nvidia, now it's your turn.
Comment by James Jones (jajones) - Tuesday, 31 May 2011, 22:47 GMT
This is a bug in the NVIDIA X driver code that was exposed by a change of behavior in X server 1.10. Commit b89e6dbdfbb50e3b5bc7fcb7eccc397c467c92f8 to the X.org xserver codebase causes the X server to call into the NVIDIA acceleration layer recursively, which the driver does not handle correctly. I'm evaluating various potential fixes for inclusion in a future driver release.
Comment by Elvis Stansvik (estan) - Thursday, 02 June 2011, 11:32 GMT
Great that you're working on this James. As it is now I'm missing out on kernel/x upgrades as I have them blacklisted in pacman.conf because of this.

Elvis
Comment by James Jones (jajones) - Saturday, 04 June 2011, 06:51 GMT
The fix has been completed. This bug will be fixed in the next 275 series beta driver release.
Comment by Jelle van der Waa (jelly) - Sunday, 05 June 2011, 20:00 GMT Comment by Steffen Rilk (tuxfusion) - Sunday, 05 June 2011, 20:46 GMT
confirmed, latest nvidia beta + latest everything ( xorg , etc) solves this issue

UPDATE: shame on me/ nvidia : i resized an "special" window all good, however, resizing konsole -> CRASH , f*** , back to downgrading/holding packages
Comment by Elvis Stansvik (estan) - Monday, 06 June 2011, 10:39 GMT
Perhaps some of you brave souls who updated to the new beta and still have the problem could go through the trouble and report it to nvidia. Perhaps the fix was made in a haste and wasn't complete?

Some instructions for reporting a bug seems to be in the announcement of the 275 beta at http://www.nvnews.net/vbulletin/showthread.php?p=2441669

I'm not going to complain too much at nvidia this time, at least they eventually came around and released what should be a fix. Too bad the problem still seems to be there (?) for some. Anyone who upgraded who can confirm that it actually works for them, resizing konsole and everything? And if so, which versions of stuff you're running.

I would upgrade and try it out myself but I'm working on GSoC atm and really don't want to do anything that could jeopardize my system stability.
Comment by James Jones (jajones) - Monday, 06 June 2011, 14:36 GMT
This issue is regarding a freeze when resizing windows from my understanding. If you're seeing a crash (which I would take to mean X.org faults, giving a backtrace in the X.org log), that is most likely a separate issue. Please file a separate bug and whenever reporting bugs which you suspect to be the fault of the nvidia driver, attach the result of running nvidia-bug-report.sh, preferably after reproducing the issue. As noted in the beta release notes, the issue is most likely to get our attention if you post it on the NVIDIA Linux forum on nvnews.net, which we scan for new issues as time allows.

http://www.nvnews.net/vbulletin/forumdisplay.php?f=14

If you're still seeing graphics freezes or screen flickering when resizing konsole windows (these are the symptoms of the bug I fixed), please run nvidia-bug-report.sh after reproducing the issue and attach the resulting nvidia-bug-report.log.gz here so we can reproduce your system state and config.
Comment by James Eder (James_Eder) - Monday, 06 June 2011, 15:29 GMT
For me, the issue of resizing konsole windows is resolved with current xorg-server (1.10.2) and NVIDIA 275.09.04 beta. With previous drivers (270.41.19), the symptoms were consistently reproducible. So, fixed in 275.09.04 as far as I can tell.

Edit: I forgot to mention I'm using a GeForce GTS 250 on x86_64.
Comment by Gábor (Arpione) - Monday, 06 June 2011, 15:41 GMT
The bug is still present here. Screen flickers when resizing konsole, terminator or sakura and I had an Xorg crash when tried to resize konsole.
edit: same card as James' (GeForce GTS 250 on x86_64).
Comment by Alessandro Nakamuta (alessandro_ufms) - Monday, 06 June 2011, 15:53 GMT
I confirm that the issue has been fixed with 275.09.04 nvidia driver. Resize don't have artifacts and Maximize don't freeze the system.
Comment by James Jones (jajones) - Monday, 06 June 2011, 16:08 GMT
Gábor, please run nvidia-bug-report.sh and attach the resulting nvidia-bug-report.log.gz here. I can't debug the issue if I can't reproduce the failure, and I can't currently reproduce this issue so I need more information about the failing systems.
Comment by Gábor (Arpione) - Monday, 06 June 2011, 16:19 GMT
Here you go.
Comment by James Jones (jajones) - Monday, 06 June 2011, 16:26 GMT
Gábor, your log shows that you're still running the 275.09 driver. Only driver versions 275.09.04 and newer have the fix. Please update to the latest beta driver version and try again when you have a chance. The latest driver versions are always listed here:

http://www.nvnews.net/vbulletin/showthread.php?t=122606
Comment by Jan de Groot (JGC) - Monday, 06 June 2011, 16:32 GMT
Could uvesafb be the problem here? I don't know if that can interfere with the nvidia driver, but I would suggest disabling it and try again.
Comment by Alessandro Nakamuta (alessandro_ufms) - Monday, 06 June 2011, 16:33 GMT
No, I use uvesafb, and the last driver solve the problem here.
Comment by Gábor (Arpione) - Monday, 06 June 2011, 16:52 GMT
Sorry, I could swear I updated yesterday... After the update to 275.09.04 the flicker and crashes/freezes are gone.
Comment by Steffen Rilk (tuxfusion) - Monday, 06 June 2011, 16:54 GMT
@jajones, I mixed up 275.09 and 275.09.04 too, in that crowded folder of nvidia drivers. It indeed fixes all X crashes ! Thanks for sticking with us normal people =)
Comment by James Jones (jajones) - Monday, 06 June 2011, 17:42 GMT
Very good news. Thanks for following up!

Loading...