Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23067 - [kernel26] Reboot fails when using UEFI on ASUS P8H67-M LE

Attached to Project: Arch Linux
Opened by Chris Darnell (cedeel) - Sunday, 27 February 2011, 14:54 GMT
Last edited by Andrea Scarpino (BaSh) - Sunday, 15 May 2011, 21:17 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
  • Anonymous Submitter (2011-04-11)
Private No

Details

Description:
When booted through UEFI, rebooting fails but halt works as expected.

Additional info:
* kernel26 2.6.37.1-1

Steps to reproduce:
Boot with an UEFI bootloader, try rebooting.

Attached is the output shown when trying to reboot.
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Sunday, 15 May 2011, 21:17 GMT
Reason for closing:  Not a bug
Additional comments about closing:  see the last comment
Comment by Jelle van der Waa (jelly) - Wednesday, 30 March 2011, 20:06 GMT
also an issue with .38?
Comment by Anonymous Submitter - Saturday, 02 April 2011, 08:05 GMT
Please add 'reboot_type=k' to the kernel commandline in the bootloader menu and check whether reboot works. This might be a problem with the firmware rather than the kernel.
Comment by Chris Darnell (cedeel) - Saturday, 02 April 2011, 10:18 GMT
reboot_type=k didn't help.

Also, I didn't try .38 on Arch yet, but it didn't work on a Gentoo install I had. I'll make a install with [testing] to see if .38 solves this.
Comment by Jelle van der Waa (jelly) - Thursday, 14 April 2011, 21:33 GMT
is this issue still there? It looks like an upstream issue, please report it there.
Comment by Chris Darnell (cedeel) - Friday, 15 April 2011, 00:54 GMT
yes, this issue is still present. I'll report it upstream shortly.
Comment by Anonymous Submitter - Sunday, 08 May 2011, 12:33 GMT
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/721576 . Must be a problem with UEFI firmware rather than kernel. Still it is better to report it upstream (kernel). Suggested workaround - add "reboot=a,w" to the kernel command line ( http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=blob_plain;f=Documentation/x86/x86_64/boot-options.txt;hb=HEAD )

Hope this helps. I don't have any Sandy Bridge UEFI system to verify this problem and it doesn't occur with Tianocore EDK2 DUET UEFI firmware.

Loading...