Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#22604 - intel_uxa_prepare_access: bo map failed: Input/output error

Attached to Project: Arch Linux
Opened by Maxwell Draven (Ravenman) - Tuesday, 25 January 2011, 20:55 GMT
Last edited by Jan de Groot (JGC) - Tuesday, 12 June 2012, 21:40 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:

When KDM starts, I can't see the text box for login and password and I can see only half screen with the background color.

Additional info:
* package version(s)

kernel26 2.6.36.3-1 & kernel26 2.6.37-2

xf86-video-intel 2.13.0-4

intel-dri 7.8.2-3

libgl 7.8.2-3

kde 4.5.5-1

* config and/or log files etc.

I'm attaching some log files.

Steps to reproduce:

Install these packages version with one Intel Corporation 82946GZ/GL Integrated Graphics Controller.
This task depends upon

Closed by  Jan de Groot (JGC)
Tuesday, 12 June 2012, 21:40 GMT
Reason for closing:  No response
Additional comments about closing:  This is old. Probably already fixed.
Comment by Jan de Groot (JGC) - Tuesday, 25 January 2011, 23:20 GMT
Please update libgl and intel-dri to 7.9 from extra. Mixing older libgl/intel-dri packages with more recent kernels and libdrm versions can cause problems like these.
Comment by Maxwell Draven (Ravenman) - Wednesday, 26 January 2011, 15:02 GMT
I have tested with kernel 2.6.37-2, intel-dri-7.9.0.git20101207-2 & intel-dri-7.9-1, libgl-7.9.0.git20101207-2 & libgl-7.9-1, xf86-video-intel 2.13.0-4 and KDE 4.5.5-1 and I found the same message in the X.org log file, many times: "intel(0): intel_uxa_prepare_access: bo map failed: Input/output error".

I have tested with kernel 2.6.37-2, intel-dri-7.10-1, libgl-7.10-1, xf86-video-intel-2.14.0-1 and KDE 4.5.5-1 and I found this message in the X.org log file, many times: "intel(0): Failed to submit batch buffer, expect rendering corruption or even a frozen display: Invalid argument.". I'll try report it to you in this bug report: https://bugs.archlinux.org/task/17920, but you don't reopen it.

Can you change the severity to High?. Maybe is Low for you, but I can't login to my machine for to work. Thanks.
Comment by Maxwell Draven (Ravenman) - Monday, 31 January 2011, 15:44 GMT
I have tested with kernel 2.6.37-5, intel-dri-7.10.1, libgl-7.10.1, xf86-video-intel 2.14.0-1 and KDE 4.6.0-1 and I found the same message in the X.org log file, many times: "intel(0): intel_uxa_prepare_access: bo map failed: Input/output error".

I'm working again (I have some problems with cursor, window and pages redrawing) with kernel 2.6.37-5, intel-dri-7.9.1, libgl-7.9.1, xf86-video-intel 2.12.0-1 and KDE 4.6.0-1, right now.
Comment by Jesse Young (jlyo) - Tuesday, 01 February 2011, 01:15 GMT
After doing a pacman -Syu today I get the repeating
(EE) intel(0): Failed to submit batch buffer, expect rendering corruption or even a frozen display: Invalid argument.
error. Downgrading to xf86-video-intel-2.13.0 fixes it. Versions 2.13.90[123] and 2.14.0 give me the error.
I'm running kernel26-2.6.32-lts.

Hardware:
Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
Intel(R) Arrandale video card
on a Thinkpad T410
Comment by Maxwell Draven (Ravenman) - Tuesday, 08 February 2011, 16:37 GMT
I have tested with kernel 2.6.37-5, intel-dri-7.10.0.git20110206-2, libgl-7.10.0.git20110206-2, xf86-video-intel 2.14.0-1 and KDE 4.6.0-1 and I found the same message in the X.org log file, many times: "intel(0): intel_uxa_prepare_access: bo map failed: Input/output error".
Comment by Jan de Groot (JGC) - Thursday, 17 February 2011, 15:32 GMT
Status with latest libdrm from extra and latest xf86-video-intel from testing?
Comment by Maxwell Draven (Ravenman) - Friday, 18 February 2011, 21:52 GMT
I have tested with kernel 2.6.37-6, libdrm-2.4.23-2, intel-dri-7.10.0.git20110215-1, libgl-7.10.0.git20110215-1, mesa-7.10.0.git20110215-1, xf86-video-intel-2.14.0-2 and KDE 4.6.0-1 and I found the same message in the X.org log file, many times: "intel(0): intel_uxa_prepare_access: bo map failed: Input/output error" and besides one new message: "intel(0): failed to set cursor: Input/output error".
Comment by Brice (eMerzh) - Wednesday, 13 April 2011, 09:43 GMT
I have the same problems since my last update.
my desktop work fine for a couple of hours then it freeze and i can't restart it, just reboot.

software updates that may be related are :

[2011-04-12 09:54] upgraded libdrm (2.4.23-2 -> 2.4.25-1)
[2011-04-12 09:54] upgraded libgl (7.10.1-1 -> 7.10.2-2)
[2011-04-12 09:54] upgraded intel-dri (7.10.1-1 -> 7.10.2-2)
[2011-04-12 09:54] upgraded libdc1394 (2.1.2-2 -> 2.1.3-1)
[2011-04-12 09:54] upgraded libtasn1 (2.8-1 -> 2.9-1)
[2011-04-12 09:54] upgraded libxfixes (4.0.5-1 -> 5.0-1)
[2011-04-12 09:54] upgraded mesa (7.10.1-1 -> 7.10.2-2)
[2011-04-12 09:54] upgraded xf86-input-evdev (2.6.0-2 -> 2.6.0-3)
[2011-04-12 09:54] upgraded xf86-video-intel (2.14.0-3 -> 2.14.903-1)
[2011-04-12 09:54] upgraded xf86-video-vesa (2.3.0-4 -> 2.3.0-5)
[2011-04-12 09:54] upgraded xkeyboard-config (2.1-1 -> 2.2.1-1)
[2011-04-12 09:54] upgraded xorg-server-common (1.9.4.901-1 -> 1.10.0.902-1)
[2011-04-12 09:54] upgraded xorg-server (1.9.4.901-1 -> 1.10.0.902-1)


Comment by Sébastien (sebcactus) - Wednesday, 13 April 2011, 21:42 GMT
I have the same problem.
Especially occurs when playing flash objects in firefox4

Comment by Brice (eMerzh) - Thursday, 14 April 2011, 13:32 GMT
i' ve reverted
xf86-input-evdev (2.6.0-3 -> 2.6.0-2)
xf86-video-intel (2.14.903-1 -> 2.14.0-3)
xf86-video-vesa (2.3.0-5 -> 2.3.0-4)
xorg-server-common (1.10.0.902-1 -> 1.9.4.901-1)
xorg-server (1.10.0.902-1 -> 1.9.4.901-1)

that didn't do the tric so i've also reverted

libdrm (2.4.25-1 -> 2.4.23-2)
libgl (7.10.2-2 -> 7.10.1-1)
intel-dri (7.10.2-2 -> 7.10.1-1)
kernel26 (2.6.38.2-1 -> 2.6.37.5-1)
kernel26-headers (2.6.38.2-1 -> 2.6.37.5-1)
libdc1394 (2.1.3-1 -> 2.1.2-2)
libtasn1 (2.9-1 -> 2.8-1)
libxfixes (5.0-1 -> 4.0.5-1)
mesa (7.10.2-2 -> 7.10.1-1)
xextproto (7.2.0-1 -> 7.1.2-1)
xkeyboard-config (2.2.1-1 -> 2.1-1)

And now it seems to works fine.
Comment by Sébastien (sebcactus) - Thursday, 14 April 2011, 13:43 GMT
I checked in the logs (dmesg) and found the following:
Apr 14 14:02:04 localhost kernel: [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
Apr 14 14:02:04 localhost kernel: [drm:i915_do_wait_request] *ERROR* i915_do_wait_request returns -11 (awaiting 921291 at 921193, next 921292)
Apr 14 14:02:06 localhost kernel: [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
Apr 14 14:02:06 localhost kernel: [drm:i915_reset] *ERROR* Failed to reset chip.



I tried first to revert
xf86-input-evdev (2.6.0-3 -> 2.6.0-2)
xf86-video-intel (2.14.903-1 -> 2.14.0-3)
xf86-video-vesa (2.3.0-5 -> 2.3.0-4)
xorg-server-common (1.10.0.902-1 -> 1.9.4.901-1)
xorg-server (1.10.0.902-1 -> 1.9.4.901-1)

-> still had the errors.

Then I reverted
mesa (7.10.2-2 -> 7.10.1-1)
libgl (7.10.2-2 -> 7.10.1-1)
intel-dri (7.10.2-2 -> 7.10.1-1)
libdrm (2.4.25-1 -> 2.4.23-2)

-> still had errors

finally:
kernel26 (2.6.38.2-1 -> 2.6.37.5-1)
kernel26-headers (2.6.38.2-1 -> 2.6.37.5-1)

> seems ok
Comment by Sébastien (sebcactus) - Sunday, 17 April 2011, 08:31 GMT
I updated all packages yesterday, BUT kernel26 and kernel26-headers: did not have any pb so far

So I guess the pb is from kernel26-2.6.38.2-1
Comment by Sébastien (sebcactus) - Sunday, 17 April 2011, 08:36 GMT Comment by Brice (eMerzh) - Wednesday, 20 April 2011, 09:29 GMT
I think it's 2 different pbms.

i've updatee everything except the kernel and then i still have the pbm :

[ 34.355] (WW) intel(0): intel_uxa_prepare_access: bo map failed: Input/output error
[ 34.355] (WW) intel(0): intel_uxa_prepare_access: bo map failed: Input/output error

.. so i've revert all packages as previously mentioned.

Comment by Sébastien (sebcactus) - Monday, 09 May 2011, 19:04 GMT
Updated everything today and I have no pb:

kernel26-2.6.38.5-1
kernel26-headers-2.6.38.5-1
libxext-1.3.0-1
Comment by Bruce (1080p) - Wednesday, 11 May 2011, 04:33 GMT
I can also confirm this no longer looks like an issue. I issued pacman -Syu after my box froze up and I saw some bad looking errors.log and Xorg.0.log.old which was 700MB :S

kernel26-2.6.38.5-1
kernel26-headers-2.6.38.5-1
libxext-1.3.0-1

Hasn't frozen up all day!
Comment by Andrés Musetti (amusetti) - Wednesday, 11 May 2011, 19:13 GMT
I can confirm that this bug reappeared with the latest kernel update (kernel26-2.6.38.6-1).
I reverted to kernel26-2.6.38.5-1 and the problem disappeared.
Comment by Andrés Musetti (amusetti) - Wednesday, 11 May 2011, 19:59 GMT
I can confirm that this bug reappeared with the latest kernel update (kernel26-2.6.38.6-1).
I reverted to kernel26-2.6.38.5-1 and the problem disappeared.
Comment by Jelle van der Waa (jelly) - Tuesday, 24 May 2011, 16:18 GMT
please make a bugreport upstream
Comment by Allan McRae (Allan) - Saturday, 02 June 2012, 12:18 GMT
Status?

Loading...