Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#22080 - [mkinitcpio] /init crashes on whitespaces in kernel parameters line

Attached to Project: Arch Linux
Opened by Sergej Pupykin (sergej) - Monday, 13 December 2010, 11:45 GMT
Last edited by Jan de Groot (JGC) - Monday, 11 April 2011, 12:12 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Thomas Bächler (brain0)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Steps to reproduce:

try to pass "video=9-pin DIN-1:1024x768-24@60e" to kernel.

Easiest way to fix it - ignore parameters with " in /init. (patch attached)
This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 11 April 2011, 12:12 GMT
Reason for closing:  Fixed
Comment by Gerardo Exequiel Pozzi (djgera) - Monday, 13 December 2010, 14:13 GMT
  • Field changed: Status (Unconfirmed → Assigned)
  • Field changed: Severity (Critical → High)
  • Task assigned to Thomas Bächler (brain0)
In someway this is a duplicate of  FS#13900 

@Sergej: you can add at end: # video...
Comment by Thomas Bächler (brain0) - Monday, 13 December 2010, 14:33 GMT
Oh yes, this is a long-standing problem. Your solution seems fine. I wonder what other systems do here.

One funny thing: The kernel actually exports some of the variables from the command line to init - but not root= (I don't understand the rationale behind it though).
Comment by Thomas Bächler (brain0) - Sunday, 10 April 2011, 20:32 GMT
Please confirm that mkinitcpio 0.6.10 fixes the problem.

Loading...