Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#21291 - [kde] VLC can't play a remote files directly

Attached to Project: Arch Linux
Opened by Alexander (heaven) - Sunday, 17 October 2010, 12:38 GMT
Last edited by Ronald van Haren (pressh) - Wednesday, 10 August 2011, 07:16 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ronald van Haren (pressh)
Andrea Scarpino (BaSh)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
I can't play remote file in VLC directly. When i click on a remote media file in dolphin, it starts to download it firstly. But dolphin can play this file directly in its information panel

Steps to reproduce:
Just open a remote (smb in my case) folder with media files and try to open it in VLC.
This task depends upon

Closed by  Ronald van Haren (pressh)
Wednesday, 10 August 2011, 07:16 GMT
Reason for closing:  Fixed
Additional comments about closing:  As per comment, fixed in KDE 4.7.
Comment by Ionut Biru (wonder) - Sunday, 17 October 2010, 13:02 GMT
i don't consider this being a bug in vlc but in kde/dolphin. kinda sucks because is doing that only because in in vlc.desktop Exec=vlc %U

try changing fom %U to %F
Comment by Alexander (heaven) - Sunday, 17 October 2010, 13:13 GMT
> try changing fom %U to %F
It doesn't help.
Comment by Alexander (heaven) - Monday, 18 October 2010, 05:45 GMT
OMG, link from kmail opens by the same way. KDE tries to download the page into the tmp folder and then open it in firefox...
This doesn't happen with all url's, but only with url's like this https://bugs.kde.org/show_bug.cgi?id=185881 that I have in mails, received from bugs.kde.org
Comment by Alexander (heaven) - Monday, 18 October 2010, 09:10 GMT
I clicked on this link https://bugs.archlinux.org/task/21294 in kmail and you can see what happened (in firefox address bar).
Comment by Caspar Verhey (casparv) - Sunday, 31 October 2010, 11:15 GMT
It is also reported here: https://bugs.kde.org/show_bug.cgi?id=253547

It seems all .desktop-files should get an extra line "X-KDE-Protocols=http,ftp,smb" or similar, to provide the protocols they support natively. According to http://blog.jfdesignnet.com/?p=1281 it defaults to "X-KDE-Protocols=http,ftp". His solution is adding smb to the default list, but IMHO it's not the proper way, as http://reviewboard.kde.org/r/5280/diff/ explains the bug they were trying to fix in the first place.

Comment by Caspar Verhey (casparv) - Sunday, 31 October 2010, 11:19 GMT
According to the Wiki Reporting_Bug_Guidelines, the omission in the .desktop would not be an Arch-bug, but it should be submitted upstream:

"A package which does not include a .desktop file or icons or other freedesktop stuff. This is not a bug if such files are not included in the source tarball, and this must be requested as a feature request upstream. If such files are provided by upstream but not used in the package then this is a bug."

Does anyone know how to do this? I am new at this.
Comment by Andrea Scarpino (BaSh) - Tuesday, 02 November 2010, 08:53 GMT
the link bug in kmail is fixed in KDE 4.5.3 (release date is today)
Comment by Ionut Biru (wonder) - Thursday, 04 November 2010, 08:26 GMT
still an issue?
Comment by Alexander (heaven) - Thursday, 04 November 2010, 09:08 GMT
Yep, it is still actual for me, even after update KDE to 4.5.3.
Comment by Caspar Verhey (casparv) - Wednesday, 10 November 2010, 12:42 GMT
In KMail, I am experiencing no problems opening http-links, so the KMail-bug can be fixed. However, applications like VLC and MPlayer still aren't opening files directly.

By the way, I realized that to fix this problem, you have to set both the %U-parameter (usually replace %F by %U) and the X-KDE-Protocols in «application».desktop, e.g.:

Exec=mplayer -really-quiet %U
X-KDE-Protocols=http,ftp,smb
Comment by Andrea Scarpino (BaSh) - Thursday, 09 December 2010, 13:07 GMT
therefore the bug is in MPlayer and VLC?
Comment by Caspar Verhey (casparv) - Thursday, 09 December 2010, 16:03 GMT
BaSh: I wouldn't call it a bug, VLC and MPlayer are just not working optimally with KDE (and probably other applications too).

They support certain protocols themselves, but because this is not listed in their respective .desktop-files with the "X-KDE-Protocols"-variable, KDE will download all files to local disk before starting VLC or MPlayer.

Btw, this only matters for SMB, because KDE will default to "X-KDE-Protocols=http,ftp". This used to default to "X-KDE-Protocols=http,ftp,smb", hence the current problems.
Comment by Alexander (heaven) - Tuesday, 09 August 2011, 17:43 GMT
Seems that now all works fine in KDE 4.7, at least with VLC.

Loading...