Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#21007 - [vte] - TERM environment variable needs set

Attached to Project: Arch Linux
Opened by Alois Nespor (anespor) - Thursday, 30 September 2010, 19:52 GMT
Last edited by Ionut Biru (wonder) - Friday, 08 June 2012, 23:08 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Ionut Biru (wonder)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:


Additional info:
[alois@lenovo ~]$ su
Password:
[root@lenovo alois]# mc
TERM environment variable needs set.
[root@lenovo alois]#

packages:
roxterm 1.19.1-1
vte 0.26.0-1


Steps to reproduce:
run "mc" under roxterm

previous version of "vte" works without problem with roxterm
This task depends upon

Closed by  Ionut Biru (wonder)
Friday, 08 June 2012, 23:08 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Reason for request: not a VTE bug, see my comment at the bottom
Comment by Ionut Biru (wonder) - Thursday, 30 September 2010, 19:55 GMT Comment by Alois Nespor (anespor) - Thursday, 30 September 2010, 20:13 GMT
can be fixed when added "export TERM=xterm" to "/etc/profile"
Comment by Ionut Biru (wonder) - Friday, 01 October 2010, 10:32 GMT
can you try to see if is working by reverting this ?

http://git.gnome.org/browse/vte/commit/?h=vte-0-26&id=0574bcfbd5c5925458ecdea0e6bbac6d65e30efc

if you don't know how, let me know and i'll compile you a package. don't forget to specify if you are on x86_64 or i686
Comment by Alois Nespor (anespor) - Friday, 01 October 2010, 11:00 GMT
yes, reverting works!! x86_64

(I remove "export TERM=xterm" from /etc/profile, and run "source /etc/profile")

I used patch from git with "patch -Rp1 -i ../revert.patch" and compile vte-0.26 again. Logout, log in.

Work now fine as old version 0.24.3
Comment by Ionut Biru (wonder) - Friday, 01 October 2010, 16:36 GMT
maybe you had in /etc/profile still the export. on bugzilla somebody tried that and is not fixed
Comment by Alois Nespor (anespor) - Friday, 01 October 2010, 17:15 GMT
yes, i have declare -x TERM="xterm", but is not via "export TERM=xterm" in /etc/profile.
How undeclare TERM?
Comment by Ionut Biru (wonder) - Friday, 01 October 2010, 19:25 GMT
please remove any workaround that you made and reboot. this is the best test that you can do.

i want to be sure is not exported anymore
Comment by Alois Nespor (anespor) - Friday, 01 October 2010, 19:38 GMT
i have no export TERM=xterm in /etc/profile, and i reboot ntb 2x, but this solution (patched vte) works:


[alois@lenovo ~]$ mc
TERM environment variable needs set.
[alois@lenovo ~]$ su
Heslo:
[root@lenovo alois]# pacman -Qi vte
Jméno : vte
Verze : 0.26.0-1
URL : http://www.gnome.org
Licence : LGPL
Skupiny : Nic
Poskytuje : Nic
Závisí na : gtk2>=2.22.0
Volitelné záv. : Nic
Požadovaný : roxterm
Konfliktní s : Nic
Nahrazuje : Nic
Vel. instalace : 3124,00 K
Zabalil : Ionut Biru <ibiru@archlinux.org>
Architektura : x86_64
Datum sestavení: Ne 26. září 2010, 21:10:58 CEST
Datum instalace: Pá 1. říjen 2010, 21:34:10 CEST
Důvod instalace: Výslovně nainstalován
Instal. skript : Ne
Popis : Virtual Terminal Emulator library

[root@lenovo alois]# pacman -U /home/ARCH/NEW/vte-0.26.0-1.1-x86_64.pkg.tar.xz
řeší se závislosti..
kontrolují se interní konflikty...

Cíle (1): vte-0.26.0-1.1

Celková velikost stahování: 0,00 MB
Celková velikost instalace: 3,05 MB

Pokračovat v instalaci? [A/n]
kontroluje se integrita balíčků...
(1/1) kontrola konfliktů souborů [########################################] 100%
(1/1) aktualizace vte [########################################] 100%
[root@lenovo alois]#

Closed all other roxterm terminals, run roxterm again and can run mc. Works for me without /etc/profile hack.
Comment by Alois Nespor (anespor) - Friday, 01 October 2010, 19:40 GMT
patched vte-0.26 with "patch -Rp1 -i ../revert.patch"
Comment by Ulf Winkelvos (uwinkelvos) - Saturday, 02 October 2010, 03:09 GMT
reverting the patch does not work for me. guake still fails here on x86_64.
Comment by Borromini (Borromini) - Saturday, 02 October 2010, 15:01 GMT
Just chiming in, got this problem too, as might be obvious from https://bbs.archlinux.org/viewtopic.php?id=105906

The error message I am getting is the TERM value is set to "dumb", which cripples a lot of apps (irssi amongst others).
Comment by Ionut Biru (wonder) - Saturday, 02 October 2010, 19:53 GMT
i had prepared packages for 0.25.1, 0.25.90 and 0.25.91. lets start bisecting to find it.

http://pkgbuild.com/~ioni/vte/

start from 0.25.1 and upgrade until it breaks it
Comment by Ulf Winkelvos (uwinkelvos) - Saturday, 02 October 2010, 21:01 GMT
0.24.3 works.
0.25.1 does not.

edit: should be somewhere between 0.23.5 and 0.25.1
Comment by Ulf Winkelvos (uwinkelvos) - Sunday, 03 October 2010, 00:09 GMT
bisected and isolated to commit: http://git.gnome.org/browse/vte/commit/?id=dd08c50c6a6dd4349d3cbce271ddf4b741db8861 It's a pretty big one and contains probably pretty fundamental changes.
Comment by Ionut Biru (wonder) - Sunday, 03 October 2010, 00:11 GMT
you should report on bugzilla. i think is more a problem with the terminals that haven't been updated to use the new stuff
Comment by Ulf Winkelvos (uwinkelvos) - Sunday, 03 October 2010, 00:39 GMT
done. lets see what Christian says about this.
Comment by Dan McGee (toofishes) - Monday, 04 October 2010, 23:13 GMT
The XFCE 'terminal' package also exhibits this breakage. It defaults TERM now to 'linux' regardless of what you have set in the preferences. Quite annoying for them to break this fundamental stuff...
Comment by Ionut Biru (wonder) - Friday, 08 October 2010, 20:42 GMT
check out vte-0.26.0-4
Comment by Ulf Winkelvos (uwinkelvos) - Saturday, 09 October 2010, 16:37 GMT
works fine with guake.
Comment by Dan McGee (toofishes) - Thursday, 28 October 2010, 21:17 GMT
Still broken with XFCE Terminal.

Right Click > Preferences > Advanced Tab > $TERM setting: --> 'xterm-256color'

Then restart, and type in shell:
$ echo $TERM
xterm
Comment by Ionut Biru (wonder) - Thursday, 28 October 2010, 21:25 GMT Comment by Dan McGee (toofishes) - Thursday, 28 October 2010, 21:28 GMT
Yeah, I actually thought I was clicking the "request reopen" button and not actually reopening it so you could do what you want, but I at least think some people might care that it isn't fully resolved. I also don't have a GNOME bugzilla account, so this is going to take a lot of effort for me to report. :)
Comment by Kyle Keen (keenerd) - Saturday, 18 June 2011, 05:07 GMT
Does this still apply? VTE is 0.28.0 now and I cannot reproduce the bug.
Comment by Dan McGee (toofishes) - Monday, 20 June 2011, 05:23 GMT
I'm still seeing the behavior I saw in #comment67874 ('xterm' instead of 'xterm-256color' as set in the preferences).
Comment by Alois Nespor (anespor) - Friday, 26 August 2011, 15:26 GMT
vte 0.28 works (Gnome3)
Comment by Daniel Micay (thestinger) - Wednesday, 23 May 2012, 12:43 GMT
This isn't a bug in VTE, it's a bug in some terminals like Xfce's Terminal in how they use the VTE API.

You need to set TERM with vte_pty_set_term() on a VtePty object before starting VTE. An existing TERM variable in the environment is ignored, because then it would be set properly when starting from another terminal.

vte_terminal_fork_command_full() doesn't let you run vte_pty_set_term() (since it creates it's own pty object, and it has to be set before starting it). That's possibly a bug, but could also be called a design decision (it's just a high-level convenience function). So the Xfce devs would have to switch to the slightly lower level way of starting up VTE, otherwise they're stuck with $TERM being xterm.

https://bugzilla.gnome.org/show_bug.cgi?id=640940 <- For reference, this was a bug report by an Xfce developer about it, and the response was basically NOTABUG/WONTFIX, but the issue never had the status changed.

Loading...